summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-21 10:42:59 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-21 10:42:59 +0000
commitc58987f9cf41e4635785a9b1974e43387531ac42 (patch)
tree33f80204cf96d26ba56cfd5d0f2aa0dc2908c19a /sci-misc
parentConvert to EAPI1 and force correct slot of both jpeg and libpng (diff)
downloadgentoo-2-c58987f9cf41e4635785a9b1974e43387531ac42.tar.gz
gentoo-2-c58987f9cf41e4635785a9b1974e43387531ac42.tar.bz2
gentoo-2-c58987f9cf41e4635785a9b1974e43387531ac42.zip
Fixes for PYTHOON ABI, #316243
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/vitables/ChangeLog7
-rw-r--r--sci-misc/vitables/vitables-2.0.ebuild19
2 files changed, 17 insertions, 9 deletions
diff --git a/sci-misc/vitables/ChangeLog b/sci-misc/vitables/ChangeLog
index 4eeb21989e27..98947d1b75f6 100644
--- a/sci-misc/vitables/ChangeLog
+++ b/sci-misc/vitables/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-misc/vitables
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/vitables/ChangeLog,v 1.3 2009/09/29 15:19:50 spock Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/vitables/ChangeLog,v 1.4 2010/05/21 10:42:59 jlec Exp $
+
+ 21 May 2010; Justin Lecher <jlec@gentoo.org> vitables-2.0.ebuild:
+ Fixes for PYTHOON ABI, #316243
29 Sep 2009; Michał Januszewski <spock@gentoo.org> vitables-2.0.ebuild:
Fix installation of icon and .desktop file.
diff --git a/sci-misc/vitables/vitables-2.0.ebuild b/sci-misc/vitables/vitables-2.0.ebuild
index fd7c7f589676..24587961375f 100644
--- a/sci-misc/vitables/vitables-2.0.ebuild
+++ b/sci-misc/vitables/vitables-2.0.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/vitables/vitables-2.0.ebuild,v 1.3 2009/09/29 15:19:50 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/vitables/vitables-2.0.ebuild,v 1.4 2010/05/21 10:42:59 jlec Exp $
EAPI="2"
-NEED_PYTHON="2.5"
-# Will work with 2.4 if you manually install the uuid package
+
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils eutils
@@ -17,13 +18,17 @@ SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="doc examples"
-DEPEND=">=dev-python/pytables-2.0
+DEPEND="
+ >=dev-python/pytables-2.0
dev-python/PyQt4[X]" # FIXME: check if any other useflags are needed
RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
S="${WORKDIR}/ViTables-${PV}"
src_prepare() {
epatch "${FILESDIR}"/${P}-doc-examples.patch
+ distutils_src_prepare
}
src_install() {
@@ -33,10 +38,10 @@ src_install() {
if use examples; then
insinto /usr/share/doc/${P}/examples
- doins -r examples/*
+ doins -r examples/* || die
fi
if use doc; then
- dodoc doc/*
+ dodoc doc/* || die
fi
}