summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-30 01:45:42 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-30 01:45:42 +0000
commit8211d5fe3c06231eb5ce146a43bf162a8e437cf1 (patch)
tree8d934d2beaa2ac5ceb348ff1c9f56d1312750165 /sci-physics/camfr
parentMask another boost python reverse depedency (diff)
downloadgentoo-2-8211d5fe3c06231eb5ce146a43bf162a8e437cf1.tar.gz
gentoo-2-8211d5fe3c06231eb5ce146a43bf162a8e437cf1.tar.bz2
gentoo-2-8211d5fe3c06231eb5ce146a43bf162a8e437cf1.zip
Adapt new boost python scheme, bug #401391
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/camfr')
-rw-r--r--sci-physics/camfr/ChangeLog10
-rw-r--r--sci-physics/camfr/camfr-20070717-r2.ebuild6
-rw-r--r--sci-physics/camfr/camfr-20070717-r3.ebuild81
3 files changed, 92 insertions, 5 deletions
diff --git a/sci-physics/camfr/ChangeLog b/sci-physics/camfr/ChangeLog
index 0d5e25d645db..e80aa392beee 100644
--- a/sci-physics/camfr/ChangeLog
+++ b/sci-physics/camfr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/camfr
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/ChangeLog,v 1.21 2011/06/21 14:41:10 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/ChangeLog,v 1.22 2012/01/30 01:45:42 bicatali Exp $
+
+*camfr-20070717-r3 (30 Jan 2012)
+
+ 30 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ camfr-20070717-r2.ebuild, +camfr-20070717-r3.ebuild:
+ Adapt new boost python scheme, bug #401391
21 Jun 2011; Justin Lecher <jlec@gentoo.org> camfr-20070717-r2.ebuild:
Add dependency on virtual/fortran
diff --git a/sci-physics/camfr/camfr-20070717-r2.ebuild b/sci-physics/camfr/camfr-20070717-r2.ebuild
index 16754c01f749..d4152176414f 100644
--- a/sci-physics/camfr/camfr-20070717-r2.ebuild
+++ b/sci-physics/camfr/camfr-20070717-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/camfr-20070717-r2.ebuild,v 1.4 2011/06/21 14:41:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/camfr-20070717-r2.ebuild,v 1.5 2012/01/30 01:45:42 bicatali Exp $
EAPI=2
@@ -25,7 +25,7 @@ RDEPEND="
virtual/fortran
dev-libs/blitz
- dev-libs/boost[python]
+ <dev-libs/boost-1.48[python]
dev-python/imaging[tk]
dev-python/matplotlib
sci-libs/scipy
diff --git a/sci-physics/camfr/camfr-20070717-r3.ebuild b/sci-physics/camfr/camfr-20070717-r3.ebuild
new file mode 100644
index 000000000000..2c50a3119b73
--- /dev/null
+++ b/sci-physics/camfr/camfr-20070717-r3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/camfr-20070717-r3.ebuild,v 1.1 2012/01/30 01:45:42 bicatali Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="tk"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils fortran-2 distutils
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="true"
+
+DESCRIPTION="Full vectorial Maxwell solver based on eigenmode expansion"
+HOMEPAGE="http://camfr.sourceforge.net/"
+SRC_URI="mirror://sourceforge/camfr/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/fortran
+ dev-libs/blitz
+ >=dev-libs/boost-1.48[python]
+ dev-python/imaging[tk]
+ dev-python/matplotlib
+ sci-libs/scipy
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/scons"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${P/-/_}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-python.patch
+ cp "${FILESDIR}"/machine_cfg.py.gentoo machine_cfg.py || die
+ python_copy_sources
+
+ preparation() {
+ local libfort lapack_libs lapack_libdirs
+ # Configure to compile against selected python version
+ cat <<-EOF >> machine_cfg.py
+ include_dirs = []
+ include_dirs.append("$(python_get_includedir)")
+ include_dirs.append("$(python_get_sitedir)")
+ EOF
+ local x
+ for x in $(pkg-config --libs-only-l lapack); do
+ lapack_libs="${lapack_libs}, \"${x#-l}\""
+ done
+ for x in $(pkg-config --libs-only-L lapack); do
+ lapack_libdirs="${lapack_libdirs}, \"${x#-L}\""
+ done
+ cat <<-EOF >> machine_cfg.py
+ library_dirs = [${lapack_libdirs#,}]
+ libs = ["boost_python-${PYTHON_ABI}", "blitz"${lapack_libs}]
+ EOF
+ }
+ python_execute_function -s preparation
+}
+
+src_test() {
+ testing() {
+ # trick to avoid X in testing (bug #229753)
+ echo "backend : Agg" > matplotlibrc
+ PYTHONPATH=".:visualisation" "$(PYTHON)" testsuite/camfr_test.py
+ rm -f matplotlibrc
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ distutils_src_install
+ dodoc docs/camfr.pdf
+}