summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-26 10:56:43 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-26 10:56:43 +0000
commitb550c689e038fb15e97f2421d5fa38832f7a3124 (patch)
tree9eb6ea20ffec44a9e0b97aaedd9346e21da01656 /sci-physics/hepmc
parentdev-haskell/xml-types: add new version (diff)
downloadgentoo-2-b550c689e038fb15e97f2421d5fa38832f7a3124.tar.gz
gentoo-2-b550c689e038fb15e97f2421d5fa38832f7a3124.tar.bz2
gentoo-2-b550c689e038fb15e97f2421d5fa38832f7a3124.zip
Bump
(Portage version: 2.2.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-physics/hepmc')
-rw-r--r--sci-physics/hepmc/ChangeLog9
-rw-r--r--sci-physics/hepmc/hepmc-2.06.09.ebuild87
2 files changed, 94 insertions, 2 deletions
diff --git a/sci-physics/hepmc/ChangeLog b/sci-physics/hepmc/ChangeLog
index e98e2b2fa1d4..234a4106f499 100644
--- a/sci-physics/hepmc/ChangeLog
+++ b/sci-physics/hepmc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/hepmc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.33 2012/08/07 16:56:28 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.34 2013/08/26 10:56:43 patrick Exp $
+
+*hepmc-2.06.09 (26 Aug 2013)
+
+ 26 Aug 2013; Patrick Lauer <patrick@gentoo.org> +hepmc-2.06.09.ebuild:
+ Bump
07 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> hepmc-2.06.08.ebuild:
keyword amd64-linux, x86-linux
diff --git a/sci-physics/hepmc/hepmc-2.06.09.ebuild b/sci-physics/hepmc/hepmc-2.06.09.ebuild
new file mode 100644
index 000000000000..b8eeb7b98223
--- /dev/null
+++ b/sci-physics/hepmc/hepmc-2.06.09.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/hepmc-2.06.09.ebuild,v 1.1 2013/08/26 10:56:43 patrick Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+MYP=HepMC-${PV}
+
+DESCRIPTION="Event Record for Monte Carlo Generators"
+HOMEPAGE="https://savannah.cern.ch/projects/hepmc/"
+SRC_URI="http://lcgapp.cern.ch/project/simu/HepMC/download/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cm doc examples gev static-libs test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen dev-tex/floatflt )"
+
+S="${WORKDIR}/${MYP}"
+
+DOCS=( ChangeLog AUTHORS )
+
+src_prepare() {
+ sed -i -e '/add_subdirectory(doc)/d' CMakeLists.txt
+ # CMake doc building broken
+ # gentoo doc directory
+ #sed -i \
+ # -e "s:share/HepMC/doc:share/doc/${PF}:" \
+ # doc/CMakeLists.txt || die
+
+ # gentoo examples directory
+ sed -i \
+ -e "s:share/HepMC:share/doc/${PF}:" \
+ $(find examples -name CMakeLists.txt) || die
+
+ # respect user's flags
+ sed -i \
+ -e "s/-O -ansi -pedantic -Wall//g" \
+ cmake/Modules/HepMCVariables.cmake || die
+
+ # gentoo libdir love
+ sed -i \
+ -e '/DESTINATION/s/lib/lib${LIB_SUFFIX}/g' \
+ {src,fio}/CMakeLists.txt || die
+
+ # remove targets if use flags not set
+ use examples || sed -i -e '/add_subdirectory(examples)/d' CMakeLists.txt
+ use test || sed -i -e '/add_subdirectory(test)/d' CMakeLists.txt
+ if ! use static-libs; then
+ sed -i \
+ -e '/(HepMC\(fio\|\)S/d' \
+ -e '/TARGETS/s/HepMC\(fio\|\)S//' \
+ {src,fio}/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ # use MeV over GeV and mm over cm
+ local length_conf="MM"
+ use cm && length_conf="CM"
+ local momentum_conf="MEV"
+ use gev && momentum_conf="GEV"
+ mycmakeargs+=(
+ -Dlength=${length_conf}
+ -Dmomentum=${momentum_conf}
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ cd doc
+ ./buildDoc.sh || die
+ ./buildDoxygen.sh || die
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc doc/*.pdf && dohtml -r doc/html/*
+}