summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-06-28 13:14:21 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-06-28 13:14:21 +0000
commitba402c6f169a8a55051e56c12dd7281669515650 (patch)
treea870242de80ce759599d7a80437c159293d077f0 /sci-physics/meep
parentFix quoting (diff)
downloadgentoo-2-ba402c6f169a8a55051e56c12dd7281669515650.tar.gz
gentoo-2-ba402c6f169a8a55051e56c12dd7281669515650.tar.bz2
gentoo-2-ba402c6f169a8a55051e56c12dd7281669515650.zip
Explicitly depend on blas-atlas and add warnings pointing out potential issues when using meep with blas-reference (see bug #229693).
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-SENTINEL-3 i686)
Diffstat (limited to 'sci-physics/meep')
-rw-r--r--sci-physics/meep/ChangeLog8
-rw-r--r--sci-physics/meep/meep-0.10.1.ebuild26
2 files changed, 32 insertions, 2 deletions
diff --git a/sci-physics/meep/ChangeLog b/sci-physics/meep/ChangeLog
index c1e1017a5f74..9a21ae024f14 100644
--- a/sci-physics/meep/ChangeLog
+++ b/sci-physics/meep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/meep
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/meep/ChangeLog,v 1.2 2008/06/27 17:21:17 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/meep/ChangeLog,v 1.3 2008/06/28 13:14:21 markusle Exp $
+
+ 28 Jun 2008; Markus Dittrich <markusle@gentoo.org> meep-0.10.1.ebuild:
+ Since blas-reference seems to result in a faulty meep, let's depend
+ explicitly on blas-atlas and add a warning in case the user has
+ selected blas-reference (see bug #229693). Thanks much to
+ Dustin Surawicz for tracking this down.
27 Jun 2008; Markus Dittrich <markusle@gentoo.org>
+files/meep-0.10.1-gcc4.3.patch, meep-0.10.1.ebuild:
diff --git a/sci-physics/meep/meep-0.10.1.ebuild b/sci-physics/meep/meep-0.10.1.ebuild
index c1c6ee962cdc..3cf607272198 100644
--- a/sci-physics/meep/meep-0.10.1.ebuild
+++ b/sci-physics/meep/meep-0.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/meep/meep-0.10.1.ebuild,v 1.2 2008/06/27 17:21:17 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/meep/meep-0.10.1.ebuild,v 1.3 2008/06/28 13:14:21 markusle Exp $
inherit eutils autotools
@@ -17,10 +17,24 @@ DEPEND="sci-libs/fftw
!bindist? ( sci-libs/gsl )
bindist? ( <sci-libs/gsl-1.10 )
sci-physics/harminv
+ sci-libs/blas-atlas
+ virtual/lapack
guile? ( >=sci-libs/libctl-3.0 )
hdf5? ( sci-libs/hdf5 )
mpi? ( virtual/mpi )"
+pkg_setup() {
+ SELECTED_BLAS=$(eselect blas show | cut -d' ' -f2)
+ if [[ ${SELECTED_BLAS} == "reference" ]]; then
+ ewarn "You have selected blas-reference which may yield a"
+ ewarn "broken meep and cause test failures (see bug #229693)"
+ ewarn "We highly recommend that you use blas-atlas"
+ ewarn "when compiling and using meep."
+ epause 5
+ fi
+}
+
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -49,3 +63,13 @@ src_install() {
doins -r examples || die "install examples failed"
fi
}
+
+pkg_postinst() {
+ # warn the user that meep + blas-reference may cause problems
+ echo
+ elog "Please note that meep may produce bad results when"
+ elog "used in conjunction with blas-reference. We recommend"
+ elog "that you use blas-atlas instead."
+ echo
+}
+