summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-05-23 13:17:35 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-05-23 13:17:35 +0000
commit41c19c024703da2be22132a67990cc149c99df55 (patch)
tree29d0cd4027ebad9ba84a0c6c280a885664c62f43 /sci-physics/xfoil
parentStable on alpha as per bug #179245 (diff)
downloadgentoo-2-41c19c024703da2be22132a67990cc149c99df55.tar.gz
gentoo-2-41c19c024703da2be22132a67990cc149c99df55.tar.bz2
gentoo-2-41c19c024703da2be22132a67990cc149c99df55.zip
Version bump. Revamped ebuild, added map generation, examples use flags.
Added patch to compile with gfortran, fixing bug #147033, thanks to Bob Johnson <ke6fis@arrl.net>. Added longdescription in metadata.xml. (Portage version: 2.1.2.7)
Diffstat (limited to 'sci-physics/xfoil')
-rw-r--r--sci-physics/xfoil/ChangeLog10
-rw-r--r--sci-physics/xfoil/files/digest-xfoil-6.966
-rw-r--r--sci-physics/xfoil/files/xfoil-6.96-gfortran.patch29
-rw-r--r--sci-physics/xfoil/metadata.xml10
-rw-r--r--sci-physics/xfoil/xfoil-6.96.ebuild76
5 files changed, 130 insertions, 1 deletions
diff --git a/sci-physics/xfoil/ChangeLog b/sci-physics/xfoil/ChangeLog
index 5729e99045fb..d7a85418d644 100644
--- a/sci-physics/xfoil/ChangeLog
+++ b/sci-physics/xfoil/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-physics/xfoil
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/ChangeLog,v 1.4 2007/02/22 01:14:53 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/ChangeLog,v 1.5 2007/05/23 13:17:35 bicatali Exp $
+
+*xfoil-6.96 (23 May 2007)
+
+ 23 May 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/xfoil-6.96-gfortran.patch, metadata.xml, +xfoil-6.96.ebuild:
+ Version bump. Revamped ebuild, added map generation, examples use flags.
+ Added patch to compile with gfortran, fixing bug #147033, thanks to
+ Bob Johnson <ke6fis@arrl.net>. Added longdescription in metadata.xml.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sci-physics/xfoil/files/digest-xfoil-6.96 b/sci-physics/xfoil/files/digest-xfoil-6.96
new file mode 100644
index 000000000000..e27871094997
--- /dev/null
+++ b/sci-physics/xfoil/files/digest-xfoil-6.96
@@ -0,0 +1,6 @@
+MD5 3bcf27382a90b82470b582c254698599 dataflow.pdf 7654
+RMD160 3e20242333cdab5f18b09603cd6d5df988629ea7 dataflow.pdf 7654
+SHA256 4596c77a3fa24cd334b35c34fcbd0b4f1d9055273c0862643e2d07b5e774aff5 dataflow.pdf 7654
+MD5 6ea00f7a3a0d338e97ab48ef5dd3d011 xfoil6.96.tar.gz 2542747
+RMD160 27a2878ecccfcd713e0d6331c83cbe3fffa6cc12 xfoil6.96.tar.gz 2542747
+SHA256 9961dfe028eaa7247b64c7e8bb92d3befc673d80c3a288a30bf9e8e1c5dc385e xfoil6.96.tar.gz 2542747
diff --git a/sci-physics/xfoil/files/xfoil-6.96-gfortran.patch b/sci-physics/xfoil/files/xfoil-6.96-gfortran.patch
new file mode 100644
index 000000000000..67fc19c645f9
--- /dev/null
+++ b/sci-physics/xfoil/files/xfoil-6.96-gfortran.patch
@@ -0,0 +1,29 @@
+--- plotlib/ps_subs.f.orig 2004-08-21 19:02:44.000000000 +0100
++++ plotlib/ps_subs.f 2007-05-03 19:14:28.901490750 +0100
+@@ -559,7 +559,7 @@
+ c in the iout array (3,1,3,1,3,1,3,1)
+ c Note: the bit mask is shifted to always start counting on a '1' bit.
+ c
+-c--- Uses the library routines and() and rshift() for bit manipulation
++c--- Uses the library routines and() and ishft() for bit manipulation
+ c which are present in most fortran libraries as extensions to f77.
+ c
+ dimension iout(*)
+@@ -570,7 +570,7 @@
+ ibitold = and(1,imask)
+ if(ibitold.NE.0) go to 5
+ nshft = n
+- imask = rshift(imask,1)
++ imask = ishft(imask,-1)
+ end do
+ c
+ 5 nout = 0
+@@ -594,7 +594,7 @@
+ c
+ ibitold = ibit
+ nbits = nbits + 1
+- imask = rshift(imask,1)
++ imask = ishft(imask,-1)
+ end do
+ c--- Add final bit(s) to end of 16 bits checked
+ c--- Now append any zero bits shifted out originally
diff --git a/sci-physics/xfoil/metadata.xml b/sci-physics/xfoil/metadata.xml
index 31c4fcb35306..c2e54a0de070 100644
--- a/sci-physics/xfoil/metadata.xml
+++ b/sci-physics/xfoil/metadata.xml
@@ -5,4 +5,14 @@
<maintainer>
<email>robbat2@gentoo.org</email>
</maintainer>
+<longdescription lang="en">
+XFOIL is an interactive program for the design and analysis of subsonic isolated airfoils.
+It consists of a collection of menu-driven routines which perform various useful functions such as:
+ * Viscous (or inviscid) analysis of an existing airfoil
+ * Airfoil design and redesign by interactive modification of surface speed distributions
+ * Airfoil redesign by interactive modification of geometric parameters
+ * Blending of airfoils
+ * Writing and reading of airfoil coordinates and polar save files
+ * Plotting of geometry, pressure distributions, and multiple polars
+</longdescription>
</pkgmetadata>
diff --git a/sci-physics/xfoil/xfoil-6.96.ebuild b/sci-physics/xfoil/xfoil-6.96.ebuild
new file mode 100644
index 000000000000..034ad862437f
--- /dev/null
+++ b/sci-physics/xfoil/xfoil-6.96.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/xfoil-6.96.ebuild,v 1.1 2007/05/23 13:17:35 bicatali Exp $
+
+inherit toolchain-funcs fortran
+
+DESCRIPTION="Design and analysis of subsonic isolated airfoils"
+HOMEPAGE="http://raphael.mit.edu/xfoil/"
+SRC_URI="http://web.mit.edu/drela/Public/web/${PN}/${PN}${PV}.tar.gz
+doc? ( http://web.mit.edu/drela/Public/web/${PN}/dataflow.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="doc examples"
+
+DEPEND="|| ( x11-libs/libX11 virtual/x11 )"
+
+RESTRICT="test"
+
+S=${WORKDIR}/Xfoil
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ [ -z "${FFLAGS}" ] && FFLAGS="${CFLAGS}"
+
+ # As defined in toolchain-funcs.eclass
+ echo "CC = $(tc-getCC)" >> plotlib/config.make
+
+ # As defined in fortran.eclass
+ echo "FC = ${FORTRANC}" >> plotlib/config.make
+
+ echo "CFLAGS += ${CFLAGS}" >> plotlib/config.make
+ echo "FFLAGS += ${FFLAGS}" >> plotlib/config.make
+
+ sed -i \
+ -e "s/^\(FC.*\)/FC = ${FORTRANC}/g" \
+ -e "s/^\(CC.*\)/CC = $(tc-getCC)/g" \
+ -e "s/^\(FFLAGS .*\)/FFLAGS = ${FFLAGS}/g" \
+ -e "s/^\(FFLOPT .*\)/FFLOPT = \$(FFLAGS)/g" \
+ -e "s/^\(FFLAGS2 .*\)/FFLAGS2 = \$(FFLAGS)/g" \
+ bin/Makefile orrs/bin/Makefile || die "sed failed"
+
+ # fix bug #147033
+ [[ "${FORTRANC}" == "gfortran" ]] && epatch "${FILESDIR}"/${P}-gfortran.patch
+
+ # make everything double precision
+ sed -i \
+ -e 's:/var/local/codes/orrs/osmap.dat:/usr/share/xfoil/orrs/osmap.dat:' \
+ -e 's:REAL*4:REAL:g' \
+ orrs/src/osmap.f || die "sed osmap.f failed"
+}
+
+src_compile() {
+ cd "${S}"/orrs/bin
+ emake FLG="${FFLAGS}" FTNLIB="" OS || die "failed to build orrs"
+ cd "${S}"/orrs
+ bin/osgen osmaps_ns.lst
+ cd "${S}"/plotlib
+ emake DP="" || die "failed to build plotlib"
+ cd "${S}"/bin
+ for i in xfoil pplot pxplot; do
+ emake CFLAGS="${CFLAGS} -DUNDERSCORE" ${i} || die "failed to build ${i}"
+ done
+}
+
+src_install() {
+ dobin bin/pplot bin/pxplot bin/xfoil || die "dobin failed"
+ insinto /usr/share/xfoil/orrs
+ doins orrs/osm*.dat
+ dodoc *.txt README
+ insinto /usr/share/doc/${PF}/
+ use examples && doins -r runs
+ use doc && doins "${DISTDIR}"/dataflow.pdf
+}