summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-10-07 12:06:32 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-10-07 12:06:32 +0000
commit22b8b2ea0f194494d05bc3091c765fd359f4e1f2 (patch)
tree06bc309a205c66e29ecfe4fd555bf6a435fdefc0 /sci-physics
parentApply patches from Fedora and Arch to fix various bugs, fix compatibility wit... (diff)
downloadgentoo-2-22b8b2ea0f194494d05bc3091c765fd359f4e1f2.tar.gz
gentoo-2-22b8b2ea0f194494d05bc3091c765fd359f4e1f2.tar.bz2
gentoo-2-22b8b2ea0f194494d05bc3091c765fd359f4e1f2.zip
version bump
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso++/ChangeLog7
-rw-r--r--sci-physics/espresso++/espresso++-1.9.2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/sci-physics/espresso++/ChangeLog b/sci-physics/espresso++/ChangeLog
index fd0a76b89f53..1edd83f1e833 100644
--- a/sci-physics/espresso++/ChangeLog
+++ b/sci-physics/espresso++/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/espresso++
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/ChangeLog,v 1.10 2014/08/29 16:39:53 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/ChangeLog,v 1.11 2014/10/07 12:06:32 ottxor Exp $
+
+*espresso++-1.9.2 (07 Oct 2014)
+
+ 07 Oct 2014; Christoph Junghans <ottxor@gentoo.org> +espresso++-1.9.2.ebuild:
+ version bump
*espresso++-1.9 (29 Aug 2014)
diff --git a/sci-physics/espresso++/espresso++-1.9.2.ebuild b/sci-physics/espresso++/espresso++-1.9.2.ebuild
new file mode 100644
index 000000000000..1aede06a379c
--- /dev/null
+++ b/sci-physics/espresso++/espresso++-1.9.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/espresso++-1.9.2.ebuild,v 1.1 2014/10/07 12:06:32 ottxor Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils multilib python-single-r1
+
+DESCRIPTION="extensible, flexible, fast and parallel simulation software for soft matter research"
+HOMEPAGE="https://www.espresso-pp.de"
+
+if [[ ${PV} = 9999 ]]; then
+ EHG_REPO_URI="https://bitbucket.org/${PN//+/p}/${PN//+/p}"
+ EHG_REVISION="default"
+ inherit mercurial
+ KEYWORDS=
+else
+ inherit vcs-snapshot
+ #SRC_URI="https://espressopp.mpip-mainz.mpg.de/Download/${PN//+/p}-${PV}.tgz"
+ SRC_URI="https://bitbucket.org/${PN//+/p}/${PN//+/p}/get/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ virtual/mpi
+ dev-libs/boost[python,mpi,${PYTHON_USEDEP}]
+ sci-libs/fftw:3.0
+ dev-python/mpi4py"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS README )
+
+src_configure() {
+ mycmakeargs=(
+ -DEXTERNAL_BOOST=ON
+ -DEXTERNAL_MPI4PY=ON
+ -DLIB="$(get_libdir)"
+ -DWITH_RC_FILES=OFF
+ )
+ cmake-utils_src_configure
+}