summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-19 19:44:18 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-19 19:44:18 +0000
commit989f54b8ed81ed47b0bf7efc3176f9aaa6b9d8fe (patch)
tree20f17a01c86f476b3796bd78a2a470c3f6580e73 /sci-physics
parentStable for alpha, wrt bug #458122 (diff)
downloadgentoo-2-989f54b8ed81ed47b0bf7efc3176f9aaa6b9d8fe.tar.gz
gentoo-2-989f54b8ed81ed47b0bf7efc3176f9aaa6b9d8fe.tar.bz2
gentoo-2-989f54b8ed81ed47b0bf7efc3176f9aaa6b9d8fe.zip
sci-physics/mpb: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/mpb/ChangeLog8
-rw-r--r--sci-physics/mpb/metadata.xml4
-rw-r--r--sci-physics/mpb/mpb-1.4.2-r2.ebuild8
3 files changed, 12 insertions, 8 deletions
diff --git a/sci-physics/mpb/ChangeLog b/sci-physics/mpb/ChangeLog
index d7253da30ee9..fa0182bda086 100644
--- a/sci-physics/mpb/ChangeLog
+++ b/sci-physics/mpb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/mpb
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/ChangeLog,v 1.16 2012/08/08 04:08:59 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/ChangeLog,v 1.17 2013/02/19 19:44:18 jlec Exp $
+
+ 19 Feb 2013; Justin Lecher <jlec@gentoo.org> mpb-1.4.2-r2.ebuild,
+ metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
08 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org>
+files/mpb-1.4.2-guile18.patch, -files/mpb-1.4.2-gcc4.patch, metadata.xml,
diff --git a/sci-physics/mpb/metadata.xml b/sci-physics/mpb/metadata.xml
index 4c409fb5d874..1b9dacc2cdfa 100644
--- a/sci-physics/mpb/metadata.xml
+++ b/sci-physics/mpb/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-physics</herd>
-<longdescription lang="en">
+ <herd>sci-physics</herd>
+ <longdescription lang="en">
The MIT Photonic-Bands (MPB) package is a program for computing
the band structures (dispersion relations) and electromagnetic modes of
periodic dielectric structures, on both serial and parallel computers. It was
diff --git a/sci-physics/mpb/mpb-1.4.2-r2.ebuild b/sci-physics/mpb/mpb-1.4.2-r2.ebuild
index 0d43b115ac13..0b7a8338e458 100644
--- a/sci-physics/mpb/mpb-1.4.2-r2.ebuild
+++ b/sci-physics/mpb/mpb-1.4.2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/mpb-1.4.2-r2.ebuild,v 1.6 2012/08/08 04:08:59 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/mpb-1.4.2-r2.ebuild,v 1.7 2013/02/19 19:44:18 jlec Exp $
EAPI=4
@@ -53,8 +53,8 @@ src_configure() {
#
local myconf=(
--with-libctl="${EPREFIX}/usr/share/libctl"
- --with-blas="$(pkg-config --libs blas)"
- --with-lapack="$(pkg-config --libs lapack)"
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
$(use_with hdf5)
)