summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-11-12 17:55:06 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-11-12 17:55:06 +0000
commitae5273d5a21517baf00c2691e36b0925665302a6 (patch)
tree30ac6007be83377938e7a82307364e9d7aafe70a /sci-physics
parentImport from Java overlay, dependency of sci-biology/cytoscape (diff)
downloadgentoo-2-ae5273d5a21517baf00c2691e36b0925665302a6.tar.gz
gentoo-2-ae5273d5a21517baf00c2691e36b0925665302a6.tar.bz2
gentoo-2-ae5273d5a21517baf00c2691e36b0925665302a6.zip
Now depend on boost[python] and removed the use of fortran eclass
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/camfr/ChangeLog6
-rw-r--r--sci-physics/camfr/camfr-20070717-r1.ebuild16
2 files changed, 12 insertions, 10 deletions
diff --git a/sci-physics/camfr/ChangeLog b/sci-physics/camfr/ChangeLog
index d4bc3744b5d7..965544921963 100644
--- a/sci-physics/camfr/ChangeLog
+++ b/sci-physics/camfr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/camfr
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/ChangeLog,v 1.14 2009/07/26 00:24:15 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/ChangeLog,v 1.15 2009/11/12 17:55:06 bicatali Exp $
+
+ 12 Nov 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ camfr-20070717-r1.ebuild:
+ Now depend on boost[python] and removed the use of fortran eclass
26 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org>
camfr-20070717-r1.ebuild, files/machine_cfg.py.gentoo:
diff --git a/sci-physics/camfr/camfr-20070717-r1.ebuild b/sci-physics/camfr/camfr-20070717-r1.ebuild
index 355ded6acdfb..b6620885e44e 100644
--- a/sci-physics/camfr/camfr-20070717-r1.ebuild
+++ b/sci-physics/camfr/camfr-20070717-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/camfr-20070717-r1.ebuild,v 1.4 2009/07/26 00:24:15 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/camfr-20070717-r1.ebuild,v 1.5 2009/11/12 17:55:06 bicatali Exp $
EAPI=2
-inherit eutils distutils fortran python
+inherit eutils distutils python toolchain-funcs
DESCRIPTION="Full vectorial Maxwell solver based on eigenmode expansion"
HOMEPAGE="http://camfr.sourceforge.net/"
@@ -18,7 +18,7 @@ RDEPEND="sci-libs/scipy
dev-lang/python[tk]
dev-python/imaging[tk]
dev-python/matplotlib
- dev-libs/boost
+ dev-libs/boost[python]
dev-libs/blitz
virtual/lapack"
@@ -49,17 +49,15 @@ src_prepare() {
lapack_libdirs="${lapack_libdirs}, \"${x#-L}\""
done
local libfort
- case ${FORTRANC} in
- gfortran) libfort=gfortran ;;
- g77) libfort=g2c ;;
+ case "$(tc-getF77)" in
+ *gfortran) libfort=gfortran ;;
+ *g77) libfort=g2c ;;
esac
cat <<-EOF >> machine_cfg.py
library_dirs = [${lapack_libdirs#,}]
libs = ["boost_python", "${libfort}", "blitz"${lapack_libs}]
EOF
-
- # scons redefines F77 to FORTRAN for env variables
- sed -i -e 's/F77/FORTRAN/g' SConstruct || die
+ export F77=$(tc-getF77)
}
src_test() {