summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-06-04 17:47:01 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-06-04 17:47:01 +0000
commitb9c9709e65e606d7d4983ecd5bcb42e5619928bb (patch)
treea9d0ca353c22f81e11dd4f24e56a5019969d812f /sci-physics
parentNew ebuild for jansi-native; dependency of jline, jruby. (diff)
downloadgentoo-2-b9c9709e65e606d7d4983ecd5bcb42e5619928bb.tar.gz
gentoo-2-b9c9709e65e606d7d4983ecd5bcb42e5619928bb.tar.bz2
gentoo-2-b9c9709e65e606d7d4983ecd5bcb42e5619928bb.zip
Version bump. Switch to autotools-utils and EAPI5
(Portage version: 2.2.01.21938-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/lhapdf/ChangeLog10
-rw-r--r--sci-physics/lhapdf/lhapdf-5.8.9.ebuild (renamed from sci-physics/lhapdf/lhapdf-5.8.7.ebuild)40
2 files changed, 29 insertions, 21 deletions
diff --git a/sci-physics/lhapdf/ChangeLog b/sci-physics/lhapdf/ChangeLog
index 3dd6635e619a..379852e329ed 100644
--- a/sci-physics/lhapdf/ChangeLog
+++ b/sci-physics/lhapdf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/lhapdf
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.20 2012/08/07 17:34:13 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.21 2013/06/04 17:47:01 bicatali Exp $
+
+*lhapdf-5.8.9 (04 Jun 2013)
+
+ 04 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> +lhapdf-5.8.9.ebuild,
+ -lhapdf-5.8.7.ebuild:
+ Version bump. Switch to autotools-utils and EAPI5
*lhapdf-5.8.8 (07 Aug 2012)
diff --git a/sci-physics/lhapdf/lhapdf-5.8.7.ebuild b/sci-physics/lhapdf/lhapdf-5.8.9.ebuild
index e4a076399af5..72a8259ae08f 100644
--- a/sci-physics/lhapdf/lhapdf-5.8.7.ebuild
+++ b/sci-physics/lhapdf/lhapdf-5.8.9.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-5.8.7.ebuild,v 1.1 2012/02/27 02:35:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-5.8.9.ebuild,v 1.1 2013/06/04 17:47:01 bicatali Exp $
-EAPI=4
+EAPI=5
-inherit versionator eutils
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+inherit versionator autotools-utils
MY_PV=$(get_version_component_range 1-3 ${PV})
MY_PF=${PN}-${MY_PV}
@@ -13,14 +14,15 @@ DESCRIPTION="Les Houches Parton Density Function unified library"
HOMEPAGE="http://projects.hepforge.org/lhapdf/"
SRC_URI="http://www.hepforge.org/archive/lhapdf/${MY_PF}.tar.gz
test? (
- http://svn.hepforge.org/${PN}/pdfsets/tags/${MY_PV}/cteq61.LHgrid
- http://svn.hepforge.org/${PN}/pdfsets/tags/${MY_PV}/MRST2004nlo.LHgrid
- http://svn.hepforge.org/${PN}/pdfsets/tags/${MY_PV}/cteq61.LHpdf
- octave? ( http://svn.hepforge.org/${PN}/pdfsets/tags/${MY_PV}/cteq5l.LHgrid ) )"
+ http://www.hepforge.org/archive/${PN}/pdfsets/${MY_PV}/cteq61.LHgrid
+ http://www.hepforge.org/archive/${PN}/pdfsets/${MY_PV}/MRST2004nlo.LHgrid
+ http://www.hepforge.org/archive/${PN}/pdfsets/${MY_PV}/cteq61.LHpdf
+ http://www.hepforge.org/archive/${PN}/pdfsets/${MY_PV}/CT10.LHgrid
+ octave? ( http://www.hepforge.org/archive/${PN}/pdfsets/${MY_PV}/cteq5l.LHgrid ) )"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="cxx doc examples octave python static-libs test"
REQUIRED_USE="octave? ( cxx )"
RDEPEND="octave? ( sci-mathematics/octave )"
@@ -38,16 +40,18 @@ src_prepare() {
}
src_configure() {
- econf \
- $(use_enable cxx ccwrap) \
- $(use_enable cxx old-ccwrap ) \
- $(use_enable doc doxygen) \
- $(use_enable octave) \
- $(use_enable python pyext) \
- $(use_enable static-libs static)
+ local myeconfargs=(
+ $(use_enable cxx ccwrap)
+ $(use_enable cxx old-ccwrap)
+ $(use_enable doc doxygen)
+ $(use_enable octave)
+ $(use_enable python pyext)
+ )
+ autotools-utils_src_configure
}
src_test() {
+ cd "${BUILD_DIR}"
# need to make a bogus link for octave test
ln -s "${DISTDIR}" PDFsets
LHAPATH="${PWD}/PDFsets" \
@@ -56,9 +60,7 @@ src_test() {
}
src_install() {
- default
- # leftover
- rm -rf "${ED}"/usr/share/${PN}/doc || die
+ autotools-utils_src_install
use doc && use cxx && dohtml -r ccwrap/doxy/html/*
if use examples; then
insinto /usr/share/doc/${PF}/examples