summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-07-22 20:33:48 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-07-22 20:33:48 +0000
commitc39f5991cb483c8d0535575f7d532662237d3b3b (patch)
tree9004639b2159c21fb850085e74836a62ac79be3a /sci-physics
parentThe thread option uses a - separator #427524 by argonovsky. (diff)
downloadgentoo-2-c39f5991cb483c8d0535575f7d532662237d3b3b.tar.gz
gentoo-2-c39f5991cb483c8d0535575f7d532662237d3b3b.tar.bz2
gentoo-2-c39f5991cb483c8d0535575f7d532662237d3b3b.zip
Imported from science overlay. Added a patch from fedora for glib-2.16. Changed all rm -f to rm to make sure they die
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/ChangeLog20
-rw-r--r--sci-physics/root/files/root-5.34.01-glibc216.patch35
-rw-r--r--sci-physics/root/root-5.34.01.ebuild (renamed from sci-physics/root/root-5.34.00.ebuild)49
3 files changed, 78 insertions, 26 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index 0161ba6b3ab7..842620a95e12 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -1,6 +1,24 @@
# ChangeLog for sci-physics/root
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.107 2012/07/15 09:35:43 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.108 2012/07/22 20:33:47 bicatali Exp $
+
+ 22 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> -root-5.34.00.ebuild,
+ +root-5.34.01.ebuild, +files/root-5.34.01-glibc216.patch:
+ Imported from science overlay. Added a patch from fedora for glib-2.16.
+ Changed all rm -f to rm to make sure they die
+
+*root-5.34.01 (22 Jul 2012)
+
+ 22 Jul 2012; Andrew Savchenko <bircoph@gmail.com> -root-5.34.00.ebuild,
+ +root-5.34.01.ebuild, metadata.xml:
+ Version bump. Clarens and PEAC are gone, despite this is a minor
+ release.
+
+ 21 Jul 2012; Andrew Savchenko <bircoph@gmail.com>
+ -files/root-5.32.00-explicit-functions.patch, +root-5.34.00.ebuild,
+ root-9999.ebuild:
+ Fix bug 426432: xft now is a strict dependency for X.
+ Remove unused.
15 Jul 2012; Justin Lecher <jlec@gentoo.org>
-files/root-5.26.00-make-3.82.patch, -root-5.26.00e-r1.ebuild,
diff --git a/sci-physics/root/files/root-5.34.01-glibc216.patch b/sci-physics/root/files/root-5.34.01-glibc216.patch
new file mode 100644
index 000000000000..b2da15970ea7
--- /dev/null
+++ b/sci-physics/root/files/root-5.34.01-glibc216.patch
@@ -0,0 +1,35 @@
+diff -ur root-5.34.00.orig/build/rmkdepend/main.c root-5.34.00/build/rmkdepend/main.c
+--- root-5.34.00.orig/build/rmkdepend/main.c 2012-06-05 15:31:46.000000000 +0200
++++ root-5.34.00/build/rmkdepend/main.c 2012-07-05 20:42:58.938953353 +0200
+@@ -60,7 +60,7 @@
+ # endif
+ # elif defined(__CYGWIN__)
+ extern int fchmod(int, mode_t);
+-#else
++# elif !defined(__GLIBC__) || __GLIBC__ < 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 16)
+ extern int fchmod(int, int);
+ # endif
+ #endif
+diff -ur root-5.34.00.orig/cint/tool/rmkdepend/main.c root-5.34.00/cint/tool/rmkdepend/main.c
+--- root-5.34.00.orig/cint/tool/rmkdepend/main.c 2012-06-05 15:31:30.000000000 +0200
++++ root-5.34.00/cint/tool/rmkdepend/main.c 2012-07-05 20:42:58.492949104 +0200
+@@ -58,7 +58,7 @@
+ #if !defined(MAC_OS_X_VERSION_10_4)
+ extern int fchmod();
+ #endif
+-#else
++#elif !defined(__GLIBC__) || __GLIBC__ < 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 16)
+ extern int fchmod();
+ #endif
+ #endif
+diff -ur root-5.34.00.orig/core/unix/src/TUnixSystem.cxx root-5.34.00/core/unix/src/TUnixSystem.cxx
+--- root-5.34.00.orig/core/unix/src/TUnixSystem.cxx 2012-06-05 15:31:17.000000000 +0200
++++ root-5.34.00/core/unix/src/TUnixSystem.cxx 2012-07-05 20:29:29.969242837 +0200
+@@ -98,6 +98,7 @@
+ #include <pwd.h>
+ #include <grp.h>
+ #include <errno.h>
++#include <sys/resource.h>
+ #include <sys/wait.h>
+ #include <time.h>
+ #include <sys/time.h>
diff --git a/sci-physics/root/root-5.34.00.ebuild b/sci-physics/root/root-5.34.01.ebuild
index faff57df347e..51c9f319594c 100644
--- a/sci-physics/root/root-5.34.00.ebuild
+++ b/sci-physics/root/root-5.34.01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.34.00.ebuild,v 1.3 2012/07/03 18:58:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.34.01.ebuild,v 1.1 2012/07/22 20:33:47 bicatali Exp $
EAPI=4
@@ -22,11 +22,12 @@ ROOFIT_DOC_PV=2.91-33
TMVA_DOC_PV=4.03
PATCH_PV=5.28.00b
PATCH_PV2=5.32.00
+PATCH_PV3=5.34.01
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="http://root.cern.ch/"
SRC_URI="${SRC_URI}
- doc? ( ftp://root.cern.ch/${PN}/doc/ROOTUsersGuide.pdf
+ doc? ( ftp://root.cern.ch/${PN}/doc/ROOTUsersGuide.pdf -> ROOTUsersGuide-${PV}.pdf
math? (
ftp://root.cern.ch/${PN}/doc/RooFit_Users_Manual_${ROOFIT_DOC_PV}.pdf
http://tmva.sourceforge.net/docu/TMVAUsersGuide.pdf -> TMVAUsersGuide-v${TMVA_DOC_PV}.pdf )
@@ -37,9 +38,9 @@ SRC_URI="${SRC_URI}
SLOT="0"
LICENSE="LGPL-2.1"
-IUSE="+X afs avahi -c++0x clarens doc emacs examples fits fftw graphviz htmldoc
+IUSE="+X afs avahi -c++0x doc emacs examples fits fftw graphviz htmldoc
kerberos ldap +math mpi mysql odbc +opengl openmp oracle postgres prefix
- pythia6 pythia8 python qt4 +reflex ruby ssl xft xinetd xml xrootd"
+ pythia6 pythia8 python qt4 +reflex ruby ssl xinetd xml xrootd"
CDEPEND="
app-arch/xz-utils
@@ -71,11 +72,10 @@ CDEPEND="
x11-libs/qt-svg:4
x11-libs/qt-webkit:4
x11-libs/qt-xmlpatterns:4 )
- xft? ( x11-libs/libXft )
+ x11-libs/libXft
)
afs? ( net-fs/openafs )
avahi? ( net-dns/avahi )
- clarens? ( dev-libs/xmlrpc-c[curl] )
emacs? ( virtual/emacs )
fits? ( sci-libs/cfitsio )
fftw? ( sci-libs/fftw:3.0 )
@@ -108,7 +108,7 @@ RDEPEND="
PDEPEND="htmldoc? ( ~app-doc/root-docs-${PV} )"
REQUIRED_USE="
- !X? ( !opengl !qt4 !xft )
+ !X? ( !opengl !qt4 )
mpi? ( math !openmp )
openmp? ( math !mpi )"
@@ -157,18 +157,19 @@ src_prepare() {
"${FILESDIR}"/${PN}-${PATCH_PV2}-afs.patch \
"${FILESDIR}"/${PN}-${PATCH_PV2}-cfitsio.patch \
"${FILESDIR}"/${PN}-${PATCH_PV2}-chklib64.patch \
- "${FILESDIR}"/${PN}-${PATCH_PV2}-dotfont.patch
+ "${FILESDIR}"/${PN}-${PATCH_PV2}-dotfont.patch \
+ "${FILESDIR}"/${PN}-${PATCH_PV3}-glibc216.patch
# make sure we use system libs and headers
rm montecarlo/eg/inc/cfortran.h README/cfortran.doc || die
- rm -rf graf2d/asimage/src/libAfterImage || die
- rm -rf graf3d/ftgl/{inc,src} || die
- rm -rf graf2d/freetype/src || die
- rm -rf graf3d/glew/{inc,src} || die
- rm -rf core/pcre/src || die
- rm -rf math/unuran/src/unuran-*.tar.gz || die
+ rm -r graf2d/asimage/src/libAfterImage || die
+ rm -r graf3d/ftgl/{inc,src} || die
+ rm -r graf2d/freetype/src || die
+ rm -r graf3d/glew/{inc,src} || die
+ rm -r core/pcre/src || die
+ rm -r math/unuran/src/unuran-*.tar.gz || die
LANG=C LC_ALL=C find core/zip -type f -name "[a-z]*" -print0 | xargs -0 rm -f || die
- rm -rf core/lzma/src/*.tar.gz || die
+ rm -r core/lzma/src/*.tar.gz || die
rm graf3d/gl/{inc,src}/gl2ps.* || die
sed -i -e 's/^GLLIBS *:= .* $(OPENGLLIB)/& -lgl2ps/' graf3d/gl/Module.mk || die
@@ -241,10 +242,9 @@ src_configure() {
--fail-on-missing \
$(use_enable X x11) \
$(use_enable X asimage) \
+ $(use_enable X xft) \
$(use_enable afs) \
$(use_enable avahi bonjour) \
- $(use_enable clarens) \
- $(use_enable clarens peac) \
$(use_enable fits fitsio) \
$(use_enable fftw fftw3) \
$(use_enable graphviz gviz) \
@@ -271,7 +271,6 @@ src_configure() {
$(use_enable reflex) \
$(use_enable ruby) \
$(use_enable ssl) \
- $(use_enable xft) \
$(use_enable xml) \
$(use_enable xrootd) \
${EXTRA_ECONF} \
@@ -289,7 +288,7 @@ doc_install() {
cd "${S}"
if use doc; then
einfo "Installing user's guides"
- dodoc "${DISTDIR}"/ROOTUsersGuide.pdf
+ dodoc "${DISTDIR}"/ROOTUsersGuide-${PV}.pdf
use math && dodoc \
"${DISTDIR}"/RooFit_Users_Manual_${ROOFIT_DOC_PV}.pdf \
"${DISTDIR}"/TMVAUsersGuide-v${TMVA_DOC_PV}.pdf
@@ -300,7 +299,7 @@ doc_install() {
insinto /usr/share/doc/${PF}/examples/tutorials/tmva
doins -r tmva/test
else
- rm -rf "${ED}"/usr/share/doc/${PF}/examples || die
+ rm -r "${ED}"/usr/share/doc/${PF}/examples || die
fi
}
@@ -347,7 +346,7 @@ src_install() {
# The build system installs Emacs support unconditionally and in the wrong
# directory. Remove it and call elisp-install in case of USE=emacs.
- rm -rf "${ED}"/usr/share/emacs
+ rm -r "${ED}"/usr/share/emacs
if use emacs; then
elisp-install ${PN} build/misc/*.{el,elc} || die "elisp-install failed"
fi
@@ -360,11 +359,11 @@ src_install() {
rm "${ED}"usr/share/doc/${PF}/{INSTALL,LICENSE,COPYING.CINT} || die
rm "${ED}"usr/share/root/fonts/LICENSE || die
pushd "${ED}"usr/$(get_libdir)/root/cint/cint/lib > /dev/null
- rm -f posix/mktypes dll_stl/setup \
+ rm posix/mktypes dll_stl/setup \
G__* dll_stl/G__* dll_stl/rootcint_* posix/exten.o || die
- rm -f "${ED}"usr/$(get_libdir)/root/cint/cint/include/makehpib || die
- rm -f "${ED}"/etc/root/proof/*.sample || die
- rm -rf "${ED}"/etc/root/daemons || die
+ rm "${ED}"usr/$(get_libdir)/root/cint/cint/include/makehpib || die
+ rm "${ED}"/etc/root/proof/*.sample || die
+ rm -r "${ED}"/etc/root/daemons || die
popd > /dev/null
# these should be in PATH
mv "${ED}"etc/root/proof/utils/pq2/pq2* \