summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-04-20 13:03:00 +0000
committerChristoph Junghans <ottxor@gentoo.org>2011-04-20 13:03:00 +0000
commitfc4acf569f2c12cbc6c3d3b59c456f1e08adcc84 (patch)
tree1ec672b9608ff9481a57ae57f604a7f5d4bee248 /sci-physics
parentRespect CC, #243960 (diff)
downloadgentoo-2-fc4acf569f2c12cbc6c3d3b59c456f1e08adcc84.tar.gz
gentoo-2-fc4acf569f2c12cbc6c3d3b59c456f1e08adcc84.tar.bz2
gentoo-2-fc4acf569f2c12cbc6c3d3b59c456f1e08adcc84.zip
initial commit from science overlay (bug 266648)
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso/ChangeLog10
-rw-r--r--sci-physics/espresso/espresso-3.0.0.ebuild92
-rw-r--r--sci-physics/espresso/metadata.xml13
3 files changed, 115 insertions, 0 deletions
diff --git a/sci-physics/espresso/ChangeLog b/sci-physics/espresso/ChangeLog
new file mode 100644
index 000000000000..4fe606be7fb1
--- /dev/null
+++ b/sci-physics/espresso/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-physics/espresso
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/ChangeLog,v 1.1 2011/04/20 13:03:00 ottxor Exp $
+
+*espresso-3.0.0 (20 Apr 2011)
+
+ 20 Apr 2011; Christoph Junghans <ottxor@gentoo.org> +espresso-3.0.0.ebuild,
+ +metadata.xml:
+ initial commit from science overlay (bug 266648)
+
diff --git a/sci-physics/espresso/espresso-3.0.0.ebuild b/sci-physics/espresso/espresso-3.0.0.ebuild
new file mode 100644
index 000000000000..3eaab33bd297
--- /dev/null
+++ b/sci-physics/espresso/espresso-3.0.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/espresso-3.0.0.ebuild,v 1.1 2011/04/20 13:03:00 ottxor Exp $
+
+EAPI="4"
+
+inherit autotools-utils savedconfig
+
+DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
+HOMEPAGE="http://www.espressomd.org"
+SRC_URI="mirror://nongnu/${PN}md/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X doc examples fftw mpi packages test -tk"
+
+RDEPEND="dev-lang/tcl
+ X? ( x11-libs/libX11 )
+ fftw? ( sci-libs/fftw:3.0 )
+ mpi? ( virtual/mpi )
+ tk? ( >=dev-lang/tk-8.4.18-r1 )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[-nodot]
+ virtual/latex-base )"
+
+src_prepare() {
+ sed -i 's/^CFLAGS/#&/' configure.ac
+ autotools-utils_src_prepare
+ eautoreconf
+ restore_config myconfig.h
+}
+
+src_configure() {
+ myeconfargs=(
+ $(use_with fftw) \
+ $(use_with mpi) \
+ $(use_with tk) \
+ $(use_with X x)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use doc; then
+ autotools-utils_src_compile doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ dodoc AUTHORS NEWS README ChangeLog
+
+ insinto /usr/share/${PN}
+ doins ${AUTOTOOLS_BUILD_DIR}/myconfig-sample.h
+
+ save_config ${AUTOTOOLS_BUILD_DIR}/src/myconfig-final.h
+
+ if use doc; then
+ newdoc doc/ug/ug.pdf user_guide.pdf
+ dohtml -r ${AUTOTOOLS_BUILD_DIR}/doc/dg/html/*
+ newdoc doc/tutorials/tut2/tut2.pdf tutorial.pdf
+ fi
+
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins -r samples/*
+ fi
+
+ if use packages; then
+ insinto /usr/share/${PN}/packages
+ doins -r packages/*
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "Please read and cite:"
+ elog "ESPResSo, Comput. Phys. Commun. 174(9) ,704, 2006."
+ elog "http://dx.doi.org/10.1016/j.cpc.2005.10.005"
+ elog
+ elog "If you need more features, change"
+ elog "/etc/portage/savedconfig/${CATEGORY}/${PF}"
+ elog "and reemerge with USE=savedconfig"
+ elog
+ elog "For a full feature list see:"
+ elog "/usr/share/${PN}/myconfig-sample.h"
+ elog
+}
diff --git a/sci-physics/espresso/metadata.xml b/sci-physics/espresso/metadata.xml
new file mode 100644
index 000000000000..05916be9fd25
--- /dev/null
+++ b/sci-physics/espresso/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-physics</herd>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <use>
+ <flag name='examples'>Installs the examples</flag>
+ <flag name='packages'>Installs extra subpackages</flag>
+ </use>
+</pkgmetadata>