summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-09-14 09:17:11 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-09-14 09:17:11 +0000
commitf964c54b97322f73db80e568e9b6aac48d8677eb (patch)
treec5e12f25a894326dfcb34f0983491da1798daf4b /sci-visualization/mayavi
parentVersion bump, test if processor supports SSE2, bug #284227 (diff)
downloadgentoo-2-f964c54b97322f73db80e568e9b6aac48d8677eb.tar.gz
gentoo-2-f964c54b97322f73db80e568e9b6aac48d8677eb.tar.bz2
gentoo-2-f964c54b97322f73db80e568e9b6aac48d8677eb.zip
Documentation generation requires X, so docs are cached on Gentoo mirrors. Closing bug #284080.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'sci-visualization/mayavi')
-rw-r--r--sci-visualization/mayavi/ChangeLog7
-rw-r--r--sci-visualization/mayavi/files/mayavi-3.3.0-nodocs.patch14
-rw-r--r--sci-visualization/mayavi/mayavi-3.3.0.ebuild60
3 files changed, 42 insertions, 39 deletions
diff --git a/sci-visualization/mayavi/ChangeLog b/sci-visualization/mayavi/ChangeLog
index aac86db56490..4f582a13164e 100644
--- a/sci-visualization/mayavi/ChangeLog
+++ b/sci-visualization/mayavi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/mayavi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/mayavi/ChangeLog,v 1.11 2009/09/06 16:18:09 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/mayavi/ChangeLog,v 1.12 2009/09/14 09:17:11 grozin Exp $
+
+ 14 Sep 2009; Andrey Grozin <grozin@gentoo.org> mayavi-3.3.0.ebuild,
+ +files/mayavi-3.3.0-nodocs.patch:
+ Documentation generation requires X, so docs are cached on Gentoo mirrors.
+ Closing bug #284080.
*mayavi-3.3.0 (06 Sep 2009)
diff --git a/sci-visualization/mayavi/files/mayavi-3.3.0-nodocs.patch b/sci-visualization/mayavi/files/mayavi-3.3.0-nodocs.patch
new file mode 100644
index 000000000000..64dba32d26a3
--- /dev/null
+++ b/sci-visualization/mayavi/files/mayavi-3.3.0-nodocs.patch
@@ -0,0 +1,14 @@
+diff -r -U2 Mayavi-3.3.0.orig/setup.py Mayavi-3.3.0/setup.py
+--- Mayavi-3.3.0.orig/setup.py 2009-07-16 18:27:25.000000000 +0200
++++ Mayavi-3.3.0/setup.py 2009-09-11 17:43:20.000000000 +0200
+@@ -282,10 +282,4 @@
+ build_tvtk_classes_zip()
+ build.build.run(self)
+- self.run_command('gen_docs')
+- try:
+- self.run_command('build_docs')
+- except:
+- log.warn("Couldn't build documentation:\n%s" %
+- traceback.format_exception(*sys.exc_info()))
+
+
diff --git a/sci-visualization/mayavi/mayavi-3.3.0.ebuild b/sci-visualization/mayavi/mayavi-3.3.0.ebuild
index bfa03701ba8a..1a07ec3d3c3b 100644
--- a/sci-visualization/mayavi/mayavi-3.3.0.ebuild
+++ b/sci-visualization/mayavi/mayavi-3.3.0.ebuild
@@ -1,21 +1,23 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/mayavi/mayavi-3.3.0.ebuild,v 1.2 2009/09/06 17:37:00 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/mayavi/mayavi-3.3.0.ebuild,v 1.3 2009/09/14 09:17:11 grozin Exp $
EAPI="2"
-
inherit distutils eutils
-MY_PN="Mayavi"
-MY_P="${MY_PN}-${PV}"
DESCRIPTION="VTK based scientific data visualizer"
-HOMEPAGE="http://code.enthought.com/projects/mayavi"
-SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
-
-IUSE="doc examples qt4"
+LICENSE="BSD"
SLOT="2"
KEYWORDS="~amd64 ~x86"
-LICENSE="BSD"
+IUSE="doc qt4"
+
+MY_PN="Mayavi"
+MY_P="${MY_PN}-${PV}"
+
+HOMEPAGE="http://code.enthought.com/projects/${PN}/"
+
+SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz
+ doc? ( mirror://gentoo/${PN}-docs-${PV}.tar.bz2 )"
RDEPEND=">=dev-python/apptools-3.3.0
>=dev-python/enthoughtbase-3.0.3
@@ -32,47 +34,29 @@ RDEPEND=">=dev-python/apptools-3.3.0
DEPEND="dev-python/setuptools
>=dev-python/numpy-1.1
>=sci-libs/vtk-5[python]"
-# doc and test need X display
-# doc? ( dev-python/setupdocs )
-# test? ( >=dev-python/nose-0.10.3 )
-RESTRICT="test"
-S="${WORKDIR}/${MY_P}"
+# tests require X
+RESTRICT=test
-PYTHON_MODNAME="enthought"
+S="${WORKDIR}"/${MY_P}
+PYTHON_MODNAME=enthought
src_prepare() {
- # remove docs and mlab which needs a display
- sed -i \
- -e "s/self.run_command('build_docs')/pass/" \
- -e "/self.run_command('gen_docs')/d" \
- setup.py || die
-}
-
-src_compile() {
- distutils_src_compile
- #if use doc; then
- # ${python} setup.py build_docs --formats=html,pdf \
- # || die "doc building failed"
- #fi
-}
-
-src_test() {
- PYTHONPATH="$(ls -d build/lib*)" "${python}" setup.py test || die "tests failed"
+ # documentation generation requires X
+ epatch "${FILESDIR}"/${P}-nodocs.patch
}
src_install() {
find "${S}" -name \*LICENSE\*.txt -delete
distutils_src_install
dodoc docs/*.txt
- insinto /usr/share/doc/${PF}
if use doc; then
- #doins -r build/docs/html build/docs/latex/*/* || die
- doins docs/pdf/*.pdf docs/pdf/*/*.pdf || die
- fi
- if use examples; then
- doins -r examples || die
+ dohtml -A txt,py,inv -r "${WORKDIR}"/html/*
fi
newicon enthought/mayavi/core/ui/images/m2.png mayavi2.png
make_desktop_entry mayavi2 "Mayavi2 2D/3D Scientific Visualization" mayavi2
}
+
+src_test() {
+ PYTHONPATH="$(ls -d build/lib*)" "${python}" setup.py test || die "tests failed"
+}