summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-27 19:56:54 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-27 19:56:54 +0000
commit7313e151a16f52ea0d8cbd50ca717f70d6f4cc63 (patch)
treefc2f968f58843b38bffb46043fe2f96da2115314 /sci-visualization/quickplot/quickplot-0.10.6.ebuild
parentsys-apps/fakeroot-ng: Version BUmp (diff)
downloadgentoo-2-7313e151a16f52ea0d8cbd50ca717f70d6f4cc63.tar.gz
gentoo-2-7313e151a16f52ea0d8cbd50ca717f70d6f4cc63.tar.bz2
gentoo-2-7313e151a16f52ea0d8cbd50ca717f70d6f4cc63.zip
sci-visualization/quickplot: Verion BUmp
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-visualization/quickplot/quickplot-0.10.6.ebuild')
-rw-r--r--sci-visualization/quickplot/quickplot-0.10.6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-visualization/quickplot/quickplot-0.10.6.ebuild b/sci-visualization/quickplot/quickplot-0.10.6.ebuild
new file mode 100644
index 000000000000..eb47c14234ad
--- /dev/null
+++ b/sci-visualization/quickplot/quickplot-0.10.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.10.6.ebuild,v 1.1 2013/11/27 19:56:54 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils
+
+DESCRIPTION="A fast interactive 2D plotter"
+HOMEPAGE="http://quickplot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="
+ media-libs/libsndfile
+ >=sys-libs/readline-0.6.2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed '/libquickplot_la_LIBADD/s:$: -lm:g' -i Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+ autotools-utils_src_configure
+}
+
+src_install () {
+ autotools-utils_src_install
+ make_desktop_entry 'quickplot --no-pipe' Quickplot quickplot Graphics
+ mv "${ED}"/usr/share/applications/quickplot*.desktop \
+ "${ED}"/usr/share/applications/quickplot.desktop || die
+}