summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-02-13 15:01:21 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-02-13 15:01:21 +0000
commitdfd5d394d3e3955a9c59b28a64909f98cfb16cd7 (patch)
treeece8fda051566acc02f120fdc1f81813c8893bc8 /sci-visualization/spectromatic
parentUnmasking patched ipw3945 as it is reported to work with both 2.6.23-r1 and 2... (diff)
downloadgentoo-2-dfd5d394d3e3955a9c59b28a64909f98cfb16cd7.tar.gz
gentoo-2-dfd5d394d3e3955a9c59b28a64909f98cfb16cd7.tar.bz2
gentoo-2-dfd5d394d3e3955a9c59b28a64909f98cfb16cd7.zip
Fixed QA issues and added bindist for >=gsl-1.10 (see bug #199451).
(Portage version: 2.1.4.2)
Diffstat (limited to 'sci-visualization/spectromatic')
-rw-r--r--sci-visualization/spectromatic/ChangeLog8
-rw-r--r--sci-visualization/spectromatic/spectromatic-1.0.ebuild24
2 files changed, 19 insertions, 13 deletions
diff --git a/sci-visualization/spectromatic/ChangeLog b/sci-visualization/spectromatic/ChangeLog
index a7483d866211..4356b1ba23a3 100644
--- a/sci-visualization/spectromatic/ChangeLog
+++ b/sci-visualization/spectromatic/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/spectromatic
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/ChangeLog,v 1.3 2007/02/22 01:12:06 jokey Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/ChangeLog,v 1.4 2008/02/13 15:01:21 markusle Exp $
+
+ 13 Feb 2008; Markus Dittrich <markusle@gentoo.org>
+ spectromatic-1.0.ebuild:
+ Fixed QA issues and added bindist for >=gsl-1.10 (see bug #199451).
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sci-visualization/spectromatic/spectromatic-1.0.ebuild b/sci-visualization/spectromatic/spectromatic-1.0.ebuild
index d9cf875f380a..a8a7a0fdd1c1 100644
--- a/sci-visualization/spectromatic/spectromatic-1.0.ebuild
+++ b/sci-visualization/spectromatic/spectromatic-1.0.ebuild
@@ -1,35 +1,37 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/spectromatic-1.0.ebuild,v 1.1 2006/01/29 20:20:53 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/spectromatic-1.0.ebuild,v 1.2 2008/02/13 15:01:21 markusle Exp $
inherit eutils
IUSE=""
MY_P="spectromatic_1.0-1"
-DESCRIPTION="Little program that generates spectrograms (time-frequency analysis images) from mono or stereo wave files."
+DESCRIPTION="Generates spectrograms (time-frequency analysis images) from mono or stereo wave files."
HOMEPAGE="http://ieee.uow.edu.au/~daniel/software/spectromatic/"
SRC_URI="http://ieee.uow.edu.au/~daniel/software/spectromatic/dist/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc x86"
+IUSE="bindist"
-DEPEND=">=sci-libs/gsl-1.2
- >=media-libs/libpng-1.2.4"
+DEPEND=">=media-libs/libpng-1.2.4
+ !bindist? ( sci-libs/gsl )
+ bindist? ( <sci-libs/gsl-1.10 )"
src_unpack() {
- unpack ${MY_P}.tar.gz
- cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.diff
- epatch ${FILESDIR}/${P}-stringliteral.patch
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${P}-stringliteral.patch
}
src_compile() {
emake || die
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dobin spectromatic
doman spectromatic.1
- dodoc COPYING README || die
+ dodoc README || die
}