summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-02-25 06:32:47 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-02-25 06:32:47 +0000
commit0c4657fc5b5b5a0ea3016bf3b728950c47383cbf (patch)
tree7f6672be913f7f387ee5d50f130f22e0f202e065 /sci-visualization
parentUnmask qemu 1.4, unleash the bug storm. (diff)
downloadgentoo-2-0c4657fc5b5b5a0ea3016bf3b728950c47383cbf.tar.gz
gentoo-2-0c4657fc5b5b5a0ea3016bf3b728950c47383cbf.tar.bz2
gentoo-2-0c4657fc5b5b5a0ea3016bf3b728950c47383cbf.zip
Version bump (tar ball from Debian). Added a desktop file patch and some m4 macro cleanup before autoreconf (bug #448824)
(Portage version: 2.2.01.21688-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/ggobi/ChangeLog12
-rw-r--r--sci-visualization/ggobi/files/ggobi-2.1.10-desktop.patch11
-rw-r--r--sci-visualization/ggobi/files/ggobi-2.1.10-hardened.patch66
-rw-r--r--sci-visualization/ggobi/ggobi-2.1.10.ebuild57
4 files changed, 144 insertions, 2 deletions
diff --git a/sci-visualization/ggobi/ChangeLog b/sci-visualization/ggobi/ChangeLog
index 42e81cdf6315..272dfb09a6a6 100644
--- a/sci-visualization/ggobi/ChangeLog
+++ b/sci-visualization/ggobi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-visualization/ggobi
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/ggobi/ChangeLog,v 1.12 2012/08/07 01:05:27 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/ggobi/ChangeLog,v 1.13 2013/02/25 06:32:47 bicatali Exp $
+
+*ggobi-2.1.10 (25 Feb 2013)
+
+ 25 Feb 2013; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/ggobi-2.1.10-desktop.patch, +files/ggobi-2.1.10-hardened.patch,
+ +ggobi-2.1.10.ebuild:
+ Version bump (tar ball from Debian). Added a desktop file patch and some m4
+ macro cleanup before autoreconf (bug #448824)
07 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> ggobi-2.1.9-r1.ebuild,
metadata.xml:
diff --git a/sci-visualization/ggobi/files/ggobi-2.1.10-desktop.patch b/sci-visualization/ggobi/files/ggobi-2.1.10-desktop.patch
new file mode 100644
index 000000000000..388cb85c975c
--- /dev/null
+++ b/sci-visualization/ggobi/files/ggobi-2.1.10-desktop.patch
@@ -0,0 +1,11 @@
+--- xdg/ggobi.desktop.orig 2013-02-24 22:20:02.616872402 -0800
++++ xdg/ggobi.desktop 2013-02-24 22:20:13.293924862 -0800
+@@ -6,6 +6,6 @@
+ Comment=Multivariate interactive graphics for exploratory data analysis
+ TryExec=ggobi
+ Exec=ggobi
+-Icon=ggobi.png
+-Categories=Graphics;2DGraphics
++Icon=ggobi
++Categories=Graphics;2DGraphics;
+ MimeType=text/comma-separated-values;text/csv;application/csv;
diff --git a/sci-visualization/ggobi/files/ggobi-2.1.10-hardened.patch b/sci-visualization/ggobi/files/ggobi-2.1.10-hardened.patch
new file mode 100644
index 000000000000..63681a0a03ea
--- /dev/null
+++ b/sci-visualization/ggobi/files/ggobi-2.1.10-hardened.patch
@@ -0,0 +1,66 @@
+Description: Upstream changes introduced in version 2.1.10-4
+ This patch has been created by dpkg-source during the package build.
+ Here's the last changelog entry, hopefully it gives details on why
+ those changes were made:
+ .
+ ggobi (2.1.10-4) unstable; urgency=low
+ .
+ * src/ggobi.c: Applied patch kindly supplied by Michael Lawrence to
+ address issues found under hardened compiler flags (Closes: #646260)
+ .
+ The person named in the Author field signed this changelog entry.
+Author: Dirk Eddelbuettel <edd@debian.org>
+Bug-Debian: http://bugs.debian.org/646260
+
+---
+The information above should follow the Patch Tagging Guidelines, please
+checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
+are templates for supplementary fields that you might want to add:
+
+Origin: <vendor|upstream|other>, <url of original patch>
+Bug: <url in upstream bugtracker>
+Bug-Debian: http://bugs.debian.org/<bugnumber>
+Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
+Forwarded: <no|not-needed|url proving that it has been forwarded>
+Reviewed-By: <name and email of someone who approved the patch>
+Last-Update: <YYYY-MM-DD>
+
+--- ggobi-2.1.10.orig/src/ggobi.c
++++ ggobi-2.1.10/src/ggobi.c
+@@ -698,10 +698,10 @@ ValidateGGobiRef (ggobid * gg, gboolean
+ }
+
+ if (fatal) {
+- g_error (error_msg);
++ g_error ("%s", error_msg);
+ }
+ else
+- g_critical (error_msg);
++ g_critical ("%s", error_msg);
+
+ return (NULL);
+ }
+@@ -718,9 +718,9 @@ ValidateDatadRef (GGobiData * d, ggobid
+ }
+
+ if (fatal)
+- g_error (error_msg);
++ g_error ("%s", error_msg);
+ else
+- g_critical (error_msg);
++ g_critical ("%s", error_msg);
+
+ return (NULL);
+ }
+@@ -739,9 +739,9 @@ ValidateDisplayRef (displayd * d, ggobid
+ }
+
+ if (fatal)
+- g_error (error_msg);
++ g_error ("%s", error_msg);
+ else
+- g_critical (error_msg);
++ g_critical ("%s", error_msg);
+
+ return (NULL);
+ }
diff --git a/sci-visualization/ggobi/ggobi-2.1.10.ebuild b/sci-visualization/ggobi/ggobi-2.1.10.ebuild
new file mode 100644
index 000000000000..a6517f629c27
--- /dev/null
+++ b/sci-visualization/ggobi/ggobi-2.1.10.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/ggobi/ggobi-2.1.10.ebuild,v 1.1 2013/02/25 06:32:47 bicatali Exp $
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Visualization program for exploring high-dimensional data"
+HOMEPAGE="http://www.ggobi.org/"
+# source code release is not well published
+#SRC_URI="http://www.ggobi.org/downloads/${P}.tar.bz2"
+SRC_URI="mirror://debian/pool/main/g/${PN}/${PN}_${PV}.orig.tar.bz2"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc minimal nls"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ media-gfx/graphviz
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e 's|ND_coord_i|ND_coord|' \
+ plugins/GraphLayout/graphviz.c || die
+ rm m4/libtool.m4 m4/lt*m4 plugins/*/aclocal.m4 || die
+ epatch \
+ "${FILESDIR}"/${PN}-2.1.8-plugindir.patch \
+ "${FILESDIR}"/${PN}-2.1.9-as-needed.patch \
+ "${FILESDIR}"/${PN}-2.1.10-hardened.patch \
+ "${FILESDIR}"/${PN}-2.1.10-desktop.patch
+ # need the ${S} for recursivity lookup
+ AT_M4DIR="${S}"/m4 eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-rpath \
+ $(use_enable nls) \
+ $(use_with !minimal all-plugins)
+}
+
+src_compile() {
+ emake all ggobirc
+}
+
+src_install() {
+ default
+ insinto /etc/xdg/ggobi
+ doins ggobirc
+ use doc || rm "${ED}"/usr/share/doc/${PF}/*.pdf
+}