summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-09-08 18:37:09 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-09-08 18:37:09 +0000
commitd45f3bb7d7cd3fa50055551c298b5331646cf2cf (patch)
tree50ab1eea70df9b0d813d0aedf89228406203daca /sci-visualization
parent(#128448) Depend on xplsprinters if USE=xprint, because it's used in profile ... (diff)
downloadgentoo-2-d45f3bb7d7cd3fa50055551c298b5331646cf2cf.tar.gz
gentoo-2-d45f3bb7d7cd3fa50055551c298b5331646cf2cf.tar.bz2
gentoo-2-d45f3bb7d7cd3fa50055551c298b5331646cf2cf.zip
Version bump.
(Portage version: 2.1.1_rc1-r7)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/labplot/ChangeLog7
-rw-r--r--sci-visualization/labplot/files/digest-labplot-1.5.1.46
-rw-r--r--sci-visualization/labplot/labplot-1.5.1.4.ebuild78
3 files changed, 90 insertions, 1 deletions
diff --git a/sci-visualization/labplot/ChangeLog b/sci-visualization/labplot/ChangeLog
index 134be2b99109..57fbf1fe6e7e 100644
--- a/sci-visualization/labplot/ChangeLog
+++ b/sci-visualization/labplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/labplot
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/labplot/ChangeLog,v 1.7 2006/06/05 22:57:36 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/labplot/ChangeLog,v 1.8 2006/09/08 18:37:09 carlo Exp $
+
+*labplot-1.5.1.4 (08 Sep 2006)
+
+ 08 Sep 2006; Carsten Lohrke <carlo@gentoo.org> +labplot-1.5.1.4.ebuild:
+ Version bump.
05 Jun 2006; Carsten Lohrke <carlo@gentoo.org>
-files/labplot-1.3.0-amd64.patch, -files/getversion.patch,
diff --git a/sci-visualization/labplot/files/digest-labplot-1.5.1.4 b/sci-visualization/labplot/files/digest-labplot-1.5.1.4
new file mode 100644
index 000000000000..d0a6fb099c2a
--- /dev/null
+++ b/sci-visualization/labplot/files/digest-labplot-1.5.1.4
@@ -0,0 +1,6 @@
+MD5 9247a4871b00e1a5a435ed48150761a8 LabPlot-1.5.1.tar.gz 10733976
+RMD160 404fe6f2c39685ed6b336c71dff3d549b3f4faa4 LabPlot-1.5.1.tar.gz 10733976
+SHA256 25f17e55e3483db33601c10ec292a77de627e7eca2effbd3a77942538a6cbfde LabPlot-1.5.1.tar.gz 10733976
+MD5 bead5a9c4b752f09ac21f9520ca355d1 LabPlot-1.5.1_1.5.1.4.diff.gz 172551
+RMD160 8539ce8174542d13e00c1961a92f8a855f013b0d LabPlot-1.5.1_1.5.1.4.diff.gz 172551
+SHA256 2c12331b806b75941261b620179d472f72d7ae83c8cd041b72665f1c072e189c LabPlot-1.5.1_1.5.1.4.diff.gz 172551
diff --git a/sci-visualization/labplot/labplot-1.5.1.4.ebuild b/sci-visualization/labplot/labplot-1.5.1.4.ebuild
new file mode 100644
index 000000000000..5e5384f8ea3f
--- /dev/null
+++ b/sci-visualization/labplot/labplot-1.5.1.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/labplot/labplot-1.5.1.4.ebuild,v 1.1 2006/09/08 18:37:09 carlo Exp $
+
+inherit eutils gnuconfig kde
+
+PV_BUGFIX="${PV/?.?.?/}"
+MY_PV="${PV/${PV_BUGFIX}/}"
+MY_P="LabPlot-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+BUGFIX="LabPlot-${MY_PV}_${PV}.diff"
+
+DESCRIPTION="LabPlot is a KDE application for data plotting and function analysis."
+HOMEPAGE="http://labplot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/labplot/${MY_P}.tar.gz"
+[[ -n PV_BUGFIX ]] && SRC_URI="${SRC_URI} mirror://sourceforge/labplot/${BUGFIX}.gz"
+
+LICENSE="GPL-2"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE="cdf fftw imagemagick jpeg2k kexi opengl tiff"
+
+DEPEND=">=sci-libs/gsl-1.6
+ sci-libs/netcdf
+ virtual/ghostscript
+ x11-libs/qwtplot3d
+ media-libs/audiofile
+ fftw? ( >=sci-libs/fftw-3 )
+ imagemagick? ( >=media-gfx/imagemagick-5.5.6-r1 )
+ jpeg2k? ( >=media-libs/jasper-1.700.5-r1 )
+ tiff? ( >=media-libs/tiff-3.5.5 )
+ opengl? ( virtual/opengl )
+ kexi? ( || ( app-office/kexi app-office/koffice ) )
+ !amd64? ( cdf? ( sci-libs/cdf )
+ >=media-gfx/pstoedit-3.33 )"
+RDEPEND="${DEPEND}"
+need-kde 3.4
+
+[[ -n PV_BUGFIX ]] && PATCHES="${WORKDIR}/${BUGFIX}"
+
+src_unpack() {
+ kde_src_unpack
+ # let's make sure we don't use included libs
+ echo "# Using shared libs!" >| netcdf/netcdf.h
+ echo "# Using shared libs!" >| qwtplot3d/qwt3d_plot.h
+ echo "# Using shared libs!" >| audiofile/audiofile.h
+}
+
+src_compile() {
+ export QTDIR="${ROOT}/usr/qt/3"
+ export QWT3D_PATH="${ROOT}/usr"
+ export KEXIDB_DIR="${ROOT}/usr"
+
+ # texvc not in Portage and I'm not keen maintaining it
+ # qsa ebuilds in bad shape atm.
+ local myconf="--disable-fftw --enable-gsl --enable-ps2eps \
+ --disable-texvc --disable-ocaml --enable-netcdf --enable-audiofile \
+ --enable-system-qwtplot3d --enable-libundo --disable-qsa"
+
+ if use amd64; then
+ myconf="${myconf} --disable-cdf"
+ else
+ myconf="${myconf} $(use_enable cdf)"
+ fi
+
+ local myconf="${myconf} \
+ $(use_enable fftw fftw3) \
+ $(use_enable imagemagick ImageMagick) \
+ $(use_enable jpeg2k jasper) \
+ $(use_enable tiff) \
+ $(use_enable kexi KexiDB) \
+ $(use_enable opengl)"
+ gnuconfig_update
+ kde_src_compile
+}
+