summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2006-10-25 11:29:41 +0000
committerChris PeBenito <pebenito@gentoo.org>2006-10-25 11:29:41 +0000
commite643e8910eb160d4b23ddf2c4e8a803058d1ae4c (patch)
treec65c67293df82edfe9c8a309f3cd426e664095df /sec-policy
parentfix selinux policy eclass to have default POLICY_TYPES if it is empty. (diff)
downloadgentoo-2-e643e8910eb160d4b23ddf2c4e8a803058d1ae4c.tar.gz
gentoo-2-e643e8910eb160d4b23ddf2c4e8a803058d1ae4c.tar.bz2
gentoo-2-e643e8910eb160d4b23ddf2c4e8a803058d1ae4c.zip
Fix to have default POLICY_TYPES if it is empty.
(Portage version: 2.1.2_pre3-r7)
Diffstat (limited to 'sec-policy')
-rw-r--r--sec-policy/selinux-base-policy/ChangeLog6
-rw-r--r--sec-policy/selinux-base-policy/selinux-base-policy-20061015.ebuild8
2 files changed, 12 insertions, 2 deletions
diff --git a/sec-policy/selinux-base-policy/ChangeLog b/sec-policy/selinux-base-policy/ChangeLog
index 466ef71c3565..3474d862b43a 100644
--- a/sec-policy/selinux-base-policy/ChangeLog
+++ b/sec-policy/selinux-base-policy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sec-policy/selinux-base-policy
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.52 2006/10/21 14:21:37 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.53 2006/10/25 11:29:41 pebenito Exp $
+
+ 25 Oct 2006; Chris PeBenito <pebenito@gentoo.org>
+ selinux-base-policy-20061015.ebuild:
+ Fix to have default POLICY_TYPES if it is empty.
21 Oct 2006; Chris PeBenito <pebenito@gentoo.org>
selinux-base-policy-20061015.ebuild:
diff --git a/sec-policy/selinux-base-policy/selinux-base-policy-20061015.ebuild b/sec-policy/selinux-base-policy/selinux-base-policy-20061015.ebuild
index 34da4269f196..1a562927072b 100644
--- a/sec-policy/selinux-base-policy/selinux-base-policy-20061015.ebuild
+++ b/sec-policy/selinux-base-policy/selinux-base-policy-20061015.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/selinux-base-policy-20061015.ebuild,v 1.2 2006/10/21 14:21:37 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/selinux-base-policy-20061015.ebuild,v 1.3 2006/10/25 11:29:41 pebenito Exp $
IUSE=""
@@ -23,6 +23,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/
src_unpack() {
+ [ -z "${POLICY_TYPES}" ] && local POLICY_TYPES="strict targeted"
+
unpack ${A}
for i in ${POLICY_TYPES}; do
@@ -33,6 +35,7 @@ src_unpack() {
src_compile() {
local OPTS="MONOLITHIC=n DISTRO=gentoo QUIET=y"
+ [ -z "${POLICY_TYPES}" ] && local POLICY_TYPES="strict targeted"
cd ${S}/refpolicy
@@ -51,6 +54,7 @@ src_compile() {
src_install() {
local OPTS="MONOLITHIC=n DISTRO=gentoo QUIET=y DESTDIR=${D}"
+ [ -z "${POLICY_TYPES}" ] && local POLICY_TYPES="strict targeted"
cd ${S}/refpolicy
@@ -76,6 +80,8 @@ src_install() {
}
pkg_postinst() {
+ [ -z "${POLICY_TYPES}" ] && local POLICY_TYPES="strict targeted"
+
if has "loadpolicy" $FEATURES ; then
for i in ${POLICY_TYPES}; do
einfo "Inserting base module into ${i} module store."