summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-22 02:50:16 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-22 02:50:16 +0000
commit50cdf445a448f4e03603b29d5a9b14eca6c7235c (patch)
tree5d1f5910b60f4356126ee94cdba51bd751cbbbd2 /skel.ebuild
parentforgot something... (Manifest recommit) (diff)
downloadgentoo-2-50cdf445a448f4e03603b29d5a9b14eca6c7235c.tar.gz
gentoo-2-50cdf445a448f4e03603b29d5a9b14eca6c7235c.tar.bz2
gentoo-2-50cdf445a448f4e03603b29d5a9b14eca6c7235c.zip
prefer econf to ./configure (opts)
Diffstat (limited to 'skel.ebuild')
-rw-r--r--skel.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/skel.ebuild b/skel.ebuild
index 6bb016c9f4ee..fe17097b38c4 100644
--- a/skel.ebuild
+++ b/skel.ebuild
@@ -100,28 +100,24 @@ S=${WORKDIR}/${P}
src_compile() {
# Most open-source packages use GNU autoconf for configuration.
- # You should use something similar to the following lines to
+ # The quickest (and preferred) way of running configure is:
+ econf || die "econf failed"
+ #
+ # You could use something similar to the following lines to
# configure your package before compilation. The "|| die" portion
# at the end will stop the build process if the command fails.
# You should use this at the end of critical commands in the build
# process. (Hint: Most commands are critical, that is, the build
# process should abort if they aren't successful.)
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ #./configure \
+ # --host=${CHOST} \
+ # --prefix=/usr \
+ # --infodir=/usr/share/info \
+ # --mandir=/usr/share/man || die "./configure failed"
# Note the use of --infodir and --mandir, above. This is to make
# this package FHS 2.2-compliant. For more information, see
# http://www.pathname.com/fhs/
- # Also note that it is cleaner and easier to use econf, which is the
- # portage shortcut to the above ./configure statement:
- #
- # econf || die
- # Note that econf will die on failure, but please use econf || die
- # for consistency.
-
# emake (previously known as pmake) is a script that calls the
# standard GNU make with parallel building options for speedier
# builds (especially on SMP systems). Try emake first. It might