summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-10-14 23:53:20 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-10-14 23:53:20 +0000
commit4e65ed8f86b951fc1649de26fbbeec34a7676c65 (patch)
treefc231854acede27f872b7a3ded12143a3dd7275f /sys-apps/acpid
parentfixor (diff)
downloadgentoo-2-4e65ed8f86b951fc1649de26fbbeec34a7676c65.tar.gz
gentoo-2-4e65ed8f86b951fc1649de26fbbeec34a7676c65.tar.bz2
gentoo-2-4e65ed8f86b951fc1649de26fbbeec34a7676c65.zip
added acpid
Diffstat (limited to 'sys-apps/acpid')
-rw-r--r--sys-apps/acpid/acpid-1.0.0.ebuild33
-rw-r--r--sys-apps/acpid/files/acpid.rc626
-rw-r--r--sys-apps/acpid/files/digest-acpid-1.0.01
3 files changed, 60 insertions, 0 deletions
diff --git a/sys-apps/acpid/acpid-1.0.0.ebuild b/sys-apps/acpid/acpid-1.0.0.ebuild
new file mode 100644
index 000000000000..efaa74b0d14c
--- /dev/null
+++ b/sys-apps/acpid/acpid-1.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Martin Schlemmer <azarah@gentoo.org>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface."
+SRC_URI="http://prdownloads.sourceforge.net/acpid/${P}.tar.gz"
+HOMEPAGE="http://acpid.sourceforge.net/"
+
+DEPEND="virtual/glibc"
+
+
+src_compile() {
+
+ # DONT compile with optimizations !
+ make INSTPREFIX=${D} ||die
+}
+
+src_install () {
+
+ make INSTPREFIX=${D} install || die
+
+ dodir /etc/acpi/events
+ exeinto /etc/acpi
+ doexe debian/default.sh
+ insinto /etc/acpi/events
+ doins debian/default
+
+ dodoc README
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/acpid.rc6 acpid
+}
diff --git a/sys-apps/acpid/files/acpid.rc6 b/sys-apps/acpid/files/acpid.rc6
new file mode 100644
index 000000000000..9252976a08cb
--- /dev/null
+++ b/sys-apps/acpid/files/acpid.rc6
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+
+depend() {
+ need localmount
+}
+
+checkconfig() {
+ if [ ! -e /proc/acpi ] ; then
+
+ eerror "ACPI support has not been compiled into the kernel"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting acpid"
+ start-stop-daemon --start --quiet --exec /usr/sbin/acpid -- -c /etc/acpi/events
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping acpid"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/acpid
+ eend $?
+}
diff --git a/sys-apps/acpid/files/digest-acpid-1.0.0 b/sys-apps/acpid/files/digest-acpid-1.0.0
new file mode 100644
index 000000000000..ce17c8394f42
--- /dev/null
+++ b/sys-apps/acpid/files/digest-acpid-1.0.0
@@ -0,0 +1 @@
+MD5 ecfc3b298b41d573b38b2de01e9fef40 acpid-1.0.0.tar.gz