summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-19 01:52:44 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-19 01:52:44 +0000
commit546368d79c3bf6d6f2a272cf462e82e695a70cb9 (patch)
tree5752933122c67d8c01fc88f00bbfd72b8b81dd6d /sys-apps/console-tools/console-tools-0.2.3-r3.ebuild
parentVersion bump, KEYWORD masked (diff)
downloadgentoo-2-546368d79c3bf6d6f2a272cf462e82e695a70cb9.tar.gz
gentoo-2-546368d79c3bf6d6f2a272cf462e82e695a70cb9.tar.bz2
gentoo-2-546368d79c3bf6d6f2a272cf462e82e695a70cb9.zip
lintool fixes for #9258
Diffstat (limited to 'sys-apps/console-tools/console-tools-0.2.3-r3.ebuild')
-rw-r--r--sys-apps/console-tools/console-tools-0.2.3-r3.ebuild32
1 files changed, 9 insertions, 23 deletions
diff --git a/sys-apps/console-tools/console-tools-0.2.3-r3.ebuild b/sys-apps/console-tools/console-tools-0.2.3-r3.ebuild
index 0af207b680e3..3415ef3de00f 100644
--- a/sys-apps/console-tools/console-tools-0.2.3-r3.ebuild
+++ b/sys-apps/console-tools/console-tools-0.2.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/console-tools/console-tools-0.2.3-r3.ebuild,v 1.10 2002/10/05 05:39:24 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/console-tools/console-tools-0.2.3-r3.ebuild,v 1.11 2002/10/19 01:52:44 vapier Exp $
IUSE="nls"
@@ -13,41 +13,31 @@ SLOT="0"
LICENSE="GPL-2"
DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc"
src_unpack() {
-
unpack ${A}
cd ${S}
patch -p1 < ${FILESDIR}/${P}.patch
- patch -p0 < ${FILESDIR}/${P}-po-Makefile.in.in-gentoo.diff
-
+ patch -p0 < ${FILESDIR}/${P}-po-Makefile.in.in-gentoo.diff
}
src_compile() {
-
local myconf
- if [ "$DEBUG" ]
- then
- myconf="--enable-debugging"
- fi
- if [ -z "`use nls`" ]
- then
- myconf="${myconf} --disable-nls"
- fi
+ [ "$DEBUG" ] && myconf="--enable-debugging"
+ [ -z "`use nls`" ] && myconf="${myconf} --disable-nls"
- try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} ${myconf}
- try make $MAKEOPTS all
+ econf --host=${CHOST} ${myconf} || die "econf died"
+ make ${MAKEOPTS} all || die "make died"
}
src_install() {
+ # DESTDIR does not work correct
+ make DESTDIR=${D} install || die "make install died"
- # DESTDIR does not work correct
- try make DESTDIR=${D} install
-
dodoc BUGS COPYING* CREDITS ChangeLog NEWS README RELEASE TODO
docinto txt
dodoc doc/*.txt doc/README.*
@@ -60,8 +50,4 @@ src_install() {
docinto txt/file-formats
dodoc doc/file-formats/*
doman doc/man/*.[1-8]
-
}
-
-
-