summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-08-11 16:52:04 +0000
committerJeroen Roovers <jer@gentoo.org>2009-08-11 16:52:04 +0000
commit44f80517dcb386b4e47f31f6968b2c98c29b59be (patch)
tree7734be0c67cb574b2fc47bb2619ed540aeb65c6c /sys-apps/debianutils
parentVersion bump to 0.5.3 (diff)
downloadgentoo-2-44f80517dcb386b4e47f31f6968b2c98c29b59be.tar.gz
gentoo-2-44f80517dcb386b4e47f31f6968b2c98c29b59be.tar.bz2
gentoo-2-44f80517dcb386b4e47f31f6968b2c98c29b59be.zip
Redo the namespace patch.
(Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'sys-apps/debianutils')
-rw-r--r--sys-apps/debianutils/ChangeLog9
-rw-r--r--sys-apps/debianutils/debianutils-3.2.1-r1.ebuild (renamed from sys-apps/debianutils/debianutils-3.2.1.ebuild)10
-rw-r--r--sys-apps/debianutils/files/debianutils-3.2.1-no-bs-namespace.patch26
3 files changed, 42 insertions, 3 deletions
diff --git a/sys-apps/debianutils/ChangeLog b/sys-apps/debianutils/ChangeLog
index b741999eea03..efd00469e1d7 100644
--- a/sys-apps/debianutils/ChangeLog
+++ b/sys-apps/debianutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/debianutils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/ChangeLog,v 1.136 2009/08/11 05:57:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/ChangeLog,v 1.137 2009/08/11 16:52:04 jer Exp $
+
+*debianutils-3.2.1-r1 (11 Aug 2009)
+
+ 11 Aug 2009; Jeroen Roovers <jer@gentoo.org> -debianutils-3.2.1.ebuild,
+ +debianutils-3.2.1-r1.ebuild,
+ +files/debianutils-3.2.1-no-bs-namespace.patch:
+ Redo the namespace patch.
*debianutils-3.2.1 (11 Aug 2009)
diff --git a/sys-apps/debianutils/debianutils-3.2.1.ebuild b/sys-apps/debianutils/debianutils-3.2.1-r1.ebuild
index 1f5fc4e1f930..2639a95f1cea 100644
--- a/sys-apps/debianutils/debianutils-3.2.1.ebuild
+++ b/sys-apps/debianutils/debianutils-3.2.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/debianutils-3.2.1.ebuild,v 1.1 2009/08/11 05:57:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/debianutils-3.2.1-r1.ebuild,v 1.1 2009/08/11 16:52:04 jer Exp $
-inherit flag-o-matic
+inherit eutils flag-o-matic
DESCRIPTION="A selection of tools from Debian"
HOMEPAGE="http://packages.qa.debian.org/d/debianutils.html"
@@ -15,6 +15,12 @@ IUSE="kernel_linux static"
PDEPEND="|| ( >=sys-apps/coreutils-6.10-r1 sys-apps/mktemp sys-freebsd/freebsd-ubin )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-no-bs-namespace.patch
+}
+
src_compile() {
use static && append-ldflags -static
econf || die
diff --git a/sys-apps/debianutils/files/debianutils-3.2.1-no-bs-namespace.patch b/sys-apps/debianutils/files/debianutils-3.2.1-no-bs-namespace.patch
new file mode 100644
index 000000000000..ea3f3349b134
--- /dev/null
+++ b/sys-apps/debianutils/files/debianutils-3.2.1-no-bs-namespace.patch
@@ -0,0 +1,26 @@
+Allow dots in the names, bug #95173. Patch by Kerin Millar.
+Re-sourced for 3.2.1
+
+--- debianutils-3.2.1/run-parts.8
++++ debianutils-3.2.1/run-parts.8
+@@ -27,7 +27,8 @@
+
+ If neither the \-\-lsbsysinit option nor the \-\-regex option is given
+ then the names must consist entirely of upper and lower case letters,
+-digits, underscores, and hyphens.
++digits, underscores, hyphens and periods. However, the name must not begin
++with a period.
+
+ If the \-\-lsbsysinit option is given, then the names must not end
+ in .dpkg\-old or .dpkg\-dist or .dpkg\-new or .dpkg\-tmp, and must
+--- debianutils-3.2.1/run-parts.c
++++ debianutils-3.2.1/run-parts.c
+@@ -501,7 +501,7 @@
+ != 0)
+ pt_regex = &tradre;
+
+- } else if ( (err = regcomp(&classicalre, "^[a-zA-Z0-9_-]+$",
++ } else if ( (err = regcomp(&classicalre, "^[a-zA-Z0-9_-][a-zA-Z0-9._-]+$",
+ REG_EXTENDED | REG_NOSUB)) != 0)
+ pt_regex = &classicalre;
+