summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-13 23:06:53 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-13 23:06:53 +0000
commit8564aa08a4cb23b54ae97a1429510911c3776bb0 (patch)
treeef5dd5cc0ec68afdc944b6acc36a4b364c29b979 /sys-apps/diffutils
parentold (diff)
downloadgentoo-2-8564aa08a4cb23b54ae97a1429510911c3776bb0.tar.gz
gentoo-2-8564aa08a4cb23b54ae97a1429510911c3776bb0.tar.bz2
gentoo-2-8564aa08a4cb23b54ae97a1429510911c3776bb0.zip
Install man pages again #177676 by Duncan and touchup build slightly.
(Portage version: 2.1.2.9)
Diffstat (limited to 'sys-apps/diffutils')
-rw-r--r--sys-apps/diffutils/ChangeLog10
-rw-r--r--sys-apps/diffutils/diffutils-2.8.7-r2.ebuild56
-rw-r--r--sys-apps/diffutils/files/diffutils-2.8.7-headers.patch12
-rw-r--r--sys-apps/diffutils/files/digest-diffutils-2.8.7-r26
4 files changed, 82 insertions, 2 deletions
diff --git a/sys-apps/diffutils/ChangeLog b/sys-apps/diffutils/ChangeLog
index 8fc8f7b19725..04bb652fa84d 100644
--- a/sys-apps/diffutils/ChangeLog
+++ b/sys-apps/diffutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/diffutils
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/ChangeLog,v 1.51 2007/02/19 23:02:41 wolf31o2 Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/ChangeLog,v 1.52 2007/06/13 23:06:53 vapier Exp $
+
+*diffutils-2.8.7-r2 (13 Jun 2007)
+
+ 13 Jun 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/diffutils-2.8.7-headers.patch, +diffutils-2.8.7-r2.ebuild:
+ Install man pages again #177676 by Duncan and touchup build slightly.
19 Feb 2007; Chris Gianelloni <wolf31o2@gentoo.org> ChangeLog:
Added Manifest2.
diff --git a/sys-apps/diffutils/diffutils-2.8.7-r2.ebuild b/sys-apps/diffutils/diffutils-2.8.7-r2.ebuild
new file mode 100644
index 000000000000..000c71891e79
--- /dev/null
+++ b/sys-apps/diffutils/diffutils-2.8.7-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.7-r2.ebuild,v 1.1 2007/06/13 23:06:53 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Tools to make diffs and compare files"
+HOMEPAGE="http://www.gnu.org/software/diffutils/diffutils.html"
+SRC_URI="ftp://alpha.gnu.org/gnu/diffutils/${P}.tar.gz
+ mirror://gentoo/${P}-i18n.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="nls static"
+
+RDEPEND="userland_GNU? ( >=sys-apps/man-pages-2.46 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Removes waitpid() call after pclose() on piped diff stream, closing
+ # bug #11728, thanks to D Wollmann <converter@dalnet-perl.org>
+ epatch "${FILESDIR}"/diffutils-2.8.4-sdiff-no-waitpid.patch
+
+ # Fix utf8 support. Patch from MDK. #71689
+ epatch "${WORKDIR}"/${P}-i18n.patch
+
+ epatch "${FILESDIR}"/${P}-headers.patch
+
+ # Make sure we don't try generating the manpages ... this requires
+ # 'help2man' which is a perl app which is not available in a
+ # stage2 / stage3 ... don't DEPEND on it or we get a DEPEND loop :(
+ # for more info, see #55479
+ touch man/*.1
+
+ # There's no reason for this crap to use the private version
+ sed -i 's:__mempcpy:mempcpy:g' lib/*.c
+
+ # Fix userpriv perm problems #76600
+ chmod ug+w config/*
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf $(use_enable nls) || die "econf"
+ emake || die "make"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog NEWS README
+}
diff --git a/sys-apps/diffutils/files/diffutils-2.8.7-headers.patch b/sys-apps/diffutils/files/diffutils-2.8.7-headers.patch
new file mode 100644
index 000000000000..d3e72d7e232f
--- /dev/null
+++ b/sys-apps/diffutils/files/diffutils-2.8.7-headers.patch
@@ -0,0 +1,12 @@
+get prototype for gettimeofday()
+
+--- src/system.h
++++ src/system.h
+@@ -93,6 +93,7 @@
+ #endif
+
+ #include <time.h>
++#include <sys/time.h>
+
+ #if HAVE_FCNTL_H
+ # include <fcntl.h>
diff --git a/sys-apps/diffutils/files/digest-diffutils-2.8.7-r2 b/sys-apps/diffutils/files/digest-diffutils-2.8.7-r2
new file mode 100644
index 000000000000..90aa20a30302
--- /dev/null
+++ b/sys-apps/diffutils/files/digest-diffutils-2.8.7-r2
@@ -0,0 +1,6 @@
+MD5 406c758a923f531f350edb82423aef56 diffutils-2.8.7-i18n.patch.bz2 4388
+RMD160 c1d8640f86e2362551d1e94893f7f0079839fa75 diffutils-2.8.7-i18n.patch.bz2 4388
+SHA256 a6a8f47d75ea9e61a0b9dba45f4a85bf1d54572c191bb7ad9e0cb7e8edd867c0 diffutils-2.8.7-i18n.patch.bz2 4388
+MD5 18d6587cb915e7aa110a5d463d6ed156 diffutils-2.8.7.tar.gz 1057977
+RMD160 389518f9008e56a283884809d7abac4b3cb8edce diffutils-2.8.7.tar.gz 1057977
+SHA256 53d9c10830ac322c00dfcccf60d961014e767da86d2c802ccc5cbad7e7aea07c diffutils-2.8.7.tar.gz 1057977