summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-10-14 09:58:36 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-10-14 09:58:36 +0000
commitaeed95f6d76b2012cb84d92278dde11e5b642ce5 (patch)
tree4c8df305cd3675d06a2c98d0c637f6a507d62640 /sys-apps/diffutils
parentMasked media-libs/SoQt (diff)
downloadgentoo-2-aeed95f6d76b2012cb84d92278dde11e5b642ce5.tar.gz
gentoo-2-aeed95f6d76b2012cb84d92278dde11e5b642ce5.tar.bz2
gentoo-2-aeed95f6d76b2012cb84d92278dde11e5b642ce5.zip
try to fix build problem on pentium4 with -j5 or higher
Diffstat (limited to 'sys-apps/diffutils')
-rw-r--r--sys-apps/diffutils/ChangeLog11
-rw-r--r--sys-apps/diffutils/diffutils-2.8.4-r1.ebuild67
-rw-r--r--sys-apps/diffutils/files/diffutils-2.8.4-fix-multi-job-build.patch19
-rw-r--r--sys-apps/diffutils/files/digest-diffutils-2.8.4-r11
4 files changed, 97 insertions, 1 deletions
diff --git a/sys-apps/diffutils/ChangeLog b/sys-apps/diffutils/ChangeLog
index 77ed93ad3680..bff25976ce11 100644
--- a/sys-apps/diffutils/ChangeLog
+++ b/sys-apps/diffutils/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-apps/diffutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/ChangeLog,v 1.6 2002/09/29 12:00:39 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/ChangeLog,v 1.7 2002/10/14 09:58:36 azarah Exp $
+
+*diffutils-2.8.4-r1 (14 Oct 2002)
+
+ 14 Oct 2002; Martin Schlemmer <azarah@gentoo.org> :
+
+ Build fails with make -j5 or greater on pentium4. This is because
+ the .c.o rule should depend on paths.h, else they are being compiled
+ at the same time of its generation. This *should* hopefully fix
+ this problem. Cannot test it now though, as this is a celeron :/
*diffutils-2.8.4 (25 Sep 2002)
diff --git a/sys-apps/diffutils/diffutils-2.8.4-r1.ebuild b/sys-apps/diffutils/diffutils-2.8.4-r1.ebuild
new file mode 100644
index 000000000000..61f6d22989f7
--- /dev/null
+++ b/sys-apps/diffutils/diffutils-2.8.4-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r1.ebuild,v 1.1 2002/10/14 09:58:36 azarah Exp $
+
+IUSE="nls build"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools to make diffs and compare files"
+SRC_URI="ftp://alpha.gnu.org/gnu/diffutils/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/diffutils/diffutils.html"
+
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ !build? ( sys-apps/texinfo )"
+
+RDEPEND="virtual/glibc"
+
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ if [ -n "`use build`" ]
+ then
+ #disable texinfo building so we can remove the dep
+ cp Makefile.in Makefile.in.orig
+ sed -e 's:SUBDIRS = doc:SUBDIRS =:' \
+ Makefile.in.orig > Makefile.in
+ fi
+
+ # Build fails with make -j5 or greater on pentium4. This is because
+ # the .c.o rule should depend on paths.h, else they are being compiled
+ # at the same time of its generation. This *should* hopefully fix
+ # this problem. Cannot test it now though, as this is a celeron :/
+ # <azarah@gentoo.org> (14 Oct 2002)
+ cd ${S}; patch -p1 < ${FILESDIR}/${P}-fix-multi-job-build.patch || die
+}
+
+src_compile() {
+ local myconf=""
+ [ -z "`use nls`" ] && myconf="--disable-nls"
+
+ econf --build=${CHOST} \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ datadir=${D}/usr/share \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share/info
+ fi
+}
+
diff --git a/sys-apps/diffutils/files/diffutils-2.8.4-fix-multi-job-build.patch b/sys-apps/diffutils/files/diffutils-2.8.4-fix-multi-job-build.patch
new file mode 100644
index 000000000000..a1c29e7f7036
--- /dev/null
+++ b/sys-apps/diffutils/files/diffutils-2.8.4-fix-multi-job-build.patch
@@ -0,0 +1,19 @@
+diff -urN diffutils-2.8.4/src/Makefile.in diffutils-2.8.4.azarah/src/Makefile.in
+--- diffutils-2.8.4/src/Makefile.in 2002-06-28 09:04:20.000000000 +0200
++++ diffutils-2.8.4.azarah/src/Makefile.in 2002-10-14 11:49:11.000000000 +0200
+@@ -254,13 +254,13 @@
+ distclean-depend:
+ -rm -rf ./$(DEPDIR)
+
+-.c.o:
++.c.o: paths.h
+ @AMDEP_TRUE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
+ @AMDEP_TRUE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@
+ @AMDEP_TRUE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+ $(COMPILE) -c `test -f '$<' || echo '$(srcdir)/'`$<
+
+-.c.obj:
++.c.obj: paths.h
+ @AMDEP_TRUE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
+ @AMDEP_TRUE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@
+ @AMDEP_TRUE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
diff --git a/sys-apps/diffutils/files/digest-diffutils-2.8.4-r1 b/sys-apps/diffutils/files/digest-diffutils-2.8.4-r1
new file mode 100644
index 000000000000..ab1523b47820
--- /dev/null
+++ b/sys-apps/diffutils/files/digest-diffutils-2.8.4-r1
@@ -0,0 +1 @@
+MD5 a9c028579abc79ecd6842d60a13abf1d diffutils-2.8.4.tar.gz 828766