summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-05-06 23:36:03 +0000
committerMike Frysinger <vapier@gentoo.org>2009-05-06 23:36:03 +0000
commitdc4c1d3cdd6f25bb5bad0dcbfb41d94ee8b1e97f (patch)
tree919ec50511fce702f86913ad6b6818713f6e3282 /sys-apps/file
parentVersion bump KDE 4.2.3 (diff)
downloadgentoo-2-dc4c1d3cdd6f25bb5bad0dcbfb41d94ee8b1e97f.tar.gz
gentoo-2-dc4c1d3cdd6f25bb5bad0dcbfb41d94ee8b1e97f.tar.bz2
gentoo-2-dc4c1d3cdd6f25bb5bad0dcbfb41d94ee8b1e97f.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog7
-rw-r--r--sys-apps/file/file-5.03.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index a904303fc8d1..80bf0036d8ac 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.168 2009/05/05 01:02:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.169 2009/05/06 23:36:03 vapier Exp $
+
+*file-5.03 (06 May 2009)
+
+ 06 May 2009; Mike Frysinger <vapier@gentoo.org> +file-5.03.ebuild:
+ Version bump.
*file-5.02 (05 May 2009)
diff --git a/sys-apps/file/file-5.03.ebuild b/sys-apps/file/file-5.03.ebuild
new file mode 100644
index 000000000000..9bd19962bc78
--- /dev/null
+++ b/sys-apps/file/file-5.03.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.03.ebuild,v 1.1 2009/05/06 23:36:03 vapier Exp $
+
+inherit eutils distutils libtool flag-o-matic
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="python"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-4.15-libtool.patch #99593
+
+ elibtoolize
+ epunt_cxx
+
+ # make sure python links against the current libmagic #54401
+ sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+
+ # only one data file, so put it into /usr/share/misc/
+# sed -i '/^pkgdatadir/s:/@PACKAGE@::' $(find -name Makefile.in)
+}
+
+src_compile() {
+ # file uses things like strndup() and wcwidth()
+ append-flags -D_GNU_SOURCE
+
+ econf || die
+ emake || die
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils_src_install
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}