summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-29 16:44:20 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-29 16:44:20 +0000
commitbae4f19215e44bf88feb7e5bc1228217d95ccc6e (patch)
tree559647857ae21bd840f138e7af81cdf341c926aa /sys-apps/gptfdisk
parentVersion bump (diff)
downloadgentoo-2-bae4f19215e44bf88feb7e5bc1228217d95ccc6e.tar.gz
gentoo-2-bae4f19215e44bf88feb7e5bc1228217d95ccc6e.tar.bz2
gentoo-2-bae4f19215e44bf88feb7e5bc1228217d95ccc6e.zip
sys-apps/gptfdisk: Version BUmp and make icu support optional, #428410, #461454
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sys-apps/gptfdisk')
-rw-r--r--sys-apps/gptfdisk/ChangeLog8
-rw-r--r--sys-apps/gptfdisk/gptfdisk-0.8.4.ebuild14
-rw-r--r--sys-apps/gptfdisk/gptfdisk-0.8.5.ebuild11
-rw-r--r--sys-apps/gptfdisk/gptfdisk-0.8.6.ebuild48
-rw-r--r--sys-apps/gptfdisk/metadata.xml8
5 files changed, 81 insertions, 8 deletions
diff --git a/sys-apps/gptfdisk/ChangeLog b/sys-apps/gptfdisk/ChangeLog
index 4b21a10327da..b860094aa660 100644
--- a/sys-apps/gptfdisk/ChangeLog
+++ b/sys-apps/gptfdisk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/gptfdisk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gptfdisk/ChangeLog,v 1.25 2013/03/09 19:37:27 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gptfdisk/ChangeLog,v 1.26 2013/03/29 16:44:20 jlec Exp $
+
+*gptfdisk-0.8.6 (29 Mar 2013)
+
+ 29 Mar 2013; Justin Lecher <jlec@gentoo.org> gptfdisk-0.8.4.ebuild,
+ gptfdisk-0.8.5.ebuild, +gptfdisk-0.8.6.ebuild, metadata.xml:
+ Version BUmp and make icu support optional, #428410, #461454
09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> gptfdisk-0.8.5.ebuild:
Stable for sparc, wrt bug #427550
diff --git a/sys-apps/gptfdisk/gptfdisk-0.8.4.ebuild b/sys-apps/gptfdisk/gptfdisk-0.8.4.ebuild
index f63897cd5e12..5ee38034bc50 100644
--- a/sys-apps/gptfdisk/gptfdisk-0.8.4.ebuild
+++ b/sys-apps/gptfdisk/gptfdisk-0.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gptfdisk/gptfdisk-0.8.4.ebuild,v 1.9 2013/01/20 13:18:24 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gptfdisk/gptfdisk-0.8.4.ebuild,v 1.10 2013/03/29 16:44:20 jlec Exp $
EAPI=4
@@ -15,11 +15,21 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm ~ia64 ~mips ppc ppc64 x86 ~amd64-linux ~x86-linux"
IUSE=""
-RDEPEND="dev-libs/icu
+RDEPEND="
+ dev-libs/icu
dev-libs/popt
sys-libs/ncurses"
DEPEND="${RDEPEND}"
+src_prepare() {
+ sed \
+ -e '/g++/s:=:?=:g' \
+ -e "s:-lncurses:$($(tc-getPKG_CONFIG) --libs ncurses):g" \
+ -i Makefile || die
+
+ tc-export CXX
+}
+
src_compile() {
emake CXX="$(tc-getCXX)"
}
diff --git a/sys-apps/gptfdisk/gptfdisk-0.8.5.ebuild b/sys-apps/gptfdisk/gptfdisk-0.8.5.ebuild
index d176582dca79..93ec7ed12486 100644
--- a/sys-apps/gptfdisk/gptfdisk-0.8.5.ebuild
+++ b/sys-apps/gptfdisk/gptfdisk-0.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gptfdisk/gptfdisk-0.8.5.ebuild,v 1.8 2013/03/09 19:37:27 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gptfdisk/gptfdisk-0.8.5.ebuild,v 1.9 2013/03/29 16:44:20 jlec Exp $
EAPI=4
inherit toolchain-funcs
@@ -21,6 +21,15 @@ RDEPEND="dev-libs/icu
DEPEND="${RDEPEND}
virtual/pkgconfig"
+src_prepare() {
+ sed \
+ -e '/g++/s:=:?=:g' \
+ -e "s:-lncurses:$($(tc-getPKG_CONFIG) --libs ncurses):g" \
+ -i Makefile || die
+
+ tc-export CXX
+}
+
src_compile() {
emake CXX="$(tc-getCXX) $($(tc-getPKG_CONFIG) --variable=CXXFLAGS icu-io icu-uc) ${CXXFLAGS}" #439696
}
diff --git a/sys-apps/gptfdisk/gptfdisk-0.8.6.ebuild b/sys-apps/gptfdisk/gptfdisk-0.8.6.ebuild
new file mode 100644
index 000000000000..036301c1b589
--- /dev/null
+++ b/sys-apps/gptfdisk/gptfdisk-0.8.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gptfdisk/gptfdisk-0.8.6.ebuild,v 1.1 2013/03/29 16:44:20 jlec Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="GPT partition table manipulator for Linux"
+HOMEPAGE="http://www.rodsbooks.com/gdisk/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="kernel_linux +icu"
+
+RDEPEND="
+ dev-libs/popt
+ >=sys-libs/ncurses-5.7-r7
+ icu? ( dev-libs/icu )
+ kernel_linux? ( sys-apps/util-linux )" # libuuid
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ if ! use icu; then
+ sed \
+ -e 's:-licuio::g' \
+ -e 's:-licuuc::g' \
+ -e 's:-D USE_UTF16::g' \
+ -i Makefile || die
+ append-cxxflags $($(tc-getPKG_CONFIG) --variable=CXXFLAGS icu-io icu-uc)
+ fi
+
+ sed \
+ -e '/g++/s:=:?=:g' \
+ -e "s:-lncurses:$($(tc-getPKG_CONFIG) --libs ncurses):g" \
+ -i Makefile || die
+
+ tc-export CXX
+}
+
+src_install() {
+ dosbin gdisk sgdisk cgdisk fixparts
+ doman *.8
+ dodoc NEWS README
+}
diff --git a/sys-apps/gptfdisk/metadata.xml b/sys-apps/gptfdisk/metadata.xml
index 247f45889c01..f233055c02bb 100644
--- a/sys-apps/gptfdisk/metadata.xml
+++ b/sys-apps/gptfdisk/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>alexxy@gentoo.org</email>
- <name>Alexey Shvetsov</name>
- </maintainer>
+ <maintainer>
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
</pkgmetadata>