summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-08-01 22:25:15 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-08-01 22:25:15 +0000
commit57e3a1c95150b7350aa33d39b12d8c2264d98fc3 (patch)
tree60c3af422992b301903eb5816675ed5ad86e8b5d /sys-apps/hdparm
parentUse xfconf.eclass. (diff)
downloadgentoo-2-57e3a1c95150b7350aa33d39b12d8c2264d98fc3.tar.gz
gentoo-2-57e3a1c95150b7350aa33d39b12d8c2264d98fc3.tar.bz2
gentoo-2-57e3a1c95150b7350aa33d39b12d8c2264d98fc3.zip
Another bump, upstream says fixes to TRIM.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/hdparm')
-rw-r--r--sys-apps/hdparm/ChangeLog7
-rw-r--r--sys-apps/hdparm/hdparm-9.20.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/sys-apps/hdparm/ChangeLog b/sys-apps/hdparm/ChangeLog
index 505319593d18..aff5cc69a774 100644
--- a/sys-apps/hdparm/ChangeLog
+++ b/sys-apps/hdparm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hdparm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hdparm/ChangeLog,v 1.197 2009/08/01 21:17:11 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hdparm/ChangeLog,v 1.198 2009/08/01 22:25:15 robbat2 Exp $
+
+*hdparm-9.20 (01 Aug 2009)
+
+ 01 Aug 2009; Robin H. Johnson <robbat2@gentoo.org> +hdparm-9.20.ebuild:
+ Another bump, upstream says fixes to TRIM.
*hdparm-9.18 (01 Aug 2009)
diff --git a/sys-apps/hdparm/hdparm-9.20.ebuild b/sys-apps/hdparm/hdparm-9.20.ebuild
new file mode 100644
index 000000000000..93ebe0e6530b
--- /dev/null
+++ b/sys-apps/hdparm/hdparm-9.20.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hdparm/hdparm-9.20.ebuild,v 1.1 2009/08/01 22:25:15 robbat2 Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to change hard drive performance parameters"
+HOMEPAGE="http://sourceforge.net/projects/hdparm/"
+SRC_URI="mirror://sourceforge/hdparm/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^CFLAGS/ s:-O2:${CFLAGS}:" \
+ -e "/^LDFLAGS/ s:-s:${LDFLAGS}:" \
+ Makefile || die "sed"
+}
+
+src_compile() {
+ emake STRIP=: CC="$(tc-getCC)" || die "compile error"
+}
+
+src_install() {
+ into /
+ dosbin hdparm contrib/idectl || die "dosbin"
+
+ newinitd "${FILESDIR}"/hdparm-init-8 hdparm
+ newconfd "${FILESDIR}"/hdparm-conf.d.3 hdparm
+
+ doman hdparm.8
+ dodoc hdparm.lsm Changelog README.acoustic hdparm-sysconfig
+}