summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-08-09 09:03:34 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-08-09 09:03:34 +0000
commit04291ecff7dca2bbd92b08975f33fab201073c90 (patch)
treebfdf987bf8392bce187ef90181cfecd7fd5c73d3 /sys-apps/hwloc
parentMask GPU related flags for sys-apps/hwloc on most profiles (diff)
downloadgentoo-2-04291ecff7dca2bbd92b08975f33fab201073c90.tar.gz
gentoo-2-04291ecff7dca2bbd92b08975f33fab201073c90.tar.bz2
gentoo-2-04291ecff7dca2bbd92b08975f33fab201073c90.zip
Version bump wrt #469708 by Mario Kicherer <dev@kicherer.org>
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'sys-apps/hwloc')
-rw-r--r--sys-apps/hwloc/ChangeLog8
-rw-r--r--sys-apps/hwloc/hwloc-1.7.1.ebuild64
-rw-r--r--sys-apps/hwloc/metadata.xml5
3 files changed, 75 insertions, 2 deletions
diff --git a/sys-apps/hwloc/ChangeLog b/sys-apps/hwloc/ChangeLog
index 77ac1e00105a..0ec774602adb 100644
--- a/sys-apps/hwloc/ChangeLog
+++ b/sys-apps/hwloc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/hwloc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.35 2013/03/21 04:33:07 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.36 2013/08/09 09:03:34 xarthisius Exp $
+
+*hwloc-1.7.1 (09 Aug 2013)
+
+ 09 Aug 2013; Kacper Kowalik <xarthisius@gentoo.org> +hwloc-1.7.1.ebuild,
+ metadata.xml:
+ Version bump wrt #469708 by Mario Kicherer <dev@kicherer.org>
*hwloc-1.6.2 (21 Mar 2013)
diff --git a/sys-apps/hwloc/hwloc-1.7.1.ebuild b/sys-apps/hwloc/hwloc-1.7.1.ebuild
new file mode 100644
index 000000000000..3f164595c085
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-1.7.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.7.1.ebuild,v 1.1 2013/08/09 09:03:34 xarthisius Exp $
+
+EAPI=5
+
+inherit multilib versionator
+
+MY_PV=v$(get_version_component_range 1-2)
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
+SRC_URI="http://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
+IUSE="cairo cuda debug gl +numa opencl +pci plugins svg static-libs xml X"
+
+# TODO opencl only works with AMD so no virtual
+
+RDEPEND="sys-libs/ncurses
+ cairo? ( x11-libs/cairo[X?,svg?] )
+ cuda? ( dev-util/nvidia-cuda-toolkit )
+ gl? ( media-video/nvidia-settings )
+ opencl? ( x11-drivers/ati-drivers )
+ pci? (
+ sys-apps/pciutils
+ x11-libs/libpciaccess
+ )
+ plugins? ( sys-devel/libtool )
+ numa? ( sys-process/numactl )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README VERSION )
+
+src_configure() {
+ export HWLOC_PKG_CONFIG=$(tc-getPKG_CONFIG) #393467
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable cairo) \
+ $(use_enable cuda) \
+ $(use_enable debug) \
+ $(use_enable gl) \
+ $(use_enable opencl) \
+ $(use_enable pci) \
+ $(use_enable pci libpci) \
+ $(use_enable plugins) \
+ $(use_enable numa libnuma) \
+ $(use_enable static-libs static) \
+ $(use_enable xml libxml2) \
+ $(use_with X x) \
+ --disable-silent-rules
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ rm "${D}"/usr/$(get_libdir)/lib${PN}.la
+ use plugins && rm -f "${D}"/usr/$(get_libdir)/${PN}/*.la
+ fi
+}
diff --git a/sys-apps/hwloc/metadata.xml b/sys-apps/hwloc/metadata.xml
index 5ae4fec3e6f0..2c42c390e605 100644
--- a/sys-apps/hwloc/metadata.xml
+++ b/sys-apps/hwloc/metadata.xml
@@ -15,8 +15,11 @@
hardware so as to exploit it accordingly and efficiently.
</longdescription>
<use>
+ <flag name='cuda'>Enable CUDA device discovery</flag>
+ <flag name='gl'>Enable GL display device discovery (NVCtrl)</flag>
<flag name='numa'>Add support for numa memory allocation</flag>
+ <flag name='opencl'>Enable OpenCL device discovery (AMD only)</flag>
<flag name='pci'>Enable PCI device discovery using libpci</flag>
- <flag name='plugins'>Build hwloc components as plugins so that the hwloc core library does not directly depend on their dependencies (for instance the libpci library)</flag>
+ <flag name='plugins'>Build hwloc components as plugins so that the hwloc core library does not directly depend on their dependencies (for instance the libpci library)</flag>
</use>
</pkgmetadata>