summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-02-28 17:25:45 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-02-28 17:25:45 +0000
commit1ee0187ab1cec5bbf049c87859b390769aabab62 (patch)
tree95b2c13724c5d9f1c62c0bb1be47aee790d69654 /sys-apps/hwloc
parentVersion bump (diff)
downloadgentoo-2-1ee0187ab1cec5bbf049c87859b390769aabab62.tar.gz
gentoo-2-1ee0187ab1cec5bbf049c87859b390769aabab62.tar.bz2
gentoo-2-1ee0187ab1cec5bbf049c87859b390769aabab62.zip
Fixed underlinking for gl flag, thanks Andrew Savchenko bug #502956
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sys-apps/hwloc')
-rw-r--r--sys-apps/hwloc/ChangeLog6
-rw-r--r--sys-apps/hwloc/files/hwloc-1.8.1-gl.patch11
-rw-r--r--sys-apps/hwloc/hwloc-1.8.1.ebuild5
3 files changed, 20 insertions, 2 deletions
diff --git a/sys-apps/hwloc/ChangeLog b/sys-apps/hwloc/ChangeLog
index 6e63400fd8ea..e3469cf58014 100644
--- a/sys-apps/hwloc/ChangeLog
+++ b/sys-apps/hwloc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/hwloc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.43 2014/02/17 11:33:01 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.44 2014/02/28 17:25:45 bicatali Exp $
+
+ 28 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/hwloc-1.8.1-gl.patch, hwloc-1.8.1.ebuild:
+ Fixed underlinking for gl flag, thanks Andrew Savchenko bug #502956
*hwloc-1.8.1 (16 Feb 2014)
diff --git a/sys-apps/hwloc/files/hwloc-1.8.1-gl.patch b/sys-apps/hwloc/files/hwloc-1.8.1-gl.patch
new file mode 100644
index 000000000000..47daa9593377
--- /dev/null
+++ b/sys-apps/hwloc/files/hwloc-1.8.1-gl.patch
@@ -0,0 +1,11 @@
+--- hwloc-1.8.1/config/hwloc.m4.orig 2014-01-30 17:46:58.000000000 +0400
++++ hwloc-1.8.1/config/hwloc.m4 2014-02-27 13:46:28.587238873 +0400
+@@ -948,7 +948,7 @@
+ hwloc_gl_happy=no])
+
+ AC_CHECK_HEADERS([NVCtrl/NVCtrl.h], [
+- AC_CHECK_LIB([XNVCtrl], [XNVCTRLQueryTargetAttribute], [:], [hwloc_gl_happy=no], [-lXext])
++ AC_CHECK_LIB([XNVCtrl], [XNVCTRLQueryTargetAttribute], [:], [hwloc_gl_happy=no], [-lXext -lX11])
+ ], [hwloc_gl_happy=no])
+
+ if test "x$hwloc_gl_happy" = "xyes"; then
diff --git a/sys-apps/hwloc/hwloc-1.8.1.ebuild b/sys-apps/hwloc/hwloc-1.8.1.ebuild
index b26035a60812..3fa4f78edffb 100644
--- a/sys-apps/hwloc/hwloc-1.8.1.ebuild
+++ b/sys-apps/hwloc/hwloc-1.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.8.1.ebuild,v 1.1 2014/02/16 02:43:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.8.1.ebuild,v 1.2 2014/02/28 17:25:45 bicatali Exp $
EAPI=5
@@ -36,6 +36,9 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS NEWS README VERSION )
+PATCHES=( "${FILESDIR}/${P}-gl.patch" )
+AUTOTOOLS_AUTORECONF=1
+
src_prepare() {
if use cuda ; then
append-cflags -I/opt/cuda/include