summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-06 02:02:39 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-06 02:02:39 +0000
commit5f78eafa9b57fc09c78188fb322dd75e9d0e3042 (patch)
tree8cdf3c2238c282813fc8a344934727e30481b8bf /sys-apps/initng
parentold (diff)
downloadgentoo-2-5f78eafa9b57fc09c78188fb322dd75e9d0e3042.tar.gz
gentoo-2-5f78eafa9b57fc09c78188fb322dd75e9d0e3042.tar.bz2
gentoo-2-5f78eafa9b57fc09c78188fb322dd75e9d0e3042.zip
Version bump #108172 by Erdroh Moshan and delete scripts that are installed by other packages #108179 by Henrique Ferreiro.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/initng')
-rw-r--r--sys-apps/initng/ChangeLog9
-rw-r--r--sys-apps/initng/files/digest-initng-0.3.11
-rw-r--r--sys-apps/initng/initng-0.3.1.ebuild35
-rw-r--r--sys-apps/initng/initng-9999.ebuild9
4 files changed, 49 insertions, 5 deletions
diff --git a/sys-apps/initng/ChangeLog b/sys-apps/initng/ChangeLog
index 7eb12c1e8581..88fefa53a175 100644
--- a/sys-apps/initng/ChangeLog
+++ b/sys-apps/initng/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/initng
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/ChangeLog,v 1.23 2005/09/27 23:05:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/ChangeLog,v 1.24 2005/10/06 02:02:39 vapier Exp $
+
+*initng-0.3.1 (06 Oct 2005)
+
+ 06 Oct 2005; Mike Frysinger <vapier@gentoo.org> +initng-0.3.1.ebuild,
+ initng-9999.ebuild:
+ Version bump #108172 by Erdroh Moshan and delete scripts that are installed
+ by other packages #108179 by Henrique Ferreiro.
*initng-0.3.0 (27 Sep 2005)
diff --git a/sys-apps/initng/files/digest-initng-0.3.1 b/sys-apps/initng/files/digest-initng-0.3.1
new file mode 100644
index 000000000000..c8c5a2562dc9
--- /dev/null
+++ b/sys-apps/initng/files/digest-initng-0.3.1
@@ -0,0 +1 @@
+MD5 a6888a6e7e4a2e29057b128934c0b723 initng-0.3.1.tar.bz2 538498
diff --git a/sys-apps/initng/initng-0.3.1.ebuild b/sys-apps/initng/initng-0.3.1.ebuild
new file mode 100644
index 000000000000..5772ada76bb6
--- /dev/null
+++ b/sys-apps/initng/initng-0.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-0.3.1.ebuild,v 1.1 2005/10/06 02:02:39 vapier Exp $
+
+DESCRIPTION="A next generation init replacement"
+HOMEPAGE="http://initng.thinktux.net/"
+SRC_URI="http://initng.thinktux.net/download/v${PV:0:3}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug"
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ --with-doc-dir=/usr/share/doc/${PF} \
+ --prefix=/ \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ # Dont need libtool linker scripts, so punt em
+ find "${D}" -name '*.la' -exec rm {} \;
+ # other packages install these
+ rm -f "${D}"/sbin/{ifplugd,wpa_cli}.action
+ dodoc README FAQ AUTHORS ChangeLog NEWS TEMPLATE_HEADER TODO
+}
+
+pkg_postinst() {
+ einfo "remember to add init=/sbin/initng in your grub or lilo config"
+ einfo "to use initng Happy testing."
+}
diff --git a/sys-apps/initng/initng-9999.ebuild b/sys-apps/initng/initng-9999.ebuild
index efa7f75d929b..23a50ca0e3db 100644
--- a/sys-apps/initng/initng-9999.ebuild
+++ b/sys-apps/initng/initng-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-9999.ebuild,v 1.2 2005/09/21 23:39:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-9999.ebuild,v 1.3 2005/10/06 02:02:39 vapier Exp $
ESVN_REPO_URI="http://svn.initng.thinktux.net/initng"
ESVN_PROJECT="initng"
@@ -20,9 +20,6 @@ S=${WORKDIR}/${PN}
src_unpack() {
subversion_src_unpack
./autogen.sh || die "autogen failed"
- sed -i \
- -e '/CFLAGS=.*ALL_CFLAGS/s|.*|:;|' \
- configure || die "sed configure"
}
src_compile() {
@@ -36,6 +33,10 @@ src_compile() {
src_install() {
make install DESTDIR="${D}" || die
+ # Dont need libtool linker scripts, so punt em
+ find "${D}" -name '*.la' -exec rm {} \;
+ # other packages install these
+ rm -f "${D}"/sbin/{ifplugd,wpa_cli}.action
dodoc README FAQ AUTHORS ChangeLog NEWS TEMPLATE_HEADER TODO
}