summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-23 02:29:22 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-23 02:29:22 +0000
commit6952f2f2095f69e938064ffbf101af6ff2e2fcf6 (patch)
tree6d6eb1ef074e20cb368fb7ed581f7c9a0f1dd547 /sys-apps/iproute2/files
parentStable for HPPA (bug #285213). (diff)
downloadgentoo-2-6952f2f2095f69e938064ffbf101af6ff2e2fcf6.tar.gz
gentoo-2-6952f2f2095f69e938064ffbf101af6ff2e2fcf6.tar.bz2
gentoo-2-6952f2f2095f69e938064ffbf101af6ff2e2fcf6.zip
Allow people to disable ipv6 support #326849 by Pinkbyte.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/iproute2/files')
-rw-r--r--sys-apps/iproute2/files/iproute2-2.6.35-no-ipv6.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/iproute2/files/iproute2-2.6.35-no-ipv6.patch b/sys-apps/iproute2/files/iproute2-2.6.35-no-ipv6.patch
new file mode 100644
index 000000000000..d82c8873344c
--- /dev/null
+++ b/sys-apps/iproute2/files/iproute2-2.6.35-no-ipv6.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/326849
+
+allow ipv6 to be disabled
+
+--- iproute2-2.6.31/ip/iptunnel.c
++++ iproute2-2.6.31/ip/iptunnel.c
+@@ -456,13 +456,6 @@ int do_iptunnel(int argc, char **argv)
+ break;
+ case AF_INET:
+ break;
+- /*
+- * This is silly enough but we have no easy way to make it
+- * protocol-independent because of unarranged structure between
+- * IPv4 and IPv6.
+- */
+- case AF_INET6:
+- return do_ip6tunnel(argc, argv);
+ default:
+ fprintf(stderr, "Unsupported family:%d\n", preferred_family);
+ exit(-1);
+--- iproute2-2.6.31/ip/Makefile
++++ iproute2-2.6.31/ip/Makefile
+@@ -1,4 +1,4 @@
+ IPOBJ=ip.o ipaddress.o ipaddrlabel.o iproute.o iprule.o \
+- rtm_map.o iptunnel.o ip6tunnel.o tunnel.o ipneigh.o ipntable.o iplink.o \
++ rtm_map.o iptunnel.o tunnel.o ipneigh.o ipntable.o iplink.o \
+ ipmaddr.o ipmonitor.o ipmroute.o ipprefix.o \