summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-10-18 21:41:55 +0000
committerMike Frysinger <vapier@gentoo.org>2011-10-18 21:41:55 +0000
commit8b36eb29db3c9d1668eacd41b0133af8efe8c2a8 (patch)
treef635e5ad254a42be980366a3b3121bfe3295961e /sys-apps/iproute2
parentOnly skip KDE for gdu-notification-daemon autostart. (diff)
downloadgentoo-2-8b36eb29db3c9d1668eacd41b0133af8efe8c2a8.tar.gz
gentoo-2-8b36eb29db3c9d1668eacd41b0133af8efe8c2a8.tar.bz2
gentoo-2-8b36eb29db3c9d1668eacd41b0133af8efe8c2a8.zip
Fix parallel builds in the tc subdir.
(Portage version: 2.2.0_alpha65/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/iproute2')
-rw-r--r--sys-apps/iproute2/ChangeLog6
-rw-r--r--sys-apps/iproute2/files/iproute2-2.6.38-parallel-build.patch40
-rw-r--r--sys-apps/iproute2/iproute2-2.6.38.ebuild5
3 files changed, 48 insertions, 3 deletions
diff --git a/sys-apps/iproute2/ChangeLog b/sys-apps/iproute2/ChangeLog
index 6d7e837276b2..63f70f3b5bc9 100644
--- a/sys-apps/iproute2/ChangeLog
+++ b/sys-apps/iproute2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/iproute2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.173 2011/07/31 18:33:22 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.174 2011/10/18 21:41:55 vapier Exp $
+
+ 18 Oct 2011; Mike Frysinger <vapier@gentoo.org> iproute2-2.6.38.ebuild,
+ +files/iproute2-2.6.38-parallel-build.patch:
+ Fix parallel builds in the tc subdir.
31 Jul 2011; Matt Turner <mattst88@gentoo.org> iproute2-2.6.29.1-r1.ebuild,
iproute2-2.6.35-r2.ebuild, iproute2-2.6.35-r3.ebuild, iproute2-2.6.38.ebuild,
diff --git a/sys-apps/iproute2/files/iproute2-2.6.38-parallel-build.patch b/sys-apps/iproute2/files/iproute2-2.6.38-parallel-build.patch
new file mode 100644
index 000000000000..7966cfce5044
--- /dev/null
+++ b/sys-apps/iproute2/files/iproute2-2.6.38-parallel-build.patch
@@ -0,0 +1,40 @@
+sent upstream already
+
+From f8a783bbe98b0fe5aaedbf623bc70471b88c9187 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 18 Oct 2011 17:36:55 -0400
+Subject: [PATCH] tc: fix parallel build file with lex/yacc
+
+Building iproute2 in parallel might hit the race failure:
+ emp_ematch.l:2:30: fatal error: emp_ematch.yacc.h:
+ No such file or directory
+ make[1]: *** [emp_ematch.lex.o] Error 1
+
+This is because we currently allow the yacc/lex files to generate and
+compile in parallel. So add a simple dependency to make sure yacc has
+finished before we attempt to compile the lex output.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ tc/Makefile | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+diff --git a/tc/Makefile b/tc/Makefile
+index 08aa4ce..b2ca165 100644
+--- a/tc/Makefile
++++ b/tc/Makefile
+@@ -136,6 +136,11 @@ m_xt_old.so: m_xt_old.c
+ %.lex.c: %.l
+ $(LEX) $(LEXFLAGS) -o$@ $<
+
++# our lexer includes the header from yacc, so make sure
++# we don't attempt to compile it before the header has
++# been generated as part of the yacc step.
++emp_ematch.lex.o: emp_ematch.yacc.c
++
+ ifneq ($(SHARED_LIBS),y)
+
+ tc: static-syms.o
+--
+1.7.6.1
+
diff --git a/sys-apps/iproute2/iproute2-2.6.38.ebuild b/sys-apps/iproute2/iproute2-2.6.38.ebuild
index d812041623e6..9a04fe7c566a 100644
--- a/sys-apps/iproute2/iproute2-2.6.38.ebuild
+++ b/sys-apps/iproute2/iproute2-2.6.38.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.38.ebuild,v 1.2 2011/07/31 18:33:22 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.38.ebuild,v 1.3 2011/10/18 21:41:55 vapier Exp $
EAPI=4
@@ -38,7 +38,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
PATCHES=(
- "${FILESDIR}/${PN}-2.6.29.1-hfsc.patch" #291907
+ "${FILESDIR}"/${PN}-2.6.29.1-hfsc.patch #291907
+ "${FILESDIR}"/${PN}-2.6.38-parallel-build.patch
)
src_prepare() {