summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-04 19:23:55 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-04 19:23:55 +0000
commitfcac157b179dc28b781cc8d2ff3a60be7d95b019 (patch)
treec984d1de11a6dcdf624c9375e260cecedc943a20 /sys-apps/iproute2
parentBug 322245, Bug 330019 (diff)
downloadgentoo-2-fcac157b179dc28b781cc8d2ff3a60be7d95b019.tar.gz
gentoo-2-fcac157b179dc28b781cc8d2ff3a60be7d95b019.tar.bz2
gentoo-2-fcac157b179dc28b781cc8d2ff3a60be7d95b019.zip
Sync live ebuild version and move `ip` into /bin #330115 by Thilo Bangert.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/iproute2')
-rw-r--r--sys-apps/iproute2/ChangeLog8
-rw-r--r--sys-apps/iproute2/iproute2-2.6.35.ebuild105
-rw-r--r--sys-apps/iproute2/iproute2-9999.ebuild37
3 files changed, 130 insertions, 20 deletions
diff --git a/sys-apps/iproute2/ChangeLog b/sys-apps/iproute2/ChangeLog
index 88dfa5ada4f4..4861bf9fcb1c 100644
--- a/sys-apps/iproute2/ChangeLog
+++ b/sys-apps/iproute2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/iproute2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.155 2010/06/10 00:55:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.156 2010/08/04 19:23:55 vapier Exp $
+
+*iproute2-2.6.35 (04 Aug 2010)
+
+ 04 Aug 2010; Mike Frysinger <vapier@gentoo.org> +iproute2-2.6.35.ebuild,
+ iproute2-9999.ebuild:
+ Sync live ebuild version and move `ip` into /bin #330115 by Thilo Bangert.
*iproute2-2.6.34 (10 Jun 2010)
diff --git a/sys-apps/iproute2/iproute2-2.6.35.ebuild b/sys-apps/iproute2/iproute2-2.6.35.ebuild
new file mode 100644
index 000000000000..2930657a3fbb
--- /dev/null
+++ b/sys-apps/iproute2/iproute2-2.6.35.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.35.ebuild,v 1.1 2010/08/04 19:23:55 vapier Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git"
+ inherit git
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ if [[ ${PV} == *.*.*.* ]] ; then
+ MY_PV=${PV%.*}-${PV##*.}
+ else
+ MY_PV=${PV}
+ fi
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="http://developer.osdl.org/dev/iproute2/download/${MY_P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S=${WORKDIR}/${MY_P}
+fi
+
+DESCRIPTION="kernel routing and traffic control utilities"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="atm berkdb minimal"
+
+RDEPEND="!net-misc/arpd
+ !minimal? ( berkdb? ( sys-libs/db ) )
+ atm? ( net-dialup/linux-atm )"
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.7 )
+ >=virtual/os-headers-2.6.27"
+
+src_prepare() {
+ sed -i \
+ -e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
+ -e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
+ Makefile || die
+
+ # build against system headers
+ rm -r include/netinet #include/linux include/ip{,6}tables{,_common}.h include/libiptc
+
+ epatch "${FILESDIR}"/${PN}-2.6.29.1-hfsc.patch #291907
+
+ epatch_user
+
+ # don't build arpd if USE=-berkdb #81660
+ use berkdb || sed -i '/^TARGETS=/s: arpd : :' misc/Makefile
+
+ use minimal && sed -i -e '/^SUBDIRS=/s:=.*:=lib tc:' Makefile
+}
+
+src_configure() {
+ echo -n 'TC_CONFIG_ATM:=' > Config
+ use atm \
+ && echo 'y' >> Config \
+ || echo 'n' >> Config
+
+ # Use correct iptables dir, #144265 #293709
+ append-cppflags -DIPT_LIB_DIR=\\\"`$(tc-getPKG_CONFIG) xtables --variable=xtlibdir`\\\"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ || die
+}
+
+src_install() {
+ if use minimal ; then
+ into /
+ dosbin tc/tc || die "minimal"
+ return 0
+ fi
+
+ emake \
+ DESTDIR="${D}" \
+ SBINDIR=/sbin \
+ DOCDIR=/usr/share/doc/${PF} \
+ MANDIR=/usr/share/man \
+ install \
+ || die
+ prepalldocs
+
+ dodir /bin
+ mv "${D}"/{sbin,bin}/ip || die #330115
+
+ dolib.a lib/libnetlink.a || die
+ insinto /usr/include
+ doins include/libnetlink.h || die
+
+ if use berkdb ; then
+ dodir /var/lib/arpd
+ # bug 47482, arpd doesn't need to be in /sbin
+ dodir /usr/sbin
+ mv "${D}"/sbin/arpd "${D}"/usr/sbin/
+ fi
+}
diff --git a/sys-apps/iproute2/iproute2-9999.ebuild b/sys-apps/iproute2/iproute2-9999.ebuild
index 353d5416fabc..49f2b14a51e7 100644
--- a/sys-apps/iproute2/iproute2-9999.ebuild
+++ b/sys-apps/iproute2/iproute2-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-9999.ebuild,v 1.10 2009/12/29 06:06:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-9999.ebuild,v 1.11 2010/08/04 19:23:55 vapier Exp $
EAPI="2"
@@ -37,16 +37,11 @@ DEPEND="${RDEPEND}
elibc_glibc? ( >=sys-libs/glibc-2.7 )
>=virtual/os-headers-2.6.27"
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
- else
- unpack ${A}
- fi
-}
-
src_prepare() {
- sed -i "s:-O2:${CFLAGS} ${CPPFLAGS}:" Makefile || die "sed Makefile failed"
+ sed -i \
+ -e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
+ -e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
+ Makefile || die
# build against system headers
rm -r include/netinet #include/linux include/ip{,6}tables{,_common}.h include/libiptc
@@ -57,10 +52,8 @@ src_prepare() {
# don't build arpd if USE=-berkdb #81660
use berkdb || sed -i '/^TARGETS=/s: arpd : :' misc/Makefile
- # Multilib fixes
- sed -i "s:/usr/lib:/usr/$(get_libdir):g" \
- netem/Makefile tc/{Makefile,tc.c,q_netem.c,m_ipt.c} || die
- sed -i "s:/lib/tc:$(get_libdir)/tc:g" tc/Makefile || die
+
+ use minimal && sed -i -e '/^SUBDIRS=/s:=.*:=lib tc:' Makefile
}
src_configure() {
@@ -69,8 +62,6 @@ src_configure() {
&& echo 'y' >> Config \
|| echo 'n' >> Config
- use minimal && sed -i -e '/^SUBDIRS=/s:=.*:=lib tc:' Makefile
-
# Use correct iptables dir, #144265 #293709
append-cppflags -DIPT_LIB_DIR=\\\"`$(tc-getPKG_CONFIG) xtables --variable=xtlibdir`\\\"
}
@@ -79,7 +70,7 @@ src_compile() {
emake \
CC="$(tc-getCC)" \
AR="$(tc-getAR)" \
- || die "make failed"
+ || die
}
src_install() {
@@ -95,8 +86,16 @@ src_install() {
DOCDIR=/usr/share/doc/${PF} \
MANDIR=/usr/share/man \
install \
- || die "make install failed"
+ || die
prepalldocs
+
+ dodir /bin
+ mv "${D}"/{sbin,bin}/ip || die #330115
+
+ dolib.a lib/libnetlink.a || die
+ insinto /usr/include
+ doins include/libnetlink.h || die
+
if use berkdb ; then
dodir /var/lib/arpd
# bug 47482, arpd doesn't need to be in /sbin