summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-06-15 10:19:44 +0000
committerTim Harder <radhermit@gentoo.org>2013-06-15 10:19:44 +0000
commit237f29b35f3ebf1dcd2981b6321752173ef54960 (patch)
tree50880ca801297d93f179d1afe7c02ff70d6333c5 /sys-apps/irqbalance
parentVersion bump. (diff)
downloadgentoo-2-237f29b35f3ebf1dcd2981b6321752173ef54960.tar.gz
gentoo-2-237f29b35f3ebf1dcd2981b6321752173ef54960.tar.bz2
gentoo-2-237f29b35f3ebf1dcd2981b6321752173ef54960.zip
Version bump.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps/irqbalance')
-rw-r--r--sys-apps/irqbalance/ChangeLog7
-rw-r--r--sys-apps/irqbalance/irqbalance-1.0.6.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/sys-apps/irqbalance/ChangeLog b/sys-apps/irqbalance/ChangeLog
index 1f2965bfa65c..bccaff28181d 100644
--- a/sys-apps/irqbalance/ChangeLog
+++ b/sys-apps/irqbalance/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/irqbalance
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/ChangeLog,v 1.54 2013/01/31 23:07:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/ChangeLog,v 1.55 2013/06/15 10:19:44 radhermit Exp $
+
+*irqbalance-1.0.6 (15 Jun 2013)
+
+ 15 Jun 2013; Tim Harder <radhermit@gentoo.org> +irqbalance-1.0.6.ebuild:
+ Version bump.
31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> irqbalance-1.0.5-r1.ebuild:
Stable for ppc, wrt bug #454026
diff --git a/sys-apps/irqbalance/irqbalance-1.0.6.ebuild b/sys-apps/irqbalance/irqbalance-1.0.6.ebuild
new file mode 100644
index 000000000000..ef650bf28890
--- /dev/null
+++ b/sys-apps/irqbalance/irqbalance-1.0.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-1.0.6.ebuild,v 1.1 2013/06/15 10:19:44 radhermit Exp $
+
+EAPI=4
+
+inherit systemd linux-info
+
+DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
+HOMEPAGE="http://irqbalance.googlecode.com/"
+SRC_URI="http://irqbalance.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="caps +numa"
+
+RDEPEND="dev-libs/glib:2
+ caps? ( sys-libs/libcap-ng )
+ numa? ( sys-process/numactl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ CONFIG_CHECK="~PCI_MSI"
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ econf \
+ $(use_with caps libcap-ng) \
+ $(use_enable numa)
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/irqbalance.init.3 irqbalance
+ newconfd "${FILESDIR}"/irqbalance.confd-1 irqbalance
+ systemd_dounit "${FILESDIR}"/irqbalance.service
+}