summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-11-28 07:24:22 +0000
committerMike Frysinger <vapier@gentoo.org>2007-11-28 07:24:22 +0000
commitcfb983343a94c00991113e7dc28b51be097bf4ca (patch)
tree0e256f3bca51eb83d1f4a3ef971678801c27fca2 /sys-apps/less/less-416.ebuild
parentFixing manifest and adding sed call as suggested by justin in bug 200389. (diff)
downloadgentoo-2-cfb983343a94c00991113e7dc28b51be097bf4ca.tar.gz
gentoo-2-cfb983343a94c00991113e7dc28b51be097bf4ca.tar.bz2
gentoo-2-cfb983343a94c00991113e7dc28b51be097bf4ca.zip
Version bump.
(Portage version: 2.1.3.19)
Diffstat (limited to 'sys-apps/less/less-416.ebuild')
-rw-r--r--sys-apps/less/less-416.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/less/less-416.ebuild b/sys-apps/less/less-416.ebuild
new file mode 100644
index 000000000000..15052984b0eb
--- /dev/null
+++ b/sys-apps/less/less-416.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/less/less-416.ebuild,v 1.1 2007/11/28 07:24:21 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Excellent text file viewer"
+HOMEPAGE="http://www.greenwoodsoftware.com/less/"
+SRC_URI="http://www.greenwoodsoftware.com/less/${P}.tar.gz
+ http://www-zeuthen.desy.de/~friebel/unix/less/code2color"
+
+LICENSE="|| ( GPL-2 less )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="unicode"
+
+DEPEND=">=sys-libs/ncurses-5.2"
+PROVIDE="virtual/pager"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ cp "${DISTDIR}"/code2color "${S}"/
+ epatch "${FILESDIR}"/code2color.patch
+}
+
+yesno() { use $1 && echo yes || echo no ; }
+src_compile() {
+ export ac_cv_lib_ncursesw_initscr=$(yesno unicode)
+ export ac_cv_lib_ncurses_initscr=$(yesno !unicode)
+ econf || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dobin code2color || die "dobin"
+ newbin "${FILESDIR}"/lesspipe.sh lesspipe.sh || die "newbin"
+ newenvd "${FILESDIR}"/less.envd 70less
+
+ dodoc NEWS README* "${FILESDIR}"/README.Gentoo
+}