summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-20 08:35:46 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-20 08:35:46 +0000
commit9e6051a58eb387c28ed9deaa3c7cb13b935f237b (patch)
treecc1e719af434d161c62ace824d7f88de2dcb29c1 /sys-apps/lshw
parentFix building with gcc-4.3 #209036. (diff)
downloadgentoo-2-9e6051a58eb387c28ed9deaa3c7cb13b935f237b.tar.gz
gentoo-2-9e6051a58eb387c28ed9deaa3c7cb13b935f237b.tar.bz2
gentoo-2-9e6051a58eb387c28ed9deaa3c7cb13b935f237b.zip
Add fix from upstream for building with gcc-4.3 #213912 by Sergey Dryabzhinsky.
(Portage version: 2.2_pre5)
Diffstat (limited to 'sys-apps/lshw')
-rw-r--r--sys-apps/lshw/ChangeLog6
-rw-r--r--sys-apps/lshw/files/lshw-02.12.01b-gcc43.patch298
-rw-r--r--sys-apps/lshw/lshw-02.12.01b.ebuild3
3 files changed, 305 insertions, 2 deletions
diff --git a/sys-apps/lshw/ChangeLog b/sys-apps/lshw/ChangeLog
index 6b7c74a36ee5..7add8eb2b9d9 100644
--- a/sys-apps/lshw/ChangeLog
+++ b/sys-apps/lshw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/lshw
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lshw/ChangeLog,v 1.63 2008/04/17 11:12:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lshw/ChangeLog,v 1.64 2008/04/20 08:35:45 vapier Exp $
+
+ 20 Apr 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/lshw-02.12.01b-gcc43.patch, lshw-02.12.01b.ebuild:
+ Add fix from upstream for building with gcc-4.3 #213912 by Sergey Dryabzhinsky.
17 Apr 2008; Raúl Porcel <armin76@gentoo.org> lshw-02.12.01b.ebuild:
ia64/x86 stable wrt #217783
diff --git a/sys-apps/lshw/files/lshw-02.12.01b-gcc43.patch b/sys-apps/lshw/files/lshw-02.12.01b-gcc43.patch
new file mode 100644
index 000000000000..f8612009f7c9
--- /dev/null
+++ b/sys-apps/lshw/files/lshw-02.12.01b-gcc43.patch
@@ -0,0 +1,298 @@
+fix from upstream for building with gcc-4.3
+
+http://bugs.gentoo.org/213912
+
+--- lshw-B.02.12.01/src/core/blockio.cc
++++ lshw-B.02.12.01/src/core/blockio.cc
+@@ -11,6 +11,7 @@
+ #include "blockio.h"
+ #include "osutils.h"
+ #include <stdio.h>
++#include <string.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+--- lshw-B.02.12.01/src/core/cdrom.cc
++++ lshw-B.02.12.01/src/core/cdrom.cc
+@@ -23,6 +23,7 @@
+ #include <sys/ioctl.h>
+ #include <fcntl.h>
+ #include <unistd.h>
++#include <limits.h>
+ #include <linux/cdrom.h>
+
+ __ID("@(#) $Id: cdrom.cc 1907 2007-10-13 22:23:16Z lyonel $");
+--- lshw-B.02.12.01/src/core/cpuid.cc
++++ lshw-B.02.12.01/src/core/cpuid.cc
+@@ -1,6 +1,7 @@
+ #include "version.h"
+ #include "cpuid.h"
+ #include <stdio.h>
++#include <string.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <sys/stat.h>
+--- lshw-B.02.12.01/src/core/cpuinfo.cc
++++ lshw-B.02.12.01/src/core/cpuinfo.cc
+@@ -6,6 +6,7 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <vector>
+
+ __ID("@(#) $Id: cpuinfo.cc 1907 2007-10-13 22:23:16Z lyonel $");
+--- lshw-B.02.12.01/src/core/device-tree.cc
++++ lshw-B.02.12.01/src/core/device-tree.cc
+@@ -15,7 +15,9 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <unistd.h>
+ #include <dirent.h>
+
+--- lshw-B.02.12.01/src/core/fb.cc
++++ lshw-B.02.12.01/src/core/fb.cc
+@@ -12,6 +12,7 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <errno.h>
+
+ __ID("@(#) $Id: fb.cc 1907 2007-10-13 22:23:16Z lyonel $");
+--- lshw-B.02.12.01/src/core/hw.cc
++++ lshw-B.02.12.01/src/core/hw.cc
+@@ -4,12 +4,14 @@
+ #include "version.h"
+ #include "options.h"
+ #include "heuristics.h"
++#include <cstring>
+ #include <vector>
+ #include <map>
+ #include <sstream>
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <ctype.h>
++#include <limits.h>
+ #include <unistd.h>
+ #include <sys/utsname.h>
+
+--- lshw-B.02.12.01/src/core/ide.cc
++++ lshw-B.02.12.01/src/core/ide.cc
+@@ -23,6 +23,8 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <string.h>
++#include <stdlib.h>
+ #include <dirent.h>
+ #include <ctype.h>
+ #include <vector>
+--- lshw-B.02.12.01/src/core/ideraid.cc
++++ lshw-B.02.12.01/src/core/ideraid.cc
+@@ -17,6 +17,7 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <dirent.h>
+ #include <ctype.h>
+ #include <vector>
+--- lshw-B.02.12.01/src/core/lvm.cc
++++ lshw-B.02.12.01/src/core/lvm.cc
+@@ -12,6 +12,7 @@
+ #include "version.h"
+ #include "lvm.h"
+ #include "osutils.h"
++#include <string.h>
+
+ __ID("@(#) $Id: lvm.cc 1907 2007-10-13 22:23:16Z lyonel $");
+
+--- lshw-B.02.12.01/src/core/mounts.cc
++++ lshw-B.02.12.01/src/core/mounts.cc
+@@ -11,6 +11,8 @@
+ #include <iostream>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <unistd.h>
+
+
+--- lshw-B.02.12.01/src/core/osutils.cc
++++ lshw-B.02.12.01/src/core/osutils.cc
+@@ -9,6 +9,7 @@
+ #include <dirent.h>
+ #include <limits.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <regex.h>
+ #include <ctype.h>
+ #include <stdio.h>
+--- lshw-B.02.12.01/src/core/parisc.cc
++++ lshw-B.02.12.01/src/core/parisc.cc
+@@ -17,6 +17,8 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <unistd.h>
+ #include <dirent.h>
+
+--- lshw-B.02.12.01/src/core/partitions.cc
++++ lshw-B.02.12.01/src/core/partitions.cc
+@@ -24,6 +24,8 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
++#include <stdlib.h>
+ #include <unistd.h>
+ #include <stdint.h>
+
+--- lshw-B.02.12.01/src/core/pci.cc
++++ lshw-B.02.12.01/src/core/pci.cc
+@@ -6,6 +6,8 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <string.h>
++#include <stdlib.h>
+ #include <dirent.h>
+
+ __ID("@(#) $Id: pci.cc 1907 2007-10-13 22:23:16Z lyonel $");
+--- lshw-B.02.12.01/src/core/pcmcia.cc
++++ lshw-B.02.12.01/src/core/pcmcia.cc
+@@ -7,6 +7,8 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <errno.h>
+ #include <dirent.h>
+
+--- lshw-B.02.12.01/src/core/pcmcia-legacy.cc
++++ lshw-B.02.12.01/src/core/pcmcia-legacy.cc
+@@ -7,6 +7,7 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <errno.h>
+
+ __ID("@(#) $Id: pcmcia-legacy.cc 1907 2007-10-13 22:23:16Z lyonel $");
+--- lshw-B.02.12.01/src/core/pnp.cc
++++ lshw-B.02.12.01/src/core/pnp.cc
+@@ -9,6 +9,7 @@
+ #include "version.h"
+ #include "pnp.h"
+
++#include <stdlib.h>
+ #include <string.h>
+
+ __ID("@(#) $Id: pnp.cc 1907 2007-10-13 22:23:16Z lyonel $");
+--- lshw-B.02.12.01/src/core/print.cc
++++ lshw-B.02.12.01/src/core/print.cc
+@@ -11,10 +11,12 @@
+ #include "options.h"
+ #include "version.h"
+ #include "osutils.h"
++#include <cstring>
+ #include <iostream>
+ #include <sstream>
+ #include <iomanip>
+ #include <unistd.h>
++#include <stdlib.h>
+ #include <stdio.h>
+ #include <sys/ioctl.h>
+ #include <termios.h>
+--- lshw-B.02.12.01/src/core/scsi.cc
++++ lshw-B.02.12.01/src/core/scsi.cc
+@@ -12,6 +12,8 @@
+ #include <unistd.h>
+ #include <dirent.h>
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <scsi/sg.h>
+ #include <scsi/scsi.h>
+ #ifndef MKDEV
+--- lshw-B.02.12.01/src/core/smp.cc
++++ lshw-B.02.12.01/src/core/smp.cc
+@@ -9,6 +9,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+ #include <unistd.h>
+
+ #include "osutils.h"
+--- lshw-B.02.12.01/src/core/spd.cc
++++ lshw-B.02.12.01/src/core/spd.cc
+@@ -5,6 +5,7 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <unistd.h>
++#include <string.h>
+ #include <string>
+ #include <dirent.h>
+ #include <stdio.h>
+--- lshw-B.02.12.01/src/core/sysfs.cc
++++ lshw-B.02.12.01/src/core/sysfs.cc
+@@ -11,6 +11,7 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <dirent.h>
+ #include <libgen.h>
+ #include <sys/stat.h>
+--- lshw-B.02.12.01/src/core/usb.cc
++++ lshw-B.02.12.01/src/core/usb.cc
+@@ -18,6 +18,8 @@
+ #include <sys/ioctl.h>
+ #include <errno.h>
+ #include <fcntl.h>
++#include <string.h>
++#include <stdlib.h>
+ #include <unistd.h>
+ #include <dirent.h>
+
+--- lshw-B.02.12.01/src/core/volumes.cc
++++ lshw-B.02.12.01/src/core/volumes.cc
+@@ -15,6 +15,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+ #include <unistd.h>
+ #include <stdint.h>
+ #include <time.h>
+--- lshw-B.02.12.01/src/gui/engine.cc
++++ lshw-B.02.12.01/src/gui/engine.cc
+@@ -9,6 +9,8 @@
+ #include <iostream>
+ #include <fstream>
+ #include <sys/utsname.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <libgen.h>
+
+ static char *id = "@(#) $Id: engine.cc 1907 2007-10-13 22:23:16Z lyonel $";
+--- lshw-B.02.12.01/src/lshw.cc
++++ lshw-B.02.12.01/src/lshw.cc
+@@ -8,6 +8,8 @@
+
+ #include <unistd.h>
+ #include <stdio.h>
++#include <string.h>
++#include <stdlib.h>
+ #include <iostream>
+
+ __ID("@(#) $Id: lshw.cc 1907 2007-10-13 22:23:16Z lyonel $");
diff --git a/sys-apps/lshw/lshw-02.12.01b.ebuild b/sys-apps/lshw/lshw-02.12.01b.ebuild
index 6073fa2bc8cb..75eeb752f951 100644
--- a/sys-apps/lshw/lshw-02.12.01b.ebuild
+++ b/sys-apps/lshw/lshw-02.12.01b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lshw/lshw-02.12.01b.ebuild,v 1.4 2008/04/17 11:12:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lshw/lshw-02.12.01b.ebuild,v 1.5 2008/04/20 08:35:45 vapier Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -28,6 +28,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-02.12.01b-build.patch
epatch "${FILESDIR}"/${PN}-02.09b-cpuid-PIC.patch #61947
+ epatch "${FILESDIR}"/${P}-gcc43.patch #213912
}
src_compile() {