summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-21 13:48:09 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-21 13:48:09 +0000
commite0a7f317443b8c1f1a1eb4499da0100db298a2a7 (patch)
tree5f82e80c55e2cab0c5d9bcccb7ba30658897f9f0 /sys-apps/openrc
parentMask app-dicts/vdict* for removal. (diff)
downloadgentoo-2-e0a7f317443b8c1f1a1eb4499da0100db298a2a7.tar.gz
gentoo-2-e0a7f317443b8c1f1a1eb4499da0100db298a2a7.tar.bz2
gentoo-2-e0a7f317443b8c1f1a1eb4499da0100db298a2a7.zip
Restore more e* output style.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/openrc')
-rw-r--r--sys-apps/openrc/ChangeLog6
-rw-r--r--sys-apps/openrc/files/openrc-9999-msg-style.patch51
2 files changed, 48 insertions, 9 deletions
diff --git a/sys-apps/openrc/ChangeLog b/sys-apps/openrc/ChangeLog
index 796d2a500ab0..85a23afa50d6 100644
--- a/sys-apps/openrc/ChangeLog
+++ b/sys-apps/openrc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/openrc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.101 2009/12/07 09:09:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.102 2009/12/21 13:48:09 vapier Exp $
+
+ 21 Dec 2009; Mike Frysinger <vapier@gentoo.org>
+ files/openrc-9999-msg-style.patch:
+ Restore more e* output style.
07 Dec 2009; Mike Frysinger <vapier@gentoo.org> openrc-0.5.3.ebuild,
openrc-9999.ebuild:
diff --git a/sys-apps/openrc/files/openrc-9999-msg-style.patch b/sys-apps/openrc/files/openrc-9999-msg-style.patch
index 0ba3697facf5..ac325bb79bcf 100644
--- a/sys-apps/openrc/files/openrc-9999-msg-style.patch
+++ b/sys-apps/openrc/files/openrc-9999-msg-style.patch
@@ -1,17 +1,43 @@
-From 1eddb56f11b41c4bf4f878c995c5d140b1f9d44d Mon Sep 17 00:00:00 2001
+From 1e307244138c8f650ab37bffa7b3cc3e3b39cd64 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Mon, 24 Mar 2008 01:48:19 -0400
-Subject: [PATCH] This reverts commit 0e2f160c95b15e95f3885e3f5a3670ec5ae0a709. 2 spaces in 80 cols has never made any sort of realistic difference and we're not going to change this behavior in Gentoo.
+Subject: [PATCH] restore old e* func output
+Gentoo has always used the sytle:
+ * moo ... [ ok ]
+Latest openrc now does:
+* moo... [ok]
+
+Realistically, 4 spaces out of 80 on reduced terminals doesn't make any
+sort of realistic difference and it's been just fine for the last 10
+years, so keep the default behavior.
---
- src/libeinfo/libeinfo.c | 9 +++------
- 1 files changed, 3 insertions(+), 6 deletions(-)
+ src/libeinfo/libeinfo.c | 15 ++++++---------
+ 1 files changed, 6 insertions(+), 9 deletions(-)
diff --git a/src/libeinfo/libeinfo.c b/src/libeinfo/libeinfo.c
-index f8ddcb5..c46cacb 100644
+index 8a7613c..234b1af 100644
--- a/src/libeinfo/libeinfo.c
+++ b/src/libeinfo/libeinfo.c
-@@ -817,7 +817,7 @@ static void _eend(FILE * __EINFO_RESTRICT fp, int col, ECOLOR color,
+@@ -643,7 +643,7 @@ static int EINFO_PRINTF(3, 0)
+ fprintf(f, "\n");
+ if (_eprefix)
+ fprintf(f, "%s%s%s|", _ecolor(f, color), _eprefix, _ecolor(f, ECOLOR_NORMAL));
+- fprintf(f, "%s*%s ", _ecolor(f, color), _ecolor(f, ECOLOR_NORMAL));
++ fprintf(f, " %s*%s ", _ecolor(f, color), _ecolor(f, ECOLOR_NORMAL));
+ retval += _eindent(f);
+ va_copy(ap, va);
+ retval += vfprintf(f, fmt, ap) + 3;
+@@ -800,7 +800,7 @@ ebegin(const char *EINFO_RESTRICT fmt, ...)
+ va_start(ap, fmt);
+ retval = _einfovn(fmt, ap);
+ va_end(ap);
+- retval += printf("...");
++ retval += printf(" ...");
+ if (colour_terminal(stdout))
+ retval += printf("\n");
+ LASTCMD("ebegin");
+@@ -817,7 +817,7 @@ _eend(FILE * EINFO_RESTRICT fp, int col, ECOLOR color, const char *msg)
if (!msg)
return;
@@ -20,7 +46,7 @@ index f8ddcb5..c46cacb 100644
/* cons25 is special - we need to remove one char, otherwise things
* do not align properly at all. */
-@@ -831,18 +831,15 @@ static void _eend(FILE * __EINFO_RESTRICT fp, int col, ECOLOR color,
+@@ -831,18 +831,15 @@ _eend(FILE * EINFO_RESTRICT fp, int col, ECOLOR color, const char *msg)
if (term_is_cons25)
cols--;
@@ -41,6 +67,15 @@ index f8ddcb5..c46cacb 100644
}
}
+@@ -1030,7 +1027,7 @@ ebeginv(const char *EINFO_RESTRICT fmt, ...)
+
+ va_start(ap, fmt);
+ retval = _einfovn(fmt, ap);
+- retval += printf("...");
++ retval += printf(" ...");
+ if (colour_terminal(stdout))
+ retval += printf("\n");
+ va_end(ap);
--
-1.5.4.4
+1.6.6.rc3