summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-12 13:57:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-12 13:57:43 +0000
commit0a3b41c5d0bf046624de0b842ee7f173cb0fa4ee (patch)
treea9f2aa0f1a9a3ea3d060e1807918d6b498369012 /sys-apps/pmount
parentAdd [options] stanza #142850#36 by Steven Wilson. (diff)
downloadgentoo-2-0a3b41c5d0bf046624de0b842ee7f173cb0fa4ee.tar.gz
gentoo-2-0a3b41c5d0bf046624de0b842ee7f173cb0fa4ee.tar.bz2
gentoo-2-0a3b41c5d0bf046624de0b842ee7f173cb0fa4ee.zip
Version bump.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pmount')
-rw-r--r--sys-apps/pmount/ChangeLog8
-rw-r--r--sys-apps/pmount/files/pmount-0.9.20-ext4-support.patch12
-rw-r--r--sys-apps/pmount/pmount-0.9.20.ebuild73
3 files changed, 92 insertions, 1 deletions
diff --git a/sys-apps/pmount/ChangeLog b/sys-apps/pmount/ChangeLog
index 7421a8fda4fd..691f2210ae4f 100644
--- a/sys-apps/pmount/ChangeLog
+++ b/sys-apps/pmount/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pmount
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.71 2009/10/05 16:09:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.72 2009/10/12 13:57:42 ssuominen Exp $
+
+*pmount-0.9.20 (12 Oct 2009)
+
+ 12 Oct 2009; Samuli Suominen <ssuominen@gentoo.org> +pmount-0.9.20.ebuild,
+ +files/pmount-0.9.20-ext4-support.patch:
+ Version bump.
05 Oct 2009; Raúl Porcel <armin76@gentoo.org> pmount-0.9.19.ebuild:
arm/ia64/sh/sparc stable wrt #281208
diff --git a/sys-apps/pmount/files/pmount-0.9.20-ext4-support.patch b/sys-apps/pmount/files/pmount-0.9.20-ext4-support.patch
new file mode 100644
index 000000000000..cf84b1e14e53
--- /dev/null
+++ b/sys-apps/pmount/files/pmount-0.9.20-ext4-support.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/show_bug.cgi?id=265453
+
+--- pmount-0.9.20/src/fs.c
++++ pmount-0.9.20/src/fs.c
+@@ -26,6 +26,7 @@
+ { "hfsplus", "nosuid,nodev,user", 1, NULL, 0 },
+ { "hfs", "nosuid,nodev,user", 1, "077", NULL,
+ ",file_umask=%04o,dir_umask=%04o"},
++ { "ext4", "nodev,noauto,nosuid,user,errors=remount-ro", 0, NULL, 0 },
+ { "ext3", "nodev,noauto,nosuid,user,errors=remount-ro", 0, NULL, 0 },
+ { "ext2", "nodev,noauto,nosuid,user,errors=remount-ro", 0, NULL, 0 },
+ { "reiserfs", "nodev,noauto,nosuid,user", 0, NULL, 0 },
diff --git a/sys-apps/pmount/pmount-0.9.20.ebuild b/sys-apps/pmount/pmount-0.9.20.ebuild
new file mode 100644
index 000000000000..c76fff0327dc
--- /dev/null
+++ b/sys-apps/pmount/pmount-0.9.20.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.20.ebuild,v 1.1 2009/10/12 13:57:42 ssuominen Exp $
+
+EAPI=2
+inherit base eutils
+
+DESCRIPTION="Policy based mounter that gives the ability to mount removable devices as a user"
+HOMEPAGE="http://pmount.alioth.debian.org/"
+SRC_URI="https://alioth.debian.org/frs/download.php/3127/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="crypt hal"
+
+RDEPEND=">=sys-apps/util-linux-2.16
+ hal? ( >=sys-apps/dbus-0.33 >=sys-apps/hal-0.5.2 )
+ crypt? ( >=sys-fs/cryptsetup-1.0.5 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext"
+
+PATCHES=( "${FILESDIR}/${P}-ext4-support.patch"
+ "${FILESDIR}/${PN}-0.9.19-testsuite-missing-dir.patch" )
+
+pkg_setup() {
+ enewgroup plugdev
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable hal)
+}
+
+src_test() {
+ local testdir=${S}/tests/check_fstab
+
+ ln -s $testdir/a $testdir/b && ln -s $testdir/d $testdir/c && \
+ ln -s $testdir/c $testdir/e \
+ || die "Unable to create fake symlinks required for testsuite"
+ emake check || die "check failed"
+}
+
+src_install () {
+ # Must be run SETUID+SETGID, bug #250106
+ exeinto /usr/bin
+ exeopts -m 6710 -g plugdev
+ doexe src/pmount src/pumount || die "doexe failed"
+
+ dodoc AUTHORS ChangeLog TODO || die "dodoc failed"
+ doman man/pmount.1 man/pumount.1 || die "doman failed"
+
+ if use hal; then
+ doexe src/pmount-hal || die "doexe failed"
+ doman man/pmount-hal.1 || die "doman failed"
+ fi
+
+ insinto /etc
+ doins etc/pmount.allow || die "doins failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "This package has been installed setuid and setgid."
+
+ elog "The permissions are as such that only users that belong to the plugdev"
+ elog "group are allowed to run this. But if a script run by root mounts a"
+ elog "device, members of the plugdev group will have access to it."
+ elog
+ elog "Please add your user to the plugdev group to be able to mount USB drives"
+}