summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-12-08 18:04:06 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-12-08 18:04:06 +0000
commit7d10e2743fe9e2dcd4b3e8450f8760b1dae846ba (patch)
tree33fa3d0cda1d269a1602f9b2d947c6c8fc5e84e7 /sys-apps/pmount
parentcorrect install with patch from Michael (kensington) (bug #393607) (diff)
downloadgentoo-2-7d10e2743fe9e2dcd4b3e8450f8760b1dae846ba.tar.gz
gentoo-2-7d10e2743fe9e2dcd4b3e8450f8760b1dae846ba.tar.bz2
gentoo-2-7d10e2743fe9e2dcd4b3e8450f8760b1dae846ba.zip
Restore default value for not_physically_logged_allow (change from "no" to "yes") wrt #393633 by Michał Górny
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pmount')
-rw-r--r--sys-apps/pmount/ChangeLog9
-rw-r--r--sys-apps/pmount/pmount-0.9.99_alpha-r1.ebuild79
2 files changed, 87 insertions, 1 deletions
diff --git a/sys-apps/pmount/ChangeLog b/sys-apps/pmount/ChangeLog
index f9245aeb46e2..2c97f8a433fa 100644
--- a/sys-apps/pmount/ChangeLog
+++ b/sys-apps/pmount/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/pmount
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.87 2011/12/03 01:22:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.88 2011/12/08 18:04:06 ssuominen Exp $
+
+*pmount-0.9.99_alpha-r1 (08 Dec 2011)
+
+ 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +pmount-0.9.99_alpha-r1.ebuild:
+ Restore default value for not_physically_logged_allow (change from "no" to
+ "yes") wrt #393633 by Michał Górny
*pmount-0.9.99_alpha (03 Dec 2011)
diff --git a/sys-apps/pmount/pmount-0.9.99_alpha-r1.ebuild b/sys-apps/pmount/pmount-0.9.99_alpha-r1.ebuild
new file mode 100644
index 000000000000..ac72dd7cfbf6
--- /dev/null
+++ b/sys-apps/pmount/pmount-0.9.99_alpha-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.99_alpha-r1.ebuild,v 1.1 2011/12/08 18:04:06 ssuominen Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Policy based mounter that gives the ability to mount removable devices as a user"
+HOMEPAGE="http://pmount.alioth.debian.org/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV/_/-}.orig.tar.bz2"
+#SRC_URI="http://alioth.debian.org/frs/download.php/3530/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="crypt"
+
+RDEPEND=">=sys-apps/util-linux-2.17.2
+ crypt? ( >=sys-fs/cryptsetup-1.0.6-r2 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext"
+
+S=${WORKDIR}/${P/_/-}
+
+pkg_setup() {
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # Restore default value from pmount <= 0.9.23 wrt #393633
+ sed -i -e '/^not_physically_logged_allow/s:=.*:= yes:' etc/pmount.conf || die
+
+ cat <<-EOF > po/POTFILES.skip
+ src/conffile.c
+ src/configuration.c
+ src/loop.c
+ EOF
+
+ epatch "${FILESDIR}"/${PN}-0.9.19-testsuite-missing-dir.patch
+}
+
+src_configure() {
+ econf --disable-hal
+}
+
+src_test() {
+ local testdir=${S}/tests/check_fstab
+
+ ln -s $testdir/a $testdir/b && ln -s $testdir/d $testdir/c && \
+ ln -s $testdir/c $testdir/e \
+ || die "Unable to create fake symlinks required for testsuite"
+
+ emake check
+}
+
+src_install () {
+ # Must be run SETUID+SETGID, bug #250106
+ exeinto /usr/bin
+ exeopts -m 6710 -g plugdev
+ doexe src/{p,pu}mount
+
+ dodoc AUTHORS ChangeLog TODO
+ doman man/{{p,pu}mount.1,pmount.conf.5}
+
+ insinto /etc
+ doins etc/pmount.{allow,conf}
+}
+
+pkg_postinst() {
+ elog
+ elog "This package has been installed setuid and setgid."
+
+ elog "The permissions are as such that only users that belong to the plugdev"
+ elog "group are allowed to run this. But if a script run by root mounts a"
+ elog "device, members of the plugdev group will have access to it."
+ elog
+ elog "Please add your user to the plugdev group to be able to mount USB drives"
+}