summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-04-18 21:49:41 +0000
committerJason Zaman <perfinion@gentoo.org>2015-04-18 21:49:41 +0000
commit5473d3ae488f3424a71621965ba0858f2b822fc6 (patch)
tree3fd05d3a76c2c950e85b9accb4dbf2287860c29f /sys-apps/policycoreutils
parentFix build failure with Emacs 24.5, bug 547026. (diff)
downloadgentoo-2-5473d3ae488f3424a71621965ba0858f2b822fc6.tar.gz
gentoo-2-5473d3ae488f3424a71621965ba0858f2b822fc6.tar.bz2
gentoo-2-5473d3ae488f3424a71621965ba0858f2b822fc6.zip
Drop old RCs
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x7EF137EC935B0EAF)
Diffstat (limited to 'sys-apps/policycoreutils')
-rw-r--r--sys-apps/policycoreutils/ChangeLog7
-rw-r--r--sys-apps/policycoreutils/policycoreutils-2.3-r2.ebuild152
-rw-r--r--sys-apps/policycoreutils/policycoreutils-2.4_rc6-r1.ebuild171
-rw-r--r--sys-apps/policycoreutils/policycoreutils-2.4_rc7.ebuild151
4 files changed, 6 insertions, 475 deletions
diff --git a/sys-apps/policycoreutils/ChangeLog b/sys-apps/policycoreutils/ChangeLog
index f35190fe7010..8d32c1f651eb 100644
--- a/sys-apps/policycoreutils/ChangeLog
+++ b/sys-apps/policycoreutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/policycoreutils
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.150 2015/03/04 16:05:39 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.151 2015/04/18 21:49:41 perfinion Exp $
+
+ 18 Apr 2015; Jason Zaman <perfinion@gentoo.org>
+ -policycoreutils-2.3-r2.ebuild, -policycoreutils-2.4_rc6-r1.ebuild,
+ -policycoreutils-2.4_rc7.ebuild:
+ Drop old RCs
04 Mar 2015; Sven Vermeulen <swift@gentoo.org> policycoreutils-2.4.ebuild:
Fix build failure on x32 (bug #541618)
diff --git a/sys-apps/policycoreutils/policycoreutils-2.3-r2.ebuild b/sys-apps/policycoreutils/policycoreutils-2.3-r2.ebuild
deleted file mode 100644
index 61dca5b8501b..000000000000
--- a/sys-apps/policycoreutils/policycoreutils-2.3-r2.ebuild
+++ /dev/null
@@ -1,152 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-2.3-r2.ebuild,v 1.3 2014/09/21 10:22:57 swift Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="xml"
-
-inherit multilib python-r1 toolchain-funcs eutils
-
-MY_P="${P//_/-}"
-
-EXTRAS_VER="1.33"
-SEMNG_VER="2.3"
-SELNX_VER="2.3"
-SEPOL_VER="2.3"
-PATCHBUNDLE="3"
-
-IUSE="audit pam dbus"
-
-DESCRIPTION="SELinux core utilities"
-HOMEPAGE="http://userspace.selinuxproject.org"
-SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20140506/${MY_P}.tar.gz
-http://dev.gentoo.org/~swift/patches/policycoreutils/patchbundle-${PN}-${PATCHBUNDLE}.tar.gz
- mirror://gentoo/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-COMMON_DEPS=">=sys-libs/libselinux-${SELNX_VER}[python]
- >=sys-libs/glibc-2.4
- >=sys-libs/libcap-1.10-r10
- >=sys-libs/libsemanage-${SEMNG_VER}[python]
- sys-libs/libcap-ng
- >=sys-libs/libsepol-${SEPOL_VER}
- sys-devel/gettext
- dev-python/ipy
- dbus? (
- sys-apps/dbus
- dev-libs/dbus-glib
- )
- audit? ( >=sys-process/audit-1.5.1 )
- pam? ( sys-libs/pam )
- ${PYTHON_DEPS}"
-
-### libcgroup -> seunshare
-### dbus -> restorecond
-
-# pax-utils for scanelf used by rlpkg
-RDEPEND="${COMMON_DEPS}
- dev-python/sepolgen
- app-misc/pax-utils"
-
-DEPEND="${COMMON_DEPS}"
-
-S="${WORKDIR}/${MY_P}"
-S1="${WORKDIR}/${MY_P}"
-S2="${WORKDIR}/policycoreutils-extra"
-
-src_prepare() {
- # rlpkg is more useful than fixfiles
- sed -i -e '/^all/s/fixfiles//' "${S}/scripts/Makefile" \
- || die "fixfiles sed 1 failed"
- sed -i -e '/fixfiles/d' "${S}/scripts/Makefile" \
- || die "fixfiles sed 2 failed"
-
- EPATCH_MULTI_MSG="Applying policycoreutils patches ... " \
- EPATCH_SUFFIX="patch" \
- EPATCH_SOURCE="${WORKDIR}/gentoo-patches" \
- EPATCH_FORCE="yes" \
- epatch
-
- epatch_user
-
- python_copy_sources
- # Our extra code is outside the regular directory, so set it to the extra
- # directory. We really should optimize this as it is ugly, but the extra
- # code is needed for Gentoo at the same time that policycoreutils is present
- # (so we cannot use an additional package for now).
- S="${S2}"
- python_copy_sources
-}
-
-src_compile() {
- local use_audit="n";
- local use_pam="n";
- local use_dbus="n";
- local use_sesandbox="n";
-
- use audit && use_audit="y";
- use pam && use_pam="y";
- use dbus && use_dbus="y";
-
- building() {
- emake -C "${BUILD_DIR}" AUDIT_LOG_PRIVS="y" AUDITH="${use_audit}" PAMH="${use_pam}" INOTIFYH="${use_dbus}" SESANDBOX="${use_sesandbox}" CC="$(tc-getCC)" PYLIBVER="${EPYTHON}" || die
- }
- S="${S1}" # Regular policycoreutils
- python_foreach_impl building
- S="${S2}" # Extra set
- python_foreach_impl building
-}
-
-src_install() {
- local use_audit="n";
- local use_pam="n";
- local use_dbus="n";
- local use_sesandbox="n";
-
- use audit && use_audit="y";
- use pam && use_pam="y";
- use dbus && use_dbus="y";
-
- # Python scripts are present in many places. There are no extension modules.
- installation-policycoreutils() {
- einfo "Installing policycoreutils"
- emake -C "${BUILD_DIR}" DESTDIR="${D}" AUDITH="${use_audit}" PAMH="${use_pam}" INOTIFYH="${use_dbus}" SESANDBOX="${use_sesandbox}" AUDIT_LOG_PRIV="y" PYLIBVER="${EPYTHON}" install || return 1
- }
-
- installation-extras() {
- einfo "Installing policycoreutils-extra"
- emake -C "${BUILD_DIR}" DESTDIR="${D}" INOTIFYH="${use_dbus}" SHLIBDIR="${D}$(get_libdir)/rc" install || return 1
- }
-
- S="${S1}" # policycoreutils
- python_foreach_impl installation-policycoreutils
- S="${S2}" # extras
- python_foreach_impl installation-extras
- S="${S1}" # back for later
-
- # remove redhat-style init script
- rm -fR "${D}/etc/rc.d"
-
- # compatibility symlinks
- dosym /sbin/setfiles /usr/sbin/setfiles
- dosym /$(get_libdir)/rc/runscript_selinux.so /$(get_libdir)/rcscripts/runscript_selinux.so
-
- # location for permissive definitions
- dodir /var/lib/selinux
- keepdir /var/lib/selinux
-
- # Set version-specific scripts
- for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
- python_replicate_script "${ED}/usr/bin/${pyscript}"
- done
- for pyscript in semanage rlpkg; do
- python_replicate_script "${ED}/usr/sbin/${pyscript}"
- done
-
- dodir /usr/share/doc/${PF}/mcstrans/examples
- cp -dR "${S1}"/mcstrans/share/examples/* "${D}/usr/share/doc/${PF}/mcstrans/examples"
-}
diff --git a/sys-apps/policycoreutils/policycoreutils-2.4_rc6-r1.ebuild b/sys-apps/policycoreutils/policycoreutils-2.4_rc6-r1.ebuild
deleted file mode 100644
index e37cc263a32f..000000000000
--- a/sys-apps/policycoreutils/policycoreutils-2.4_rc6-r1.ebuild
+++ /dev/null
@@ -1,171 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-2.4_rc6-r1.ebuild,v 1.2 2014/12/06 23:28:23 perfinion Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="xml"
-
-inherit multilib python-r1 toolchain-funcs eutils
-
-MY_P="${P//_/-}"
-
-EXTRAS_VER="1.33"
-SEMNG_VER="2.4_rc6"
-SELNX_VER="2.4_rc6"
-SEPOL_VER="2.4_rc6"
-PATCHBUNDLE="4"
-
-IUSE="audit pam dbus"
-
-DESCRIPTION="SELinux core utilities"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20140826/${MY_P}.tar.gz
- mirror://gentoo/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-COMMON_DEPS=">=sys-libs/libselinux-${SELNX_VER}[python]
- >=sys-libs/glibc-2.4
- >=sys-libs/libcap-1.10-r10
- >=sys-libs/libsemanage-${SEMNG_VER}[python]
- sys-libs/libcap-ng
- >=sys-libs/libsepol-${SEPOL_VER}
- sys-devel/gettext
- dev-python/ipy[${PYTHON_USEDEP}]
- dbus? (
- sys-apps/dbus
- dev-libs/dbus-glib
- )
- audit? ( >=sys-process/audit-1.5.1 )
- pam? ( sys-libs/pam )
- ${PYTHON_DEPS}"
-
-### libcgroup -> seunshare
-### dbus -> restorecond
-
-# pax-utils for scanelf used by rlpkg
-RDEPEND="${COMMON_DEPS}
- dev-python/sepolgen
- app-misc/pax-utils"
-
-DEPEND="${COMMON_DEPS}"
-
-S="${WORKDIR}/${MY_P}"
-S1="${WORKDIR}/${MY_P}"
-S2="${WORKDIR}/policycoreutils-extra"
-
-src_prepare() {
- epatch "${FILESDIR}/0010-remove-sesandbox-support.patch"
- epatch "${FILESDIR}/0020-disable-autodetection-of-pam-and-audit.patch"
- epatch "${FILESDIR}/0030-make-inotify-check-use-flag-triggered.patch"
- epatch "${FILESDIR}/0040-reverse-access-check-in-run_init.patch"
- epatch "${FILESDIR}/0070-remove-symlink-attempt-fails-with-gentoo-sandbox-approach.patch"
- epatch "${FILESDIR}/0110-build-mcstrans-bug-472912.patch"
- epatch "${FILESDIR}/0120-build-failure-for-mcscolor-for-CONTEXT__CONTAINS.patch"
- epatch "${FILESDIR}/0001-policycoreutils-pp-add-roletype-statements-for-both-.patch"
-
- # rlpkg is more useful than fixfiles
- sed -i -e '/^all/s/fixfiles//' "${S}/scripts/Makefile" \
- || die "fixfiles sed 1 failed"
- sed -i -e '/fixfiles/d' "${S}/scripts/Makefile" \
- || die "fixfiles sed 2 failed"
-
- epatch_user
-
- python_copy_sources
- # Our extra code is outside the regular directory, so set it to the extra
- # directory. We really should optimize this as it is ugly, but the extra
- # code is needed for Gentoo at the same time that policycoreutils is present
- # (so we cannot use an additional package for now).
- S="${S2}"
- python_copy_sources
-}
-
-src_compile() {
- local use_audit="no";
- local use_pam="no";
- local use_dbus="no";
- local use_sesandbox="no";
-
- use audit && use_audit="yes";
- use pam && use_pam="yes";
- use dbus && use_dbus="yes";
-
- building() {
- emake -C "${BUILD_DIR}" AUDIT_LOG_PRIVS="y" AUDITH="${use_audit}" PAMH="${use_pam}" INOTIFYH="${use_dbus}" SESANDBOX="${use_sesandbox}" CC="$(tc-getCC)" PYLIBVER="${EPYTHON}" || die
- }
- S="${S1}" # Regular policycoreutils
- python_foreach_impl building
- S="${S2}" # Extra set
- python_foreach_impl building
-}
-
-src_install() {
- local use_audit="no";
- local use_pam="no";
- local use_dbus="no";
- local use_sesandbox="no";
-
- use audit && use_audit="yes";
- use pam && use_pam="yes";
- use dbus && use_dbus="yes";
-
- # Python scripts are present in many places. There are no extension modules.
- installation-policycoreutils() {
- einfo "Installing policycoreutils"
- emake -C "${BUILD_DIR}" DESTDIR="${D}" AUDITH="${use_audit}" PAMH="${use_pam}" INOTIFYH="${use_dbus}" SESANDBOX="${use_sesandbox}" AUDIT_LOG_PRIV="y" PYLIBVER="${EPYTHON}" install || return 1
- }
-
- installation-extras() {
- einfo "Installing policycoreutils-extra"
- emake -C "${BUILD_DIR}" DESTDIR="${D}" INOTIFYH="${use_dbus}" SHLIBDIR="${D}$(get_libdir)/rc" install || return 1
- }
-
- S="${S1}" # policycoreutils
- python_foreach_impl installation-policycoreutils
- S="${S2}" # extras
- python_foreach_impl installation-extras
- S="${S1}" # back for later
-
- # remove redhat-style init script
- rm -fR "${D}/etc/rc.d"
-
- # compatibility symlinks
- dosym /sbin/setfiles /usr/sbin/setfiles
- dosym /$(get_libdir)/rc/runscript_selinux.so /$(get_libdir)/rcscripts/runscript_selinux.so
-
- # location for permissive definitions
- dodir /var/lib/selinux
- keepdir /var/lib/selinux
-
- # Set version-specific scripts
- for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
- python_replicate_script "${ED}/usr/bin/${pyscript}"
- done
- for pyscript in semanage rlpkg; do
- python_replicate_script "${ED}/usr/sbin/${pyscript}"
- done
-
- dodir /usr/share/doc/${PF}/mcstrans/examples
- cp -dR "${S1}"/mcstrans/share/examples/* "${D}/usr/share/doc/${PF}/mcstrans/examples"
-}
-
-pkg_postinst() {
- # The selinux_gentoo init script is no longer needed with recent OpenRC
- elog "The selinux_gentoo init script will be removed in future versions when OpenRC 0.13.x is stabilized."
-
- # Migrate the SELinux semanage configuration store if not done already
- local selinuxtype=$(awk -F'=' '/SELINUXTYPE=/ {print $2}' /etc/selinux/config);
- if [ -n "${selinuxtype}" ] && [ ! -d /var/lib/selinux/${mcs}/active ] ; then
- ewarn "Since the 2.4 SELinux userspace, the policy module store is moved"
- ewarn "from /etc/selinux to /var/lib/selinux. In order to continue with"
- ewarn "the 2.4 userspace, please migrate the necessary files by executing"
- ewarn "/usr/libexec/selinux/semanage_migrate_store. Warnings about 'else'"
- ewarn "blocks can be safely ignored."
- ewarn "For more information, please see"
- ewarn "- https://github.com/SELinuxProject/selinux/wiki/Policy-Store-Migration"
- fi
-}
diff --git a/sys-apps/policycoreutils/policycoreutils-2.4_rc7.ebuild b/sys-apps/policycoreutils/policycoreutils-2.4_rc7.ebuild
deleted file mode 100644
index 78885a25c04c..000000000000
--- a/sys-apps/policycoreutils/policycoreutils-2.4_rc7.ebuild
+++ /dev/null
@@ -1,151 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-2.4_rc7.ebuild,v 1.1 2014/12/06 23:28:23 perfinion Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="xml"
-
-inherit multilib python-r1 toolchain-funcs eutils
-
-MY_P="${P//_/-}"
-
-EXTRAS_VER="1.33"
-SEMNG_VER="${PV}"
-SELNX_VER="${PV}"
-SEPOL_VER="${PV}"
-
-IUSE="audit pam dbus"
-
-DESCRIPTION="SELinux core utilities"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20140826/${MY_P}.tar.gz
- mirror://gentoo/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND=">=sys-libs/libselinux-${SELNX_VER}[python]
- >=sys-libs/glibc-2.4
- >=sys-libs/libcap-1.10-r10
- >=sys-libs/libsemanage-${SEMNG_VER}[python]
- sys-libs/libcap-ng
- >=sys-libs/libsepol-${SEPOL_VER}
- sys-devel/gettext
- dev-python/ipy[${PYTHON_USEDEP}]
- dbus? (
- sys-apps/dbus
- dev-libs/dbus-glib
- )
- audit? ( >=sys-process/audit-1.5.1 )
- pam? ( sys-libs/pam )
- ${PYTHON_DEPS}"
-
-### libcgroup -> seunshare
-### dbus -> restorecond
-
-# pax-utils for scanelf used by rlpkg
-RDEPEND="${DEPEND}
- dev-python/sepolgen
- app-misc/pax-utils"
-
-S="${WORKDIR}/${MY_P}"
-S1="${WORKDIR}/${MY_P}"
-S2="${WORKDIR}/policycoreutils-extra"
-
-src_prepare() {
- epatch "${FILESDIR}/0010-remove-sesandbox-support.patch"
- epatch "${FILESDIR}/0020-disable-autodetection-of-pam-and-audit.patch"
- epatch "${FILESDIR}/0030-make-inotify-check-use-flag-triggered.patch"
- epatch "${FILESDIR}/0040-reverse-access-check-in-run_init.patch"
- epatch "${FILESDIR}/0070-remove-symlink-attempt-fails-with-gentoo-sandbox-approach.patch"
- epatch "${FILESDIR}/0110-build-mcstrans-bug-472912.patch"
- epatch "${FILESDIR}/0120-build-failure-for-mcscolor-for-CONTEXT__CONTAINS.patch"
-
- # rlpkg is more useful than fixfiles
- sed -i -e '/^all/s/fixfiles//' "${S}/scripts/Makefile" \
- || die "fixfiles sed 1 failed"
- sed -i -e '/fixfiles/d' "${S}/scripts/Makefile" \
- || die "fixfiles sed 2 failed"
-
- epatch_user
-
- python_copy_sources
- # Our extra code is outside the regular directory, so set it to the extra
- # directory. We really should optimize this as it is ugly, but the extra
- # code is needed for Gentoo at the same time that policycoreutils is present
- # (so we cannot use an additional package for now).
- S="${S2}"
- python_copy_sources
-}
-
-src_compile() {
- building() {
- emake -C "${BUILD_DIR}" AUDIT_LOG_PRIVS="y" AUDITH="$(usex audit)" PAMH="$(usex pam)" INOTIFYH="$(usex dbus)" SESANDBOX="n" CC="$(tc-getCC)" PYLIBVER="${EPYTHON}"
- }
- S="${S1}" # Regular policycoreutils
- python_foreach_impl building
- S="${S2}" # Extra set
- python_foreach_impl building
-}
-
-src_install() {
- # Python scripts are present in many places. There are no extension modules.
- installation-policycoreutils() {
- einfo "Installing policycoreutils"
- emake -C "${BUILD_DIR}" DESTDIR="${D}" AUDITH="$(usex audit)" PAMH="$(usex pam)" INOTIFYH="$(usex dbus)" SESANDBOX="n" AUDIT_LOG_PRIV="y" PYLIBVER="${EPYTHON}" install
- python_optimize
- }
-
- installation-extras() {
- einfo "Installing policycoreutils-extra"
- emake -C "${BUILD_DIR}" DESTDIR="${D}" INOTIFYH="$(usex dbus)" SHLIBDIR="${D}$(get_libdir)/rc" install
- python_optimize
- }
-
- S="${S1}" # policycoreutils
- python_foreach_impl installation-policycoreutils
- S="${S2}" # extras
- python_foreach_impl installation-extras
- S="${S1}" # back for later
-
- # remove redhat-style init script
- rm -fR "${D}/etc/rc.d"
-
- # compatibility symlinks
- dosym /sbin/setfiles /usr/sbin/setfiles
- dosym /$(get_libdir)/rc/runscript_selinux.so /$(get_libdir)/rcscripts/runscript_selinux.so
-
- # location for policy definitions
- dodir /var/lib/selinux
- keepdir /var/lib/selinux
-
- # Set version-specific scripts
- for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
- python_replicate_script "${ED}/usr/bin/${pyscript}"
- done
- for pyscript in semanage rlpkg; do
- python_replicate_script "${ED}/usr/sbin/${pyscript}"
- done
-
- dodir /usr/share/doc/${PF}/mcstrans/examples
- cp -dR "${S1}"/mcstrans/share/examples/* "${D}/usr/share/doc/${PF}/mcstrans/examples"
-}
-
-pkg_postinst() {
- # The selinux_gentoo init script is no longer needed with recent OpenRC
- elog "The selinux_gentoo init script will be removed in future versions when OpenRC 0.13.x is stabilized."
-
- # Migrate the SELinux semanage configuration store if not done already
- local selinuxtype=$(awk -F'=' '/SELINUXTYPE=/ {print $2}' /etc/selinux/config);
- if [ -n "${selinuxtype}" ] && [ ! -d /var/lib/selinux/${mcs}/active ] ; then
- ewarn "Since the 2.4 SELinux userspace, the policy module store is moved"
- ewarn "from /etc/selinux to /var/lib/selinux. In order to continue with"
- ewarn "the 2.4 userspace, please migrate the necessary files by executing"
- ewarn "/usr/libexec/selinux/semanage_migrate_store. Warnings about 'else'"
- ewarn "blocks can be safely ignored."
- ewarn "For more information, please see"
- ewarn "- https://github.com/SELinuxProject/selinux/wiki/Policy-Store-Migration"
- fi
-}