summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-15 18:17:03 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-15 18:17:03 +0000
commit50407e0c1bcfcb3c9391f5c9cdfafe57e87e6cf6 (patch)
tree786cc79c029866ee0407b60c1882c69c618b2a74 /sys-apps/rlocate
parentold (diff)
downloadgentoo-2-50407e0c1bcfcb3c9391f5c9cdfafe57e87e6cf6.tar.gz
gentoo-2-50407e0c1bcfcb3c9391f5c9cdfafe57e87e6cf6.tar.bz2
gentoo-2-50407e0c1bcfcb3c9391f5c9cdfafe57e87e6cf6.zip
Fix misc broken hardcoded values #130066 by CBke.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'sys-apps/rlocate')
-rw-r--r--sys-apps/rlocate/ChangeLog8
-rw-r--r--sys-apps/rlocate/files/digest-rlocate-0.5.0-r13
-rw-r--r--sys-apps/rlocate/files/rlocate-0.5.0-settings.patch26
-rw-r--r--sys-apps/rlocate/rlocate-0.5.0-r1.ebuild50
4 files changed, 86 insertions, 1 deletions
diff --git a/sys-apps/rlocate/ChangeLog b/sys-apps/rlocate/ChangeLog
index b21712632519..3a383ad07aed 100644
--- a/sys-apps/rlocate/ChangeLog
+++ b/sys-apps/rlocate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/rlocate
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.13 2006/04/15 02:24:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.14 2006/04/15 18:17:03 vapier Exp $
+
+*rlocate-0.5.0-r1 (15 Apr 2006)
+
+ 15 Apr 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/rlocate-0.5.0-settings.patch, +rlocate-0.5.0-r1.ebuild:
+ Fix misc broken hardcoded values #130066 by CBke.
*rlocate-0.5.0 (15 Apr 2006)
diff --git a/sys-apps/rlocate/files/digest-rlocate-0.5.0-r1 b/sys-apps/rlocate/files/digest-rlocate-0.5.0-r1
new file mode 100644
index 000000000000..49fd85a59b60
--- /dev/null
+++ b/sys-apps/rlocate/files/digest-rlocate-0.5.0-r1
@@ -0,0 +1,3 @@
+MD5 4e27e57d315c908f5dd67104f0c40a2d rlocate-0.5.0.tar.gz 178201
+RMD160 5cffda20db76de7d6bd7c362c8aa9aa992639ea4 rlocate-0.5.0.tar.gz 178201
+SHA256 ea003868f59111932c85fa1d560fa2d315b16f0e5c2db2ffab4846c3f0c640b5 rlocate-0.5.0.tar.gz 178201
diff --git a/sys-apps/rlocate/files/rlocate-0.5.0-settings.patch b/sys-apps/rlocate/files/rlocate-0.5.0-settings.patch
new file mode 100644
index 000000000000..e9ff4d8679c6
--- /dev/null
+++ b/sys-apps/rlocate/files/rlocate-0.5.0-settings.patch
@@ -0,0 +1,26 @@
+--- src/slocate.h
++++ src/slocate.h
+@@ -35,20 +35,11 @@
+ #define MTAB_FILE "/etc/mtab"
+ #define UPDATEDB_FILE "/etc/updatedb.conf"
+
+-/* More fitting paths for FreeBSD -matt */
+-#if defined(__FreeBSD__)
+-# define DEFAULT_DB "/var/db/slocate/slocate.db"
+-# define DEFAULT_DB_DIR "/var/db/slocate/"
+-#elif defined(__SunOS__)
+-# define DEFAULT_DB "/var/db/slocate/slocate.db"
+-# define DEFAULT_DB_DIR "/var/db/slocate/"
+-#else
+-# define DEFAULT_DB "/usr/local/var/rlocate/rlocate.db"
+-# define DEFAULT_DB_DIR "/usr/local/var/rlocate/"
+-#endif
++#define DEFAULT_DB "/var/lib/rlocate/rlocate.db"
++#define DEFAULT_DB_DIR "/var/lib/rlocate/"
+
+ #define DB_UID 0
+-#define DB_GROUP "rlocate"
++#define DB_GROUP "locate"
+ #define DB_MODE 00640
+
+ #define SLOC_ESC -0x80
diff --git a/sys-apps/rlocate/rlocate-0.5.0-r1.ebuild b/sys-apps/rlocate/rlocate-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..eb88f0c93764
--- /dev/null
+++ b/sys-apps/rlocate/rlocate-0.5.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.5.0-r1.ebuild,v 1.1 2006/04/15 18:17:03 vapier Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="locate implementation that is always up-to-date"
+HOMEPAGE="http://rlocate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rlocate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate"
+
+pkg_setup() {
+ MODULE_NAMES="rlocate(misc:${S}/src/rlocate-module)"
+ CONFIG_CHECK="SECURITY"
+ SECURITY_ERROR="You need to select the \"Enable different security models\" option in the kernel configuration (CONFIG_SECURITY)."
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+
+ enewgroup locate
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.5.0-build.patch
+ epatch "${FILESDIR}"/${PN}-0.5.0-settings.patch
+}
+
+src_compile() {
+ econf \
+ --with-kernel=${KV_DIR} \
+ --with-rlocate-group=locate \
+ || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+die
+ make install DESTDIR="${D}" || die
+ newinitd "${FILESDIR}"/rlocated.rc rlocated
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog* NEWS README
+}