summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-07 15:54:34 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-07 15:54:34 +0000
commit35dfb50547b71d046e7dc8248e65707a87930906 (patch)
tree5e704e4edfbed98e8e2a7726cbb2b20d56ba4cb0 /sys-apps/sed
parentadded fix for ximian's openoffice apps (Manifest recommit) (diff)
downloadgentoo-2-35dfb50547b71d046e7dc8248e65707a87930906.tar.gz
gentoo-2-35dfb50547b71d046e7dc8248e65707a87930906.tar.bz2
gentoo-2-35dfb50547b71d046e7dc8248e65707a87930906.zip
dont try to bootstrap sed if USE="bootstrap build" and use type -p instead of which (THX SOLAR I LUB J00)
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/sed-4.0.9.ebuild16
-rw-r--r--sys-apps/sed/sed-4.1.2.ebuild16
2 files changed, 18 insertions, 14 deletions
diff --git a/sys-apps/sed/sed-4.0.9.ebuild b/sys-apps/sed/sed-4.0.9.ebuild
index a1f1193bb573..b96b4534870b 100644
--- a/sys-apps/sed/sed-4.0.9.ebuild
+++ b/sys-apps/sed/sed-4.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.9.ebuild,v 1.26 2004/10/03 08:58:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.9.ebuild,v 1.27 2004/10/07 15:54:34 vapier Exp $
inherit gnuconfig flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/sed/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha arm amd64 hppa ia64 macos mips ppc ppc64 ppc-macos s390 sparc x86"
-IUSE="nls static build"
+IUSE="nls static build bootstrap"
RDEPEND="virtual/libc"
DEPEND="${RDEPEND}
@@ -26,11 +26,13 @@ src_unpack() {
src_compile() {
# make sure system-sed works #40786
export NO_SYS_SED=""
- if ! which sed >& /dev/null ; then
- NO_SYS_SED="!!!"
- ./bootstrap.sh || die "couldnt bootstrap"
- cp sed/sed ${T}/ || die "couldnt copy"
- export PATH="${PATH}:${T}"
+ if ! use bootstrap && ! use build ; then
+ if ! type -p sed ; then
+ NO_SYS_SED="!!!"
+ ./bootstrap.sh || die "couldnt bootstrap"
+ cp sed/sed ${T}/ || die "couldnt copy"
+ export PATH="${PATH}:${T}"
+ fi
fi
local myconf=""
diff --git a/sys-apps/sed/sed-4.1.2.ebuild b/sys-apps/sed/sed-4.1.2.ebuild
index 72f7177ae6f1..5659cc07d28a 100644
--- a/sys-apps/sed/sed-4.1.2.ebuild
+++ b/sys-apps/sed/sed-4.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.1.2.ebuild,v 1.5 2004/10/03 08:58:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.1.2.ebuild,v 1.6 2004/10/07 15:54:34 vapier Exp $
inherit gnuconfig flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/sed/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~arm ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sparc ~x86"
-IUSE="nls static build"
+IUSE="nls static build bootstrap"
RDEPEND="virtual/libc"
DEPEND="${RDEPEND}
@@ -26,11 +26,13 @@ src_unpack() {
src_compile() {
# make sure system-sed works #40786
export NO_SYS_SED=""
- if ! which sed >& /dev/null ; then
- NO_SYS_SED="!!!"
- ./bootstrap.sh || die "couldnt bootstrap"
- cp sed/sed ${T}/ || die "couldnt copy"
- export PATH="${PATH}:${T}"
+ if ! use bootstrap && ! use build ; then
+ if ! type -p sed ; then
+ NO_SYS_SED="!!!"
+ ./bootstrap.sh || die "couldnt bootstrap"
+ cp sed/sed ${T}/ || die "couldnt copy"
+ export PATH="${PATH}:${T}"
+ fi
fi
local myconf=""