summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-04-07 05:54:21 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-04-07 05:54:21 +0000
commit433ecab48d5a5e4c55f9ae508d1b694a580f5bc7 (patch)
tree9ba2b5b71ffc6f9248e56a3aa19a4d38752a5a43 /sys-apps/sg3_utils
parentDue to portage's environment filtering, variables that start with BASH_ canno... (diff)
downloadgentoo-2-433ecab48d5a5e4c55f9ae508d1b694a580f5bc7.tar.gz
gentoo-2-433ecab48d5a5e4c55f9ae508d1b694a580f5bc7.tar.bz2
gentoo-2-433ecab48d5a5e4c55f9ae508d1b694a580f5bc7.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/sg3_utils')
-rw-r--r--sys-apps/sg3_utils/ChangeLog7
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.29.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/sys-apps/sg3_utils/ChangeLog b/sys-apps/sg3_utils/ChangeLog
index 49490c8213a3..cd664ed9f48b 100644
--- a/sys-apps/sg3_utils/ChangeLog
+++ b/sys-apps/sg3_utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sg3_utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.58 2010/04/03 15:11:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.59 2010/04/07 05:54:21 robbat2 Exp $
+
+*sg3_utils-1.29 (07 Apr 2010)
+
+ 07 Apr 2010; Robin H. Johnson <robbat2@gentoo.org> +sg3_utils-1.29.ebuild:
+ Version bump.
03 Apr 2010; Raúl Porcel <armin76@gentoo.org> sg3_utils-1.25.ebuild,
sg3_utils-1.26.ebuild, sg3_utils-1.26-r1.ebuild,
diff --git a/sys-apps/sg3_utils/sg3_utils-1.29.ebuild b/sys-apps/sg3_utils/sg3_utils-1.29.ebuild
new file mode 100644
index 000000000000..76cd87aec3ae
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.29.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.29.ebuild,v 1.1 2010/04/07 05:54:21 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="http://sg.danny.cz/sg/"
+SRC_URI="http://sg.danny.cz/sg/p/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-devel/libtool"
+RDEPEND="sys-apps/sdparm"
+PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.26-stdint.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc ChangeLog AUTHORS COVERAGE CREDITS README*
+ dodoc doc/README examples/*.txt
+ newdoc scripts/README README.scripts
+ dosbin scripts/scsi* || die
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${D}"/usr/$(get_libdir)/libsgutils2.*; do
+ lib=${lib##*/}
+ dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+}