summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-11-04 04:17:14 +0000
committerMike Frysinger <vapier@gentoo.org>2007-11-04 04:17:14 +0000
commit42f967843ecaf585a4f5e038329865c2f058c379 (patch)
tree9825725a9f1f345414725e8889b99b5002b01167 /sys-apps/shadow
parentstable ppc, bug #197933 (diff)
downloadgentoo-2-42f967843ecaf585a4f5e038329865c2f058c379.tar.gz
gentoo-2-42f967843ecaf585a4f5e038329865c2f058c379.tar.bz2
gentoo-2-42f967843ecaf585a4f5e038329865c2f058c379.zip
Version bump.
(Portage version: 2.1.3.16)
Diffstat (limited to 'sys-apps/shadow')
-rw-r--r--sys-apps/shadow/ChangeLog8
-rw-r--r--sys-apps/shadow/files/digest-shadow-4.0.18.23
-rw-r--r--sys-apps/shadow/files/shadow-4.0.18.2-useradd.patch22
-rw-r--r--sys-apps/shadow/shadow-4.0.18.2.ebuild207
4 files changed, 239 insertions, 1 deletions
diff --git a/sys-apps/shadow/ChangeLog b/sys-apps/shadow/ChangeLog
index e0594efca026..a0fac212edb5 100644
--- a/sys-apps/shadow/ChangeLog
+++ b/sys-apps/shadow/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/shadow
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/ChangeLog,v 1.177 2007/07/05 15:36:07 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/ChangeLog,v 1.178 2007/11/04 04:17:13 vapier Exp $
+
+*shadow-4.0.18.2 (04 Nov 2007)
+
+ 04 Nov 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/shadow-4.0.18.2-useradd.patch, +shadow-4.0.18.2.ebuild:
+ Version bump.
05 Jul 2007; Brent Baude <ranger@gentoo.org> shadow-4.0.18.1-r1.ebuild:
Marking shadow-4.0.18.1-r1 ppc64 stable for bug 183886
diff --git a/sys-apps/shadow/files/digest-shadow-4.0.18.2 b/sys-apps/shadow/files/digest-shadow-4.0.18.2
new file mode 100644
index 000000000000..c58c5020dc7c
--- /dev/null
+++ b/sys-apps/shadow/files/digest-shadow-4.0.18.2
@@ -0,0 +1,3 @@
+MD5 c3cf8814cc1323ecafd953b00efcba50 shadow_4.0.18.2.orig.tar.gz 2501791
+RMD160 f13d5c06bc88eea8d851a8c396110b2e96d1bb39 shadow_4.0.18.2.orig.tar.gz 2501791
+SHA256 0b3cbfb32200cacd8544734d227d0a576642baf573f972f046bbbae457145cae shadow_4.0.18.2.orig.tar.gz 2501791
diff --git a/sys-apps/shadow/files/shadow-4.0.18.2-useradd.patch b/sys-apps/shadow/files/shadow-4.0.18.2-useradd.patch
new file mode 100644
index 000000000000..1135500758b8
--- /dev/null
+++ b/sys-apps/shadow/files/shadow-4.0.18.2-useradd.patch
@@ -0,0 +1,22 @@
+--- shadow-4.0.18.2/src/useradd.c
++++ shadow-4.0.18.2/src/useradd.c
+@@ -203,14 +203,18 @@
+ long gid;
+ char *errptr;
+
++ struct group* grp = getgrnam (grname);
++ if (grp)
++ return grp;
++
+ gid = strtol (grname, &errptr, 10);
+ if (*errptr || errno == ERANGE || gid < 0) {
+ fprintf (stderr,
+ _("%s: invalid numeric argument '%s'\n"), Prog,
+ grname);
+ exit (E_BAD_ARG);
+ }
+- return getgrnam (grname);
++ return getgrgid (gid);
+ }
+
+ static long get_number (const char *numstr)
diff --git a/sys-apps/shadow/shadow-4.0.18.2.ebuild b/sys-apps/shadow/shadow-4.0.18.2.ebuild
new file mode 100644
index 000000000000..390c57f8de05
--- /dev/null
+++ b/sys-apps/shadow/shadow-4.0.18.2.ebuild
@@ -0,0 +1,207 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.18.2.ebuild,v 1.1 2007/11/04 04:17:13 vapier Exp $
+
+inherit eutils libtool toolchain-funcs autotools pam
+
+DESCRIPTION="Utilities to deal with user accounts"
+HOMEPAGE="http://shadow.pld.org.pl/ http://packages.qa.debian.org/s/shadow.html"
+SRC_URI="mirror://debian/pool/main/s/shadow/shadow_${PV}.orig.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls pam selinux skey nousuid cracklib"
+
+RDEPEND="cracklib? ( >=sys-libs/cracklib-2.7-r3 )
+ pam? ( virtual/pam )
+ !sys-apps/pam-login
+ !app-admin/nologin
+ skey? ( app-admin/skey )
+ selinux? ( >=sys-libs/libselinux-1.28 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # uclibc support, corrects NIS usage
+ epatch "${FILESDIR}"/${PN}-4.0.13-nonis.patch
+
+ # If su should not simulate a login shell, use '/bin/sh' as shell to enable
+ # running of commands as user with /bin/false as shell, closing bug #15015.
+ # *** This one could be a security hole; disable for now ***
+ #epatch "${FILESDIR}"/${P}-nologin-run-sh.patch
+
+ # tweak the default login.defs
+ epatch "${FILESDIR}"/${PN}-4.0.17-login.defs.patch
+
+ # Make user/group names more flexible #3485 / #22920
+ epatch "${FILESDIR}"/${PN}-4.0.13-dots-in-usernames.patch
+ epatch "${FILESDIR}"/${PN}-4.0.13-long-groupnames.patch
+
+ # Fix compiling with gcc-2.95.x
+ epatch "${FILESDIR}"/${PN}-4.0.12-gcc2.patch
+
+ # lock down setuid perms #47208
+ epatch "${FILESDIR}"/${PN}-4.0.11.1-perms.patch
+
+ epatch "${FILESDIR}"/${PN}-4.0.15-uclibc-missing-l64a.patch
+ epatch "${FILESDIR}"/${PN}-4.0.16-fix-useradd-usergroups.patch #128715
+ epatch "${FILESDIR}"/${PN}-4.0.18.2-useradd.patch
+
+ # Needed by the UCLIBC patches
+ eautoconf || die
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ tc-is-cross-compiler && export ac_cv_func_setpgrp_void=yes
+ econf \
+ --disable-desrpc \
+ --with-libcrypt \
+ --enable-shared=no \
+ --enable-static=yes \
+ $(use_with cracklib libcrack) \
+ $(use_with pam libpam) \
+ $(use_with skey) \
+ $(use_with selinux) \
+ $(use_enable nls) \
+ || die "bad configure"
+ emake || die "compile problem"
+}
+
+src_install() {
+ local perms=4711
+ use nousuid && perms=711
+ make DESTDIR="${D}" suiduperms=${perms} install || die "install problem"
+ dosym useradd /usr/sbin/adduser
+
+ # Remove libshadow and libmisc; see bug 37725 and the following
+ # comment from shadow's README.linux:
+ # Currently, libshadow.a is for internal use only, so if you see
+ # -lshadow in a Makefile of some other package, it is safe to
+ # remove it.
+ rm -f "${D}"/{,usr/}$(get_libdir)/lib{misc,shadow}.{a,la}
+
+ insinto /etc
+ # Using a securetty with devfs device names added
+ # (compat names kept for non-devfs compatibility)
+ insopts -m0600 ; doins "${FILESDIR}"/securetty
+ if ! use pam ; then
+ insopts -m0600
+ doins etc/login.access etc/limits
+ else
+ newpamd "${FILESDIR}/login.pamd.1" login
+ use selinux || sed -i -e '/@selinux@/d' "${D}"/etc/pam.d/login
+ use selinux && sed -i -e 's:@selinux@::g' "${D}"/etc/pam.d/login
+ fi
+ # Output arch-specific cruft
+ case $(tc-arch) in
+ ppc*) echo "hvc0" >> "${D}"/etc/securetty
+ echo "hvsi0" >> "${D}"/etc/securetty
+ echo "ttyPSC0" >> "${D}"/etc/securetty;;
+ hppa) echo "ttyB0" >> "${D}"/etc/securetty;;
+ arm) echo "ttyFB0" >> "${D}"/etc/securetty;;
+ sh) echo "ttySC0" >> "${D}"/etc/securetty
+ echo "ttySC1" >> "${D}"/etc/securetty;;
+ esac
+
+ # needed for 'adduser -D'
+ insinto /etc/default
+ insopts -m0600
+ doins "${FILESDIR}"/default/useradd
+
+ # move passwd to / to help recover broke systems #64441
+ mv "${D}"/usr/bin/passwd "${D}"/bin/
+ dosym /bin/passwd /usr/bin/passwd
+
+ if use pam ; then
+ local INSTALL_SYSTEM_PAMD="yes"
+
+ # Do not install below pam.d files if we have pam-0.78 or later
+ has_version '>=sys-libs/pam-0.78' && \
+ INSTALL_SYSTEM_PAMD="no"
+
+ for x in "${FILESDIR}"/pam.d-include/*; do
+ case "${x##*/}" in
+ "login")
+ # We do no longer install this one, as its from
+ # pam-login now.
+ ;;
+ "system-auth"|"system-auth-1.1"|"other")
+ # These we only install if we do not have pam-0.78
+ # or later.
+ [ "${INSTALL_SYSTEM_PAMD}" = "yes" ] && [ -f ${x} ] && \
+ dopamd ${x}
+ ;;
+ "su")
+ # Disable support for pam_env and pam_wheel on openpam
+ has_version sys-libs/pam && dopamd ${x}
+ ;;
+ "su-openpam")
+ has_version sys-libs/openpam && newpamd ${x} su
+ ;;
+ *)
+ [ -f ${x} ] && dopamd ${x}
+ ;;
+ esac
+ done
+ for x in chage chsh chfn chpasswd newusers \
+ user{add,del,mod} group{add,del,mod} ; do
+ newpamd "${FILESDIR}"/pam.d-include/shadow ${x}
+ done
+
+ # remove manpages that pam will install for us
+ # and/or don't apply when using pam
+
+ find "${D}"/usr/share/man \
+ '(' -name 'limits.5*' -o -name 'suauth.5*' ')' \
+ -exec rm {} \;
+ fi
+
+ cd "${S}"
+ insinto /etc
+ insopts -m0644
+ newins etc/login.defs login.defs
+
+ # comment out options that pam hates
+ if use pam ; then
+ awk -f "${FILESDIR}"/login_defs.awk \
+ lib/getdef.c etc/login.defs \
+ > "${D}"/etc/login.defs
+ fi
+
+ # Remove manpages that are handled by other packages
+ find "${D}"/usr/share/man \
+ '(' -name id.1 -o -name passwd.5 -o -name getspnam.3 ')' \
+ -exec rm {} \;
+
+ cd "${S}"
+ dodoc ChangeLog NEWS TODO
+ newdoc README README.download
+ cd doc
+ dodoc HOWTO README* WISHLIST *.txt
+}
+
+pkg_preinst() {
+ rm -f "${ROOT}"/etc/pam.d/system-auth.new \
+ "${ROOT}/etc/login.defs.new"
+}
+
+pkg_postinst() {
+ # Enable shadow groups (we need ROOT=/ here, as grpconv only
+ # operate on / ...).
+ if [[ ${ROOT} == / && ! -f /etc/gshadow ]] ; then
+ if grpck -r &>/dev/null; then
+ grpconv
+ else
+ ewarn "Running 'grpck' returned errors. Please run it by hand, and then"
+ ewarn "run 'grpconv' afterwards!"
+ fi
+ fi
+}