summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-11 08:52:33 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-11 08:52:33 +0000
commitfaf09ce3751b13678f5f5426cc32deaec7bcfb2e (patch)
tree2ac50b7499cd7890c48f88cc57ccea667ba17229 /sys-apps/systemd-ui
parentapp-emulation/libvirt: Fix typo, #476466 (diff)
downloadgentoo-2-faf09ce3751b13678f5f5426cc32deaec7bcfb2e.tar.gz
gentoo-2-faf09ce3751b13678f5f5426cc32deaec7bcfb2e.tar.bz2
gentoo-2-faf09ce3751b13678f5f5426cc32deaec7bcfb2e.zip
Use systemd_get_utildir to get the systemd path.
Diffstat (limited to 'sys-apps/systemd-ui')
-rw-r--r--sys-apps/systemd-ui/ChangeLog6
-rw-r--r--sys-apps/systemd-ui/systemd-ui-2.ebuild6
-rw-r--r--sys-apps/systemd-ui/systemd-ui-9999.ebuild6
3 files changed, 11 insertions, 7 deletions
diff --git a/sys-apps/systemd-ui/ChangeLog b/sys-apps/systemd-ui/ChangeLog
index 7924d209db93..7c04f138f939 100644
--- a/sys-apps/systemd-ui/ChangeLog
+++ b/sys-apps/systemd-ui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/systemd-ui
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/ChangeLog,v 1.4 2013/03/29 14:16:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/ChangeLog,v 1.5 2013/07/11 08:52:33 mgorny Exp $
+
+ 11 Jul 2013; Michał Górny <mgorny@gentoo.org> systemd-ui-2.ebuild,
+ systemd-ui-9999.ebuild:
+ Use systemd_get_utildir to get the systemd path.
29 Mar 2013; Michał Górny <mgorny@gentoo.org> -systemd-ui-1.ebuild,
systemd-ui-2.ebuild, systemd-ui-9999.ebuild:
diff --git a/sys-apps/systemd-ui/systemd-ui-2.ebuild b/sys-apps/systemd-ui/systemd-ui-2.ebuild
index f34c9d91d8f1..076cd6f09544 100644
--- a/sys-apps/systemd-ui/systemd-ui-2.ebuild
+++ b/sys-apps/systemd-ui/systemd-ui-2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/systemd-ui-2.ebuild,v 1.2 2013/03/29 14:16:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/systemd-ui-2.ebuild,v 1.3 2013/07/11 08:52:33 mgorny Exp $
EAPI=4
VALA_MIN_API_VERSION=0.14
VALA_MAX_API_VERSION=0.20
-inherit autotools-utils vala
+inherit autotools-utils systemd vala
DESCRIPTION="System and service manager for Linux"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
@@ -39,7 +39,7 @@ src_prepare() {
touch src/*.vala || die
# Fix hardcoded path in .vala.
- sed -i -e 's:/lib/systemd:/usr&:g' src/*.vala || die
+ sed -i -e "s^/lib/systemd^$(systemd_get_utildir)^g" src/*.vala || die
autotools-utils_src_prepare
}
diff --git a/sys-apps/systemd-ui/systemd-ui-9999.ebuild b/sys-apps/systemd-ui/systemd-ui-9999.ebuild
index d5702e69ca6a..e1ff2e08f6ec 100644
--- a/sys-apps/systemd-ui/systemd-ui-9999.ebuild
+++ b/sys-apps/systemd-ui/systemd-ui-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/systemd-ui-9999.ebuild,v 1.2 2013/03/29 14:16:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/systemd-ui-9999.ebuild,v 1.3 2013/07/11 08:52:33 mgorny Exp $
EAPI=4
@@ -15,7 +15,7 @@ inherit git-2
VALA_MIN_API_VERSION=0.14
VALA_MAX_API_VERSION=0.20
-inherit autotools-utils vala
+inherit autotools-utils systemd vala
DESCRIPTION="System and service manager for Linux"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
@@ -55,7 +55,7 @@ src_prepare() {
touch src/*.vala || die
# Fix hardcoded path in .vala.
- sed -i -e 's:/lib/systemd:/usr&:g' src/*.vala || die
+ sed -i -e "s^/lib/systemd^$(systemd_get_utildir)^g" src/*.vala || die
autotools-utils_src_prepare
}