summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-08-15 17:52:17 +0000
committerTim Harder <radhermit@gentoo.org>2014-08-15 17:52:17 +0000
commit23cd0f5786859b613caccc618eb9817ed0505462 (patch)
tree537d9d3384bf803f4becca58f8e605a0e50f758d /sys-apps/the_silver_searcher
parentRemove sys-block/thin-provisioning-tools test from p.use.stable.mask as deps ... (diff)
downloadgentoo-2-23cd0f5786859b613caccc618eb9817ed0505462.tar.gz
gentoo-2-23cd0f5786859b613caccc618eb9817ed0505462.tar.bz2
gentoo-2-23cd0f5786859b613caccc618eb9817ed0505462.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps/the_silver_searcher')
-rw-r--r--sys-apps/the_silver_searcher/ChangeLog8
-rw-r--r--sys-apps/the_silver_searcher/the_silver_searcher-0.24.1.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-apps/the_silver_searcher/ChangeLog b/sys-apps/the_silver_searcher/ChangeLog
index a6fe16baebd8..aa49061ff2ea 100644
--- a/sys-apps/the_silver_searcher/ChangeLog
+++ b/sys-apps/the_silver_searcher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/the_silver_searcher
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/ChangeLog,v 1.40 2014/07/16 07:58:07 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/ChangeLog,v 1.41 2014/08/15 17:52:17 radhermit Exp $
+
+*the_silver_searcher-0.24.1 (15 Aug 2014)
+
+ 15 Aug 2014; Tim Harder <radhermit@gentoo.org>
+ +the_silver_searcher-0.24.1.ebuild:
+ Version bump.
16 Jul 2014; Mikle Kolyada <zlogene@gentoo.org>
the_silver_searcher-0.23.0.ebuild:
diff --git a/sys-apps/the_silver_searcher/the_silver_searcher-0.24.1.ebuild b/sys-apps/the_silver_searcher/the_silver_searcher-0.24.1.ebuild
new file mode 100644
index 000000000000..5e56b5f9853b
--- /dev/null
+++ b/sys-apps/the_silver_searcher/the_silver_searcher-0.24.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/the_silver_searcher-0.24.1.ebuild,v 1.1 2014/08/15 17:52:17 radhermit Exp $
+
+EAPI=5
+inherit autotools bash-completion-r1
+
+DESCRIPTION="A code-searching tool similar to ack, but faster"
+HOMEPAGE="http://github.com/ggreer/the_silver_searcher"
+SRC_URI="https://github.com/ggreer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="lzma zlib"
+
+RDEPEND="dev-libs/libpcre
+ lzma? ( app-arch/xz-utils )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README.md"
+
+src_prepare() {
+ sed -i '/^dist_bashcomp/d' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable lzma) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ default
+ newbashcomp ag.bashcomp.sh ag
+}