summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-03-13 01:04:13 +0000
committerTim Harder <radhermit@gentoo.org>2014-03-13 01:04:13 +0000
commite72023b772780aff8e25239533258e3fe6cd37f2 (patch)
tree3eae5238d2948242aff6e82a20f05f6b1f20415b /sys-apps/the_silver_searcher
parentupdate (diff)
downloadgentoo-2-e72023b772780aff8e25239533258e3fe6cd37f2.tar.gz
gentoo-2-e72023b772780aff8e25239533258e3fe6cd37f2.tar.bz2
gentoo-2-e72023b772780aff8e25239533258e3fe6cd37f2.zip
Version bump, add zlib use flag.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps/the_silver_searcher')
-rw-r--r--sys-apps/the_silver_searcher/ChangeLog8
-rw-r--r--sys-apps/the_silver_searcher/the_silver_searcher-0.20.0.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-apps/the_silver_searcher/ChangeLog b/sys-apps/the_silver_searcher/ChangeLog
index aef9deee12c6..51f049f1c4ea 100644
--- a/sys-apps/the_silver_searcher/ChangeLog
+++ b/sys-apps/the_silver_searcher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/the_silver_searcher
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/ChangeLog,v 1.34 2014/03/03 23:52:10 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/ChangeLog,v 1.35 2014/03/13 01:04:13 radhermit Exp $
+
+*the_silver_searcher-0.20.0 (13 Mar 2014)
+
+ 13 Mar 2014; Tim Harder <radhermit@gentoo.org>
+ +the_silver_searcher-0.20.0.ebuild:
+ Version bump, add zlib use flag.
03 Mar 2014; Pacho Ramos <pacho@gentoo.org> the_silver_searcher-0.18.ebuild:
amd64 stable, bug #495934
diff --git a/sys-apps/the_silver_searcher/the_silver_searcher-0.20.0.ebuild b/sys-apps/the_silver_searcher/the_silver_searcher-0.20.0.ebuild
new file mode 100644
index 000000000000..af5189b2b9a4
--- /dev/null
+++ b/sys-apps/the_silver_searcher/the_silver_searcher-0.20.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/the_silver_searcher-0.20.0.ebuild,v 1.1 2014/03/13 01:04:13 radhermit Exp $
+
+EAPI=5
+inherit autotools bash-completion-r1 eutils
+
+DESCRIPTION="A code-searching tool similar to ack, but faster"
+HOMEPAGE="http://github.com/ggreer/the_silver_searcher"
+SRC_URI="https://github.com/ggreer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="lzma zlib"
+
+RDEPEND="dev-libs/libpcre
+ lzma? ( app-arch/xz-utils )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README.md"
+
+src_prepare() {
+ sed -i '/^dist_bashcomp/d' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable lzma) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ default
+ newbashcomp ag.bashcomp.sh ag
+}