summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-04-04 11:40:40 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-04-04 11:40:40 +0000
commit944216890f62b2182a7e0a57c75ceb612a5fb76a (patch)
tree5072f9a12eead116123008bb5fd9647cc12755fb /sys-apps/tuxonice-userui
parentRemove old versions. (diff)
downloadgentoo-2-944216890f62b2182a7e0a57c75ceb612a5fb76a.tar.gz
gentoo-2-944216890f62b2182a7e0a57c75ceb612a5fb76a.tar.bz2
gentoo-2-944216890f62b2182a7e0a57c75ceb612a5fb76a.zip
Version bump.
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/tuxonice-userui')
-rw-r--r--sys-apps/tuxonice-userui/ChangeLog8
-rw-r--r--sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch26
-rw-r--r--sys-apps/tuxonice-userui/tuxonice-userui-1.0.ebuild60
3 files changed, 93 insertions, 1 deletions
diff --git a/sys-apps/tuxonice-userui/ChangeLog b/sys-apps/tuxonice-userui/ChangeLog
index fcf36f820453..824cc58b317f 100644
--- a/sys-apps/tuxonice-userui/ChangeLog
+++ b/sys-apps/tuxonice-userui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/tuxonice-userui
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuxonice-userui/ChangeLog,v 1.11 2009/02/22 20:46:03 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuxonice-userui/ChangeLog,v 1.12 2009/04/04 11:40:40 nelchael Exp $
+
+*tuxonice-userui-1.0 (04 Apr 2009)
+
+ 04 Apr 2009; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/tuxonice-userui-1.0-Makefiles.patch, +tuxonice-userui-1.0.ebuild:
+ Version bump.
22 Feb 2009; Krzysiek Pawlik <nelchael@gentoo.org>
tuxonice-userui-0.7.3.ebuild:
diff --git a/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch b/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch
new file mode 100644
index 000000000000..eee62228b460
--- /dev/null
+++ b/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch
@@ -0,0 +1,26 @@
+--- tuxonice-userui-1.0.vanilla/Makefile 2009-04-04 12:37:13.000000000 +0100
++++ tuxonice-userui-1.0/Makefile 2009-04-04 12:37:54.000000000 +0100
+@@ -32,10 +32,10 @@
+ all: $(TARGETS)
+
+ fbsplash:
+- make -C $@ all
++ $(MAKE) -C $@ all
+
+ usplash:
+- make -C $@ all
++ $(MAKE) -C $@ all
+
+ tuxoniceui_text: $(CORE_OBJECTS) userui_text.o
+ $(CC) $(LDFLAGS) -static $^ -o $@
+@@ -48,8 +48,8 @@
+
+ clean:
+ $(RM) *.o $(TARGETS)
+- make -C fbsplash clean
+- make -C usplash clean
++ $(MAKE) -C fbsplash clean
++ $(MAKE) -C usplash clean
+
+ $(INSTDIR)/%: %
+ strip $<
diff --git a/sys-apps/tuxonice-userui/tuxonice-userui-1.0.ebuild b/sys-apps/tuxonice-userui/tuxonice-userui-1.0.ebuild
new file mode 100644
index 000000000000..411bc81031ef
--- /dev/null
+++ b/sys-apps/tuxonice-userui/tuxonice-userui-1.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuxonice-userui/tuxonice-userui-1.0.ebuild,v 1.1 2009/04/04 11:40:40 nelchael Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="User Interface for TuxOnIce"
+HOMEPAGE="http://www.tuxonice.net"
+SRC_URI="http://www.tuxonice.net/downloads/all/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="fbsplash"
+DEPEND="fbsplash? ( >=media-gfx/splashutils-1.5.2.1
+ media-libs/libmng[lcms] )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-Makefiles.patch"
+}
+
+src_compile() {
+ # Package contain binaries
+ emake clean
+
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ tuxoniceui_text || die "emake tuxoniceui_text failed"
+
+ if use fbsplash; then
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ tuxoniceui_fbsplash || die "emake tuxoniceui_fbsplash failed"
+ fi
+}
+
+src_install() {
+ into /
+ dosbin tuxoniceui_text
+ use fbsplash && dosbin tuxoniceui_fbsplash
+ dodoc AUTHORS ChangeLog KERNEL_API README TODO USERUI_API
+}
+
+pkg_postinst() {
+ if use fbsplash; then
+ einfo
+ einfo "You must create a symlink from /etc/splash/tuxonice"
+ einfo "to the theme you want tuxonice to use, e.g.:"
+ einfo
+ einfo " # ln -sfn /etc/splash/emergence /etc/splash/tuxonice"
+ fi
+ einfo
+ einfo "Please see /usr/share/doc/${PF}/README.* for further"
+ einfo "instructions."
+ einfo
+}