summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-04-06 16:57:17 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-04-06 16:57:17 +0000
commit8a7a0198d6fb5133582ebd41190211b2a8d47b20 (patch)
tree5bf1643438d112f8b0a134ccfd0edeb4c847791b /sys-apps/ucspi-tcp
parentStable on ppc64; bug #215735 (diff)
downloadgentoo-2-8a7a0198d6fb5133582ebd41190211b2a8d47b20.tar.gz
gentoo-2-8a7a0198d6fb5133582ebd41190211b2a8d47b20.tar.bz2
gentoo-2-8a7a0198d6fb5133582ebd41190211b2a8d47b20.zip
fix #135571; use new qmail.eclass; ebuild cleanup
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-apps/ucspi-tcp')
-rw-r--r--sys-apps/ucspi-tcp/ChangeLog8
-rw-r--r--sys-apps/ucspi-tcp/files/0.88-exit.patch10
-rw-r--r--sys-apps/ucspi-tcp/ucspi-tcp-0.88-r17.ebuild92
3 files changed, 109 insertions, 1 deletions
diff --git a/sys-apps/ucspi-tcp/ChangeLog b/sys-apps/ucspi-tcp/ChangeLog
index d51499509fa9..e9604a4fa70d 100644
--- a/sys-apps/ucspi-tcp/ChangeLog
+++ b/sys-apps/ucspi-tcp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/ucspi-tcp
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ucspi-tcp/ChangeLog,v 1.58 2008/02/05 11:22:55 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ucspi-tcp/ChangeLog,v 1.59 2008/04/06 16:57:17 hollow Exp $
+
+*ucspi-tcp-0.88-r17 (06 Apr 2008)
+
+ 06 Apr 2008; Benedikt Böhm <hollow@gentoo.org> +files/0.88-exit.patch,
+ +ucspi-tcp-0.88-r17.ebuild:
+ fix #135571; use new qmail.eclass; ebuild cleanup
05 Feb 2008; Markus Rothe <corsair@gentoo.org> ucspi-tcp-0.88-r16.ebuild:
Stable on ppc64
diff --git a/sys-apps/ucspi-tcp/files/0.88-exit.patch b/sys-apps/ucspi-tcp/files/0.88-exit.patch
new file mode 100644
index 000000000000..4925441b49d2
--- /dev/null
+++ b/sys-apps/ucspi-tcp/files/0.88-exit.patch
@@ -0,0 +1,10 @@
+Index: ucspi-tcp-0.88/tcprulescheck.c
+===================================================================
+--- ucspi-tcp-0.88.orig/tcprulescheck.c
++++ ucspi-tcp-0.88/tcprulescheck.c
+@@ -1,3 +1,5 @@
++#include <unistd.h>
++
+ #include "byte.h"
+ #include "buffer.h"
+ #include "strerr.h"
diff --git a/sys-apps/ucspi-tcp/ucspi-tcp-0.88-r17.ebuild b/sys-apps/ucspi-tcp/ucspi-tcp-0.88-r17.ebuild
new file mode 100644
index 000000000000..03ff4abcccaa
--- /dev/null
+++ b/sys-apps/ucspi-tcp/ucspi-tcp-0.88-r17.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ucspi-tcp/ucspi-tcp-0.88-r17.ebuild,v 1.1 2008/04/06 16:57:17 hollow Exp $
+
+inherit eutils fixheadtails flag-o-matic qmail
+
+DESCRIPTION="Collection of tools for managing UNIX services"
+HOMEPAGE="http://cr.yp.to/ucspi-tcp.html"
+SRC_URI="
+ http://cr.yp.to/${PN}/${P}.tar.gz
+ mirror://qmail/ucspi-rss.diff
+ http://smarden.org/pape/djb/manpages/${P}-man.tar.gz
+ http://xs3.b92.net/tomislavr/${P}-rblspp.patch
+"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="qmail-spp selinux"
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ !app-doc/ucspi-tcp-man
+ selinux? ( sec-policy/selinux-ucspi-tcp )"
+PROVIDE="virtual/inetd"
+
+pkg_setup() {
+ if [[ -n "${UCSPI_TCP_PATCH_DIR}" ]]; then
+ eerror
+ eerror "The UCSPI_TCP_PATCH_DIR variable for custom patches"
+ eerror "has been removed from ${PN}. If you need custom patches"
+ eerror "you should create a copy of this ebuild in an overlay."
+ eerror
+ die "UCSPI_TCP_PATCH_DIR is not supported anymore"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PV}-errno.patch
+ epatch "${FILESDIR}"/${PV}-exit.patch
+ epatch "${DISTDIR}"/ucspi-rss.diff
+ epatch "${FILESDIR}"/${PV}-rblsmtpd-ignore-on-RELAYCLIENT.patch
+ epatch "${DISTDIR}"/${P}-rblspp.patch
+
+ ht_fix_file Makefile
+
+ # gcc-3.4.5 and other several versions contain a bug on some platforms that
+ # cause this error:
+ # tcpserver: fatal: temporarily unable to figure out IP address for 0.0.0.0: file does not exist
+ # To work around this, we use -O1 here instead.
+ replace-flags -O? -O1
+
+ qmail_set_cc
+ echo "/usr/" > conf-home
+
+ # allow larger responses
+ sed -i -e 's|if (text.len > 200) text.len = 200;|if (text.len > 500) text.len = 500;|g' \
+ rblsmtpd.c rblspp.c
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin tcpserver tcprules tcprulescheck argv0 recordio tcpclient *\@ \
+ tcpcat mconnect mconnect-io addcr delcr fixcrio rblsmtpd || die
+
+ if use qmail-spp; then
+ insinto "${QMAIL_HOME}"/plugins
+ insopts -m 755
+ doins rblspp
+ fi
+
+ doman "${WORKDIR}"/${P}-man/*.[1-8]
+ dodoc CHANGES FILES README SYSDEPS TARGETS TODO VERSION
+
+ insinto /etc/tcprules.d/
+ newins "${FILESDIR}"/tcprules-Makefile Makefile
+}
+
+pkg_postinst() {
+ einfo
+ einfo "We have started a move to get all tcprules files into"
+ einfo "/etc/tcprules.d/, where we have provided a Makefile to"
+ einfo "easily update the CDB file."
+ einfo
+}