summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-04-12 20:39:04 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-04-12 20:39:04 +0000
commit003ce76390d5fc8859eea3dc9522365333ca253d (patch)
treec91cef5bc9432fcdc3e2366e77a4bc8c49879540 /sys-apps/x86info
parentStable on sparc, bug #260063 (diff)
downloadgentoo-2-003ce76390d5fc8859eea3dc9522365333ca253d.tar.gz
gentoo-2-003ce76390d5fc8859eea3dc9522365333ca253d.tar.bz2
gentoo-2-003ce76390d5fc8859eea3dc9522365333ca253d.zip
Bug #214034: modprobe.d conversion, patch thanks to Victor Ostorga <vostorga@gmail.com>.
(Portage version: 2.2_rc27/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/x86info')
-rw-r--r--sys-apps/x86info/ChangeLog9
-rw-r--r--sys-apps/x86info/x86info-1.24-r1.ebuild56
2 files changed, 64 insertions, 1 deletions
diff --git a/sys-apps/x86info/ChangeLog b/sys-apps/x86info/ChangeLog
index 1af124ef8829..5aac8a3d954c 100644
--- a/sys-apps/x86info/ChangeLog
+++ b/sys-apps/x86info/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/x86info
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.22 2009/02/11 00:13:35 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.23 2009/04/12 20:39:04 robbat2 Exp $
+
+*x86info-1.24-r1 (12 Apr 2009)
+
+ 12 Apr 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +x86info-1.24-r1.ebuild:
+ Bug #214034: modprobe.d conversion, patch thanks to Victor Ostorga
+ <vostorga@gmail.com>.
*x86info-1.24 (11 Feb 2009)
diff --git a/sys-apps/x86info/x86info-1.24-r1.ebuild b/sys-apps/x86info/x86info-1.24-r1.ebuild
new file mode 100644
index 000000000000..fadce9f8a3b0
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.24-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.24-r1.ebuild,v 1.1 2009/04/12 20:39:04 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+SRC_URI="http://www.codemonkey.org.uk/projects/x86info/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/1.21-pic.patch
+}
+
+src_compile() {
+ emake x86info CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+pkg_preinst() {
+ if [[ -a /etc/modules.d/x86info ]] && [[ ! -a /etc/modprobe.d/x86info ]]; then
+ elog "Moving old x86info configuration in modules.d to new"
+ elog "location in modprobe.d in /etc/"
+ mv "${ROOT}/etc/modules.d/x86info" "${ROOT}/etc/modprobe.d/x86info"
+ fi
+}
+
+src_install() {
+ dobin x86info || die
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/x86info-modules.conf-rc x86info
+
+ dodoc TODO README ChangeLog
+ doman x86info.1
+ insinto /usr/share/doc/${PF}
+ doins -r results
+ prepalldocs
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must be built with the following options"
+ ewarn "set to Y or M"
+ ewarn " Processor type and features ->"
+ ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
+ ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
+}