summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-10-18 18:13:08 +0000
committerThomas Sachau <tommy@gentoo.org>2009-10-18 18:13:08 +0000
commit331867ddb6b690bfdfe9eceeed66340f611a33f8 (patch)
treeed00c0518d164f0ddeab33faa8bc43f03ee479f0 /sys-apps
parentx86 stable, bug #287697 (diff)
downloadgentoo-2-331867ddb6b690bfdfe9eceeed66340f611a33f8.tar.gz
gentoo-2-331867ddb6b690bfdfe9eceeed66340f611a33f8.tar.bz2
gentoo-2-331867ddb6b690bfdfe9eceeed66340f611a33f8.zip
Set ABI dependent vars at the beginning of each src_* function needing them, fixes bug #289314
(Portage version: 2.2_rc46-r1/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/openrc/ChangeLog7
-rw-r--r--sys-apps/openrc/openrc-0.5.1-r1.ebuild15
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild15
3 files changed, 22 insertions, 15 deletions
diff --git a/sys-apps/openrc/ChangeLog b/sys-apps/openrc/ChangeLog
index d1133f19ed1d..66e185bd31ae 100644
--- a/sys-apps/openrc/ChangeLog
+++ b/sys-apps/openrc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/openrc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.84 2009/10/16 07:21:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.85 2009/10/18 18:13:08 tommy Exp $
+
+ 18 Oct 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ openrc-0.5.1-r1.ebuild, openrc-9999.ebuild:
+ Set ABI dependent vars at the beginning of each src_* function needing
+ them, fixes bug #289314
16 Oct 2009; Mike Frysinger <vapier@gentoo.org> openrc-0.5.1-r1.ebuild,
openrc-9999.ebuild:
diff --git a/sys-apps/openrc/openrc-0.5.1-r1.ebuild b/sys-apps/openrc/openrc-0.5.1-r1.ebuild
index faa68c57744c..803fbc240df3 100644
--- a/sys-apps/openrc/openrc-0.5.1-r1.ebuild
+++ b/sys-apps/openrc/openrc-0.5.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.5.1-r1.ebuild,v 1.4 2009/10/16 07:21:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.5.1-r1.ebuild,v 1.5 2009/10/18 18:13:08 tommy Exp $
EAPI="1"
@@ -37,7 +37,7 @@ RDEPEND="virtual/init
DEPEND="${RDEPEND}
virtual/os-headers"
-pkg_setup() {
+make_args() {
unset LIBDIR #266688
MAKE_ARGS="${MAKE_ARGS} LIBNAME=$(get_libdir) LIBEXECDIR=/$(get_libdir)/rc"
@@ -52,7 +52,9 @@ pkg_setup() {
brand="FreeBSD"
fi
export BRANDING="Gentoo ${brand}"
+}
+pkg_setup() {
export DEBUG=$(usev debug)
export MKPAM=$(usev pam)
export MKTERMCAP=$(usev ncurses)
@@ -74,10 +76,7 @@ src_unpack() {
}
src_compile() {
- # catch people running `ebuild` w/out setup
- if [[ -z ${MAKE_ARGS} ]] ; then
- die "Your MAKE_ARGS is empty ... are you running 'ebuild' but forgot to execute 'setup' ?"
- fi
+ make_args
if [[ ${PV} == "9999" ]] ; then
local ver="git-$(echo ${EGIT_VERSION} | cut -c1-8)"
@@ -101,6 +100,7 @@ set_config_yes_no() {
}
src_install() {
+ make_args
emake ${MAKE_ARGS} DESTDIR="${D}" install || die
# move the shared libs back to /usr so ldscript can install
@@ -115,7 +115,8 @@ src_install() {
# Backup our default runlevels
dodir /usr/share/"${PN}"
- mv "${D}"/etc/runlevels "${D}"/usr/share/${PN} || die
+ cp -PR "${D}"/etc/runlevels "${D}"/usr/share/${PN} || die
+ rm -rf "${D}"/etc/runlevels
# Stick with "old" net as the default for now
doconfd conf.d/net || die
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 64d3a4d22639..283478306c62 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.58 2009/10/16 07:21:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.59 2009/10/18 18:13:08 tommy Exp $
EAPI="1"
@@ -37,7 +37,7 @@ RDEPEND="virtual/init
DEPEND="${RDEPEND}
virtual/os-headers"
-pkg_setup() {
+make_args() {
unset LIBDIR #266688
MAKE_ARGS="${MAKE_ARGS} LIBNAME=$(get_libdir) LIBEXECDIR=/$(get_libdir)/rc"
@@ -52,7 +52,9 @@ pkg_setup() {
brand="FreeBSD"
fi
export BRANDING="Gentoo ${brand}"
+}
+pkg_setup() {
export DEBUG=$(usev debug)
export MKPAM=$(usev pam)
export MKTERMCAP=$(usev ncurses)
@@ -74,10 +76,7 @@ src_unpack() {
}
src_compile() {
- # catch people running `ebuild` w/out setup
- if [[ -z ${MAKE_ARGS} ]] ; then
- die "Your MAKE_ARGS is empty ... are you running 'ebuild' but forgot to execute 'setup' ?"
- fi
+ make_args
if [[ ${PV} == "9999" ]] ; then
local ver="git-$(echo ${EGIT_VERSION} | cut -c1-8)"
@@ -101,6 +100,7 @@ set_config_yes_no() {
}
src_install() {
+ make_args
emake ${MAKE_ARGS} DESTDIR="${D}" install || die
# move the shared libs back to /usr so ldscript can install
@@ -115,7 +115,8 @@ src_install() {
# Backup our default runlevels
dodir /usr/share/"${PN}"
- mv "${D}"/etc/runlevels "${D}"/usr/share/${PN} || die
+ cp -PR "${D}"/etc/runlevels "${D}"/usr/share/${PN} || die
+ rm -rf "${D}"/etc/runlevels
# Stick with "old" net as the default for now
doconfd conf.d/net || die